What's new

Windows Consumer Preview - Bugs and Annoyances

Dwarf

The Contemplator, (1963-2013)
Moderator
I thought that I'd create a thread where we can list all bugs and annoyances that we find in WCP. I know that some are listed elsewhere on the Forums, but this should keep them all in one place.

I'll start off with the following:

1) Multiple generic icons (and sometimes folder icons) appear in the Taskbar. When moused over, they are blank and clicking, either on the icon or Taskbar (doesn't matter whether left-click or right-click), removes all of them.


2) Most users like to customize IE so that it automatically adds the suffix of their choice to be appended to the URL when using the Ctrl/Shift/Enter shortcut. For me, this is co.uk. I click on Save, but when I go back, it hasn't saved and the shortcut doesn't work.
 

My Computer

System One

  • OS
    Windows 8.1 Pro RTM x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dwarf Dwf/11/2012 r09/2013
    CPU
    Intel Core-i5-3570K 4-core @ 3.4GHz (Ivy Bridge) (OC 4.2GHz)
    Motherboard
    ASRock Z77 Extreme4-M
    Memory
    4 x 4GB DDR3-1600 Corsair Vengeance CMZ8GX3M2A1600C9B (16GB)
    Graphics Card(s)
    MSI GeForce GTX770 Gaming OC 2GB
    Sound Card
    Realtek High Definition on board solution (ALC 898)
    Monitor(s) Displays
    ViewSonic VA1912w Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    OCZ Agility 3 120GB SATA III x2 (RAID 0)
    Samsung HD501LJ 500GB SATA II x2
    Hitachi HDS721010CLA332 1TB SATA II
    Iomega 1.5TB Ext USB 2.0
    WD 2.0TB Ext USB 3.0
    PSU
    XFX Pro Series 850W Semi-Modular
    Case
    Gigabyte IF233
    Cooling
    1 x 120mm Front Inlet 1 x 120mm Rear Exhaust
    Keyboard
    Microsoft Comfort Curve Keyboard 3000 (USB)
    Mouse
    Microsoft Comfort Mouse 3000 for Business (USB)
    Internet Speed
    NetGear DG834Gv3 ADSL Modem/Router (Ethernet) ~4.0 Mb/sec (O2)
    Browser
    IE 11
    Antivirus
    Avast! 8.0.1497 MalwareBytes 1.75.0.1300
    Other Info
    Optical Drive: HL-DT-ST BD-RE BH10LS30 SATA Bluray
    Lexmark S305 Printer/Scanner/Copier (USB)
    WEI Score: 8.1/8.1/8.5/8.5/8.25
    Asus Eee PC 1011PX Netbook (Windows 7 x86 Starter)

jimbo45

New Member
VIP Member
Guru
Hi there

Two Irritants oherwise overall fine. Actually Irritants rather than Bugs.

One perceived bug.

The Irritants:

1) Cannot Turn Off Automatic Maintenance schedule -- this sometimes activates while you are doing something and can freeze the whole computer for sometimes as much as 5 mins while it's doing goodness knows what.

2) Can't customize the Tiles -- you can move them and remove those you don't want but it's (for a non coding type of person) impossible to change the background or size of Icon on Software installs

For instance I might want Office products EXCEL, WORD and POWERPOINT to have a different Background to say Adobe CS5 5 products like Photoshop.


The Bug

Software UNINSTALL doesn't work properly from the metro screen. If you go into control panel you can usually uninstall Manually via program features in the control panel itself.


Otherwise I'm not complaining -- using it on TWO laptops now as REAL rather than VM's.

Cheers
jimbo
 

My Computer

System One

  • OS
    Linux Centos 7, W8.1, W7, W2K3 Server W10
    Computer type
    PC/Desktop
    Monitor(s) Displays
    1 X LG 40 inch TV
    Hard Drives
    SSD's * 3 (Samsung 840 series) 250 GB
    2 X 3 TB sata
    5 X 1 TB sata
    Internet Speed
    0.12 GB/s (120Mb/s)

brummyfan

Well-Known Member
VIP Member
Guru
You can switch off Automatic Maintenance in Defrag. Capture1.JPG
 

My Computer

System One

  • OS
    Win 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Acer Aspire E1-571
    CPU
    i5-3230m
    Motherboard
    Acer Type-2
    Memory
    8GB DDR3 1333MHz
    Graphics Card(s)
    Intel HD 4000
    Sound Card
    High Definiton Audio Device
    Monitor(s) Displays
    Generic
    Screen Resolution
    1366x768
    Hard Drives
    Samsung 850 Pro 256GB
    PSU
    Generic
    Keyboard
    QWERTY
    Mouse
    ELANTECH Touchpad
    Internet Speed
    12.68Mbps
    Browser
    IE11
    Antivirus
    Windows Defender

pmbAustin

Member
Member
One UI annoyance:

Getting to the PC Settings is pretty unintuitive. It took me a while to figure out that at the BOTTOM of the Charms Bar, there's a little blue bit of text "More PC Settings" that takes me to what is essentially the Metro control panel. Getting to the Desktop Control Panel is, by comparison, very easy. It seems that "PC Settings" should be up at the top with all the other app-specific settings. With an ICON. Or better yet, how about two charms (ther'es plenty of room): One for "Current App Settings" and one for "Global PC Settings"? It would also be nice if there was a simple way to flip back and forth between the PC Settings (Metro) and the Control Panel (desktop).
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview
    System Manufacturer/Model
    Dell XPS 15z
    CPU
    Intel Core i5
    Memory
    6GB

stevieray

Member
VIP Member
Member
1) Multiple generic icons (and sometimes folder icons) appear in the Taskbar. When moused over, they are blank and clicking, either on the icon or Taskbar (doesn't matter whether left-click or right-click), removes all of them.

I was just about to post a new thread about this problem. Sometimes I have had 5 or 6 of them, all blank, lined up across my taskbar. I was trying to grab a snip of them, but naturally opening the snipping tool made them go away... :p
 

My Computer

System One

  • OS
    W7x64, W8CP x64
    System Manufacturer/Model
    home made
    CPU
    Intel Q6600
    Motherboard
    Gigabyte EP45-UD3L
    Memory
    g.skill ddr2 1066 8 gigs
    Graphics Card(s)
    nVidia GeForce 9800 GTX+
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680 x 1050
    Hard Drives
    WD Caviar Black 500Gb
    WD Caviar Black 1Tb
    2 x WD Elements 1Tb external

stevieray

Member
VIP Member
Member
If there is a way to do the following, I haven't found it...

Bug: Once a Windows Live ID and email account has been associated with a User Account during Set Up it can't be changed. Out here in the real world, people WILL have to change Live IDs and email accounts sometimes.

This leaves a user with only a few ugly options: having to sign in multiple times (first to your user account and then again to your new Live ID to use apps), create a whole new user account (and spend days recreating your original look and feel, copying profiles over, getting personalizations into the new account, etc...) or do a fresh installation (and still have to copy profiles, set up personalizations, etc...).

This is a show stopper. Average users will NOT know how to do most of that, and will resent having to spend hours or days doing it. Make the Live ID changeable or you will get nothing but grief.
 
Last edited:

My Computer

System One

  • OS
    W7x64, W8CP x64
    System Manufacturer/Model
    home made
    CPU
    Intel Q6600
    Motherboard
    Gigabyte EP45-UD3L
    Memory
    g.skill ddr2 1066 8 gigs
    Graphics Card(s)
    nVidia GeForce 9800 GTX+
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680 x 1050
    Hard Drives
    WD Caviar Black 500Gb
    WD Caviar Black 1Tb
    2 x WD Elements 1Tb external

denni

New Member
My WCP build 8250 cannot read DVD drive, but it looks OK in my second OS (Win 7)
 

My Computer

System One

  • OS
    Dual boot: Windows 7 & 8
    CPU
    i7 3930K
    Motherboard
    MSI X79A-GD65D (8D)
    Memory
    4 x 4 GB Corsair
    Graphics Card(s)
    MSI GTS 450 Cyclone

Phone Man

Retired Bell Head
VIP Member
Pro User
Lots of errors in Event Viewer. Have you checked yours.

Jim :geek:
 

My Computer

System One

  • OS
    Windows 7 HP 64bit, Windows 8.1 Pro w/Media Center 64BIT
    Computer type
    PC/Desktop
    System Manufacturer/Model
    ASUS - Home Built
    CPU
    AMD Phenom II X6 1100T
    Motherboard
    ASUS M5A99X EVO
    Memory
    Crucial Balistic DDR-3 1866 CL 9 (8 GB)
    Graphics Card(s)
    MSI R6850 Cyclone IGD5 PE
    Sound Card
    On Chip
    Monitor(s) Displays
    ASUS VE258Q 25" LED with DVI-HDMI-DisplayPort
    Screen Resolution
    1920 x 1080
    Hard Drives
    Two WD Cavier Black 2TB Sata 6gbs
    WD My Book Essential 2TB USB 3.0
    PSU
    Seasonic X650 80 Plus GOLD Modular
    Case
    Corsair 400R
    Cooling
    Antec Kuhler H2O 620, Two 120mm and four 140mm
    Keyboard
    AVS Gear Blue LED Backlight
    Mouse
    Logitech Marble Mouse USB, Logitech Precision Game Pad
    Internet Speed
    15MB
    Antivirus
    NIS, Malwarebytes Premium 2
    Other Info
    APC UPS ES 750, Netgear WNR3500L Gigabit & Wireless N Router with SamKnows Test Program,
    Motorola SB6120 Gigabit Cable Modem.
    Brother HL-2170W Laser Printer,
    Epson V300 Scanner

whs

New Member
VIP Member
Guru
I cannot get rid of the password. With every boot I need to put a password in. I never use passwords on my other systems. And in Control Panel\User Accounts and Family Safety\User Accounts there is no 'Change Password' option.
 

My Computer

System One

  • OS
    Vista and Win7
    System Manufacturer/Model
    2xHP, 2xGateway, 1xDell, 1xSony
    Hard Drives
    5 SSDs and 12 HDs

brummyfan

Well-Known Member
VIP Member
Guru

My Computer

System One

  • OS
    Win 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Acer Aspire E1-571
    CPU
    i5-3230m
    Motherboard
    Acer Type-2
    Memory
    8GB DDR3 1333MHz
    Graphics Card(s)
    Intel HD 4000
    Sound Card
    High Definiton Audio Device
    Monitor(s) Displays
    Generic
    Screen Resolution
    1366x768
    Hard Drives
    Samsung 850 Pro 256GB
    PSU
    Generic
    Keyboard
    QWERTY
    Mouse
    ELANTECH Touchpad
    Internet Speed
    12.68Mbps
    Browser
    IE11
    Antivirus
    Windows Defender

pmbAustin

Member
Member
Metro Scroll Bars when using trackpad or mouse:

In applications like IE, where there is a long page to read, I like to park the mouse cursor over the scroll bar (or arrow at the bottom), and just click to page down (or line down) as I read.

The problem with this is that in Windows 8 Metro, if the mouse pointer doesn't move, after a while the scrollbar fades out and disappears... meaning my clicks suddenly do nothing. I have to move the mouse out of the scrollbar and back in to get it to re-appear so that i can continue to scroll down as I read.

This is very annoying.

Proposed Solution: As long as the mouse pointer is over the scroll bar, don't let it fade/disappear. It should stay visible the entire time the mouse is over it.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview
    System Manufacturer/Model
    Dell XPS 15z
    CPU
    Intel Core i5
    Memory
    6GB

whs

New Member
VIP Member
Guru
Yeah, I did that once and ended up with a mess. My password would not work any more. In hindsight I think because the num lock was turned on somewhere in the process (I did not have a seperate num pad). I would prefer to get rid of the password all together. And thanks for reminding me of that possibility.
 

My Computer

System One

  • OS
    Vista and Win7
    System Manufacturer/Model
    2xHP, 2xGateway, 1xDell, 1xSony
    Hard Drives
    5 SSDs and 12 HDs

SmartEyeball

No. 14
Team Member
VIP Member
Pro User
The xbox companion 'not supported' in my region. One of the few apps that might have been useful to me

As much as I like the new Task Manager, not being being able to see exactly how many processes are running in task manager is kind of annoying.

Not being able to add functions to the lower left right-click admin panel.


Finding a function then losing the damn thing again. It's an odd learning curve.








Lots of errors in Event Viewer. Have you checked yours.

Jim :geek:

Yes. Lot's of new errors to decipher :p
 

My Computer

System One

  • OS
    Vanilla 8 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    SmartEyeball Custom Systems
    CPU
    Intel 3770K @4.8ghz
    Motherboard
    ASUS P8Z77 WS
    Memory
    16GB G.Skill Trident 2666mhz
    Graphics Card(s)
    3x Gigabyte GTX 670 OC WindForce SLI
    Sound Card
    SB X-FI Surround 5.1 PRO USB + ATH-AD900 Headphones
    Monitor(s) Displays
    x3 Dell U2410 / 58" Samsung / "40 Sony
    Screen Resolution
    5760*1200/1920*1200 / 1920*1080
    Hard Drives
    2x Intel 520 240GB * Crucial M4 128GB * 2x Samsung F3 1TB (RAID 0) * 2x WD Caviar Blacks 2TB (RAID 0)
    PSU
    Corsair AX1200
    Case
    Thermaltake Level 10 GT Snow Edition
    Cooling
    Noctua NH-D14
    Keyboard
    Topre Realforce // Ducky Shine MX Black // Filco Ninja TKL
    Mouse
    Razer Imperator + Thermaltake Theron
    Other Info
    Laptop Specs: Clevo Sager P170HM // 17.3 Matte 1920x1200 // i7 2720QM // 8GB 1333mhz // Dedicated GTX 485M // 240GB Intel 520 + 750GB + Blu-Ray // Samsung Story 2TB USB 3.0 // NexStar USB 3.0 enclosure 500GB

Night Hawk

New Member
VIP Member
Member
Besides the Metro UI work around of clicking the desktop button each startup the new lock screen is one large annoyance without any autologin to desktop method or option found as of yet.

Shutdown or restart is even worse with the need to logoff first to unlock the lock screen one more time and then click on the tool gear wheel icon to restart.

The lack of a Start button was a simple add a new toolbar onto the taskbar selecting "C:\ProgramData\Microsoft\Windows\Start\Programs\" as the selected folder.

What many will find baffling is the change in the repair tools when booted live from the USB Install Key or 8 dvd used! If you set up a dual boot but keep the present host/OS drive unplugged to see 8 go on as a stand alone and then go to use a program like EasyBCD to add a new boot entry into Vista or 7 BCD store you will need to use the 8 version of the Startup repair tool or see "winloader.exe missing".

The big annoyance at finding the renamed Startup repair option is finding a totally new layout for the repair AND other options now found in the additional screens added! And no you still won't find Startup repair but "Automatic repair" instead. Have a look!

Repair Tools and Options 1.jpg

You still see the repair options link under the Install Now button as expected. But wait until what? No OS detected and selected before arriving at a menu of options?

Repair Tools and Options 2.jpg

Continue, User another OS, Turn off your PC, and Troubleshoot are what you find instead. So naturally you select the Troubleshoot option but find yourself looking at...

Repair Tools and Options 3.jpg

Refresh your PC? sounds like an Upgrade to repair option for an OEM machine. Reset your PC wiping all files out suggests a full clean install or recovery, and one more Advanced option...

Repair Tools and Options 4.jpg

And finally you arrive at a screen with some familiar items seen on it! System Restore, System image Recovery for restoration of a full system image, command prompt, and what? no Startup but Automatic Repair is now seen for any startup issues only after you go through the extra screens to find what you were looking for was renamed.
 

My Computer

System One

  • OS
    1st W10 Professional x64/W7 Ultimate x64 - 2nd Remote system: W10 Insider Builds/W7 Professional
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom Builds
    CPU
    AMD Phenom II X4 975 Deneb 3.6ghz -2nd case AMD Atholon II 3.2ghz
    Motherboard
    Gigabyte GA-790XTA-UD4
    Memory
    Kingston Hyper-X DDR3 1600mhz 16gb - 2nd case Kingston Hyper-X "Fury" DDR3 1600mhz 8gb
    Graphics Card(s)
    MSI Radeon HD 5750 1gb - 2nd AMD Radeon 6450
    Sound Card
    Creative Xtreme Gamer - 2nd case Realtek Onboard audio
    Monitor(s) Displays
    Acer 19" dual monitor setup - 2nd case HP 20" lcd
    Screen Resolution
    1440x900 same on both builds
    Hard Drives
    1st build
    WD Caviar Black Edition Sata II 1tb two OS drives
    WD RE "Heavy Duty Sata II 2tb two Storage/Backup
    2nd build
    WD Blue Sata II 500gb
    WD Black Edition Sata III 1tb
    WD Green Power Sata II 1tb in external usb enclosure
    PSU
    Corsair TX750H 750w -Corsair 500w
    Case
    Antec 900-2 -NXZT Vulcan Mini tower/carrying handle
    Cooling
    120mm front pair, 120 rear 200cm top - 120mm Front intake 200mm side cover
    Keyboard
    Azio Blue led back lit both builds.
    Mouse
    MSI DS200 11 button programmable Gaming optical mouse - Odessa 3 button dual scroll trackball
    Internet Speed
    30mbps
    Other Info
    two MSI 22x ide dvd burners, 25 usb flash drives used for Linux Live, live data recovery 128gb, and Windows 7, 10 usb installation keys

whs

New Member
VIP Member
Guru
I am not sure whether those are many errors - but yes, there is a good number.

2012-03-06_2357.png

2012-03-06_2359.png
 

My Computer

System One

  • OS
    Vista and Win7
    System Manufacturer/Model
    2xHP, 2xGateway, 1xDell, 1xSony
    Hard Drives
    5 SSDs and 12 HDs

electricbluej77

New Member
Keep in mind this is a preview (beta) operating system so there is bound to be a few more errors then Windows 7. however I am used to the metro UI now after 1 day and have it set so that on boot, I am auto logged in and after a few seconds the desktop comes up after seeing the metro UI. which by then everything is loaded and ready to go. from turning my laptop to the desktop being viewable is done in 32 seconds. Windows XP still took over a minute (same programs) and Windows 7 took 55 seconds, however could also be that they were 32-bit, whereas Windows 8, I installed the 64-bit edition. and it is going very well. no blue screens or errors, maybe an odd bug here and there that's not really noticed by me any-way. Also battery life is a good 25~ minutes more then XP/7. so that's good. Windows 8 CP even though it is a preview/beta, it is more then ready for the general user in my opinion as long as you can get used to the metro UI, however I do agree in saying they never should of removed the start menu, they should have an option in the final to choose between metro and start as the defaults, maybe add this to the installer somehow. although even if they don't, I think someone would code an installer and add this option as a mod any-way. any-way that's just my 5 cents. :)
 

My Computer

System One

  • OS
    Windows 8 CP 64bit
    System Manufacturer/Model
    Acer Emachine
    Graphics Card(s)
    Intel

whs

New Member
VIP Member
Guru
Yeah, the boot is really fast. 8 seconds in Virtual box and I am on the desktop. I automated sign-in and boot directly to the desktop. Have to time it on my laptop where it is in a dual boot.
 

My Computer

System One

  • OS
    Vista and Win7
    System Manufacturer/Model
    2xHP, 2xGateway, 1xDell, 1xSony
    Hard Drives
    5 SSDs and 12 HDs

Night Hawk

New Member
VIP Member
Member
That's on a VM however not the install to HD as you still have to unlock the lock screen and type in the password, click arrow to arrive at Start screen first. But then you simply click the desktop shortcut which is minor but annoying still.

So far no automatic login options have been found in the CP>System>Advanced while a new reg value similar to what was seen with XP is a thought. That would have to come later however once more is learned about the final not CP version we see now.

There will likely be more then one 3rd party tool available as well as one company is working on a Start8 utility still not available to solve the lack of Start menu which has been a concern.
 

My Computer

System One

  • OS
    1st W10 Professional x64/W7 Ultimate x64 - 2nd Remote system: W10 Insider Builds/W7 Professional
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom Builds
    CPU
    AMD Phenom II X4 975 Deneb 3.6ghz -2nd case AMD Atholon II 3.2ghz
    Motherboard
    Gigabyte GA-790XTA-UD4
    Memory
    Kingston Hyper-X DDR3 1600mhz 16gb - 2nd case Kingston Hyper-X "Fury" DDR3 1600mhz 8gb
    Graphics Card(s)
    MSI Radeon HD 5750 1gb - 2nd AMD Radeon 6450
    Sound Card
    Creative Xtreme Gamer - 2nd case Realtek Onboard audio
    Monitor(s) Displays
    Acer 19" dual monitor setup - 2nd case HP 20" lcd
    Screen Resolution
    1440x900 same on both builds
    Hard Drives
    1st build
    WD Caviar Black Edition Sata II 1tb two OS drives
    WD RE "Heavy Duty Sata II 2tb two Storage/Backup
    2nd build
    WD Blue Sata II 500gb
    WD Black Edition Sata III 1tb
    WD Green Power Sata II 1tb in external usb enclosure
    PSU
    Corsair TX750H 750w -Corsair 500w
    Case
    Antec 900-2 -NXZT Vulcan Mini tower/carrying handle
    Cooling
    120mm front pair, 120 rear 200cm top - 120mm Front intake 200mm side cover
    Keyboard
    Azio Blue led back lit both builds.
    Mouse
    MSI DS200 11 button programmable Gaming optical mouse - Odessa 3 button dual scroll trackball
    Internet Speed
    30mbps
    Other Info
    two MSI 22x ide dvd burners, 25 usb flash drives used for Linux Live, live data recovery 128gb, and Windows 7, 10 usb installation keys
Top