Windows cannot access \\COMPUTER-1 - sharing problem


New Member
Hello guys,

I have 4 PC's at my home, they can all access each other pretty well, except the main computer, COMPUTER-1 which can easily access other computers, but when I try to access it on the network, I get:

"windows cannot access \\COMPUTER-1
error code 0x80070035"

I then click to Diagnose or just wait for about 2 minutes, and eventually I CAN access \\COMPUTER-1 over the network. I have also noticed that in my Advanced Sharing options for a private network, "Turn On Network Discovery" will not save. I have searched and read many posts about this issue and tried things like doing scans, Auto starting services, rebooting, disabling the windows firewall completely, but it makes no difference.

It seems like a bit of a clue that the network DOES appear after a couple of minutes. Any help much appreciated!


My Computer

System One

  • OS
It helps to know what Internet Security software you are using.

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    System Manufacturer/Model
    Toshiba Satellite C850D-st3nx1
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Google Chrome
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.
error code 0x80070035
You should enable windows firewall and import predefined rules for:
1.Network and sharing center
2.Core Networking
3.File and printer sharing
4.Network discovery

Also following services need to run:
1.Peer grouping
2.Function discovery provider host
3.Function discovery resource publication
4.Home group provider
5.Peer networking grouping
6.Peer name resolution protocol
7.SSDP discovery
8.PNRP Machine name publication service
9. TCP/IP netbios helper
and few others which are probably already running

Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings:
Turn on network discovery
turn on file and printer sharing
allow windows to manage homegroup

Adapter settings:
Client for Microsoft networks
File and printer sharing for MS networks
Link layer topology discovery (both)

Network profile:

My Computer

System One

  • OS
    Windows 8.1 Enterprise

I did all those things, except the firewall rules which already existed, rebooted twice and it works!
In advanced sharing I can now choose to have Network Discovery ON... GREAT.
I did not need to set the computer from password to Homegroup, it works fine keeping it with password access.

Thanks for the help.
The list you had of services which should be Automatically started instead of disabled was slightly different from the lists I have seen elsewhere on the web, so it may be your list alone or a combination that did it, but it does seem to be the services that needed to be enabled/auto started instead of disabled.

Thanks again
Last edited:

My Computer

System One

  • OS