What's new

Windows boot manager and error 0xC000000F & Much More!


New Member
I can't boot into Windows. I don't want to have to restore the computer to factory settings and lose all my data. This all started with Windows updates that failed to install. I could not get into Safe Mode and tried several things as I mention below, including using the software of Easy Recovery Essentials, which made things worse. I emailed NeoSmart twice and have gotten no response.

Other than restoring the computer to factory default, is there another option, such as getting the Windows ISO and reinstalling Windows?

Here is what occurred in full detail.

I decided a few weeks ago to download multiple Windows updates. Most of them were installed, but to complete the installation for some of them, Windows said it needed to be restarted. Because I had multiple programs, folders, and files opened, I chose not to restart my computer then. I decided this past Saturday to finally restart my computer so that these updates can be applied. I was closing open files, folders, and programs. This was taking a long time because I had multiple things open and also because the computer was running sluggishly. After having a majority of things closed, I got impatient and decided to hold down the power button to shut off the computer. I turned the computer back on and windows began to apply the updates prior to fully booting up (I'm referring to the blue screen that shows the percentage of an update or updates being applied before one is taken to the desktop). Windows then showed a message that it was unable to apply the updates and it began to uninstall / remove the updates (to be specific, it said "We couldn’t complete the updates. Undoing changes”). This was however taking a while (it seemed to be stuck) and despite the message of not to turn off one's computer, I decided to go ahead and shut off the computer by holding down the power button. When I powered it up again Windows began trying to install the updates, wasn't able to, and began uninstalling the updates once more, and it seemed to hung again. So once again I turned off the computer and powered it back on. At times I would get a message regarding winload.efi. file being missing or containing errors. In addition to this, I would be shown a blue screen with the message referring to error code 0xc000021a after windows would try to load / after showing the screen with the Toshiba logo and the spinning dots at the bottom for a long time.

I tried various options from the Windows 8.1 Recovery environment via a recovery disk I created when I first setup the computer and other times from the computer itself, as both sources seem to provide the same set of options. Automatic repair would fail and refreshing the PC was not possible because I would get the error message of "The drive where Windows is installed is locked. Unlock the drive and try again". I tried system restore to a few days ago, and after that didn't work, to a few weeks ago. Though the process would complete, I still could not boot into windows. I tried rebuilding bcd commands, deleting the hiberfil.sys file, running chkdsk, and so on: basically just about everything here I have tried: https://www.winhelp.us/repair-your-computer-in-windows-8.html I believe rebuilding the BCD is what got rid of the winload.efi message. Note that in advanced options, I am not shown the option of Startup Settings, which is why I couldn't get into Safe Mode. I read somewhere that this option is not shown when using the Recovery Environment from a DVD or USB flash drive, but it is also not shown when I am accessing the Recovery environment from the internal hard drive. The only way I can access startup settings is when the computer fails to start several times and I am then presented with the Recovery screen that shows the 0xc0000001 error message, where I can choose to either "Press Enter to try again", "Press F8 for startup settings", or "Press Esc for UEFI Firmware Settings". If I choose Startup Settings, I can't get into Safe Mode.

Installing and Running Easy Recovery Essentials & What Ensued Afterward:

So, as a last resort I decided to purchase Easy Recovery Essentials from NeoSmart. I downloaded it using another computer, but because it doesn't have a DVD drive, I had to install it to a USB drive. If it did have a DVD drive, I could have burned the image to DVD because I was able to boot to DVD discs without changing anything in the BIOS. After installing the Easy Recovery Essentials software to the USB flash drive, I couldn't boot from it on my Toshiba laptop. I formatted the flash drive on the other computer and reinstalled the program to it again, but still couldn't boot from it. I changed the Boot Mode in the BIOS of the Toshiba laptop from UEFI Boot to CSM Boot. This then enabled the option of "SATA controller mode" to be visible, and for some reason I changed the option from AHCI to Compatible. I was now able to boot from the USB flash drive. I ran the automatic repair option from the Easy Recovery Essentials Program.

However, this is now the end result:

  1. If I change the boot mode in the BIOS back to UEFI, Windows will not load at all. On the first screen I am shown the words "Toshiba Leading Innovation >>>" in the middle (split across two lines), and then I am taken to another screen that shows a message of ."Checking media [fail]", Checking Media, and then to another black screen with the message in white letters of "No bootable device -- Please restart system".
  2. The only way to get a bit further into the booting process is to now leave the boot mode as CSM.
    1. I am shown the same first screen as above ( the words "Toshiba Leading Innovation >>>" in the middle (split across two lines))
    2. I am then taken to a 2nd screen showing the Windows logo and the spinning dots at the bottom followed by a blue screen with an error message, as described in number 3 below. This is the same problem as before (practically from the beginning), with the exception of instead being shown the word/logo of Toshiba, I am now shown the Windows logo!
    3. Third Screen:
      1. This (the display of the third screen) happens rather quickly if I have the "SATA controller mode" set to Compatibility. When I do, on
        1. the third screen I am taken to blue screen with the message of Your PC ran into a problem and needs to restart. We're just collecting some error info, and then you can restart (0% complete), and on the bottom it reads "If you'd like to know more, you can search online later for this error: INACCESSIBLE_BOOT_DEVICE.", and the percentage complete does not change. It stays stuck at 0 and after about a minute or two, the computer restarts itself, and the same process is repeated.
      2. If the "SATA controller mode" isset to AHCI in the BIOS,
        1. the second screen with the Windows logo and the spinning dots are shown for a long time, and then I am finally taken to third screen, which shows the message of "We're just collecting some error info, and then you can restart (0% complete), and on the bottom it reads "If you'd like to know more, you can search online later for this error: 0xc000021a.", and the percentage complete reaches 100. and after a while, the computer restarts itself, and the same process is repeated.
What occurs in Step 2.3.2 is exactly what was happening before (staying on the screen with the spinning dots for a long time before taken to a blue screen with the 0xc000021a error message), with the exception of that instead of being shown the Toshiba word, I am now shown the Windows logo.

However, other things are now made worse!

  • Holding down 0 (zero) no longer takes me to the Recovery Screen. Nothing happens / the command is ignored. [CSM Boot / AHCI]
  • I was having problems earlier booting up from the Recovery DVD. I now can. I am using the CSM Boot / AHCI settings. Maybe before I was using CSM Boot / Compatibility. Since I was able to do this, I went ahead and chose the Automatic Repair option and despite being shown less options and it only showing me the OS of Microsoft Windows instead of Windows 8, I still foolishly went ahead and did the automatic repair. Now when I start up the computer, I am immediately shown a message about the Windows boot manager and error
I decided to re-run Easy Recovery Essentials from the USB flash drive and run the Automated repair, but it said it was unable to complete the repair and to check the logs. It also discovered less hard drives (really partitions, as there is only one drive) than it did the first time I ran this tool.

When I go to Browse/Backup Files, I see two folders under My Computer. One with a name of "Unknown Windows (C:)" with a file size of 128.00 MB and another with a name of "Windows 8.1 (D:)" with a file size of 686.19 GB. This is the actual Windows directory I have concluded based on the name and size of the folder, and it should have the drive letter of C: Opening either folder results in NO files or folders being shown in them!

It seems like Easy Recovery Essentials gets confused when I put the computer in CSM / AHCI OR CSM / Compatibility mode as it thinks the computer will stay in either one of those states and does not realize that I will be switching it back to UEFI.

I really hope someone can provide me with a solution to this nightmare!

My Computer

System One

  • OS
    Windows 8

Users Who Are Viewing This Thread (Users: 0, Guests: 1)