• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows 8 Showing wireless network but not able to connect


astock

New Member
Posts
12
#1
Hey there,

I have a lenovo ideapad z580 with windows 8 that I've had for about 8 months. It would occasionally drop wifi, but usually I could just reset the wireless adapter or unplug and refresh my router and everything would go back to normal. Yesterday my wireless dropped and I feel like I have tried just about everything but can't get it back! I've uninstalled and reinstalled the wireless adapter, reverted the system to a previous version, cleared the dns cache, disabled the bluetooth driver, updated the driver for the wireless adapter, deleted and readded the profile, and still nothing. I also tried going into services and manuarlly turning on the Wireless PAN DHCP server but get error 1067: The process terminated unexpectedly.
When I troubleshoot, it either says I have not chosen to connect to any wireless networks (even though I have), let's me select my network (which shows 5 bars) and then says can't connect. I ran the Intel PROset wireless diagnostics tool and I seem to keep failing the association test, but I can't figure out how to get around that. I ran ipconfig/all and for both the wireless lan adapter local area connection and the wireless LAN adapter WIFI it says the media is disconnected (not sure if that matters.)
I am able to get to internet when I plug in ethernet, but as I travel a lot, that's not really a long term solution. I know I can get a USB wireless adapter but I would love to figure out what is natively wrong. Any help or suggestions would be greatly appreciated!!
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

Harrylowt

New Member
Pro User
UK

Posts
333
#2
I think you need to be trying this with out the Intel PROset Wireless application.

You are able to uninstall the Intel PROset application but this does i believe come bundled with the driver.

1. First up download the Driver with out the Intel software:

Windows 8:
https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23492&lang=eng

Windows 8.1:
https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23493&lang=eng



2. Then you will want to unstinall the Intel PROSet Wireless application from Add and remove hardware.

:winkey: + R
Types "Appwiz.cpl", click "Ok"
Then uninstall Intel PROSet

3. I then recommend you turn off automatic driver installation:
Drivers - Turn Off Automatic Driver Installation - Windows 7 Help Forums

4. install the Wireless Driver you downloaded earlier.

Give that a try and post results back.

Cheers,
Harry
 

My Computer

System One

  • OS
    Windows Server 2012 R2 / 8.1

astock

New Member
Posts
12
#3
Hey there - Thanks for replying! Now unfortunately when I tried to connect with the ethernet cable, I still can't access the internet. It says it's connected, but when I go to a browser I can't connect. I ran diagnostics and got a message that says, "Your computer appears to be correctly configured but the device or resource is not responding."
Of course I can't see the additional help, because it's online. Shoot. Any thoughts? Should I still uninstall the Intel PROset wireless app?
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

Harrylowt

New Member
Pro User
UK

Posts
333
#4
ok

keep the LAN cable

IF you bring up task manager

1. CTRL + Shiift + ESC

2. Click "More Details"

3. Click "Performance", Can you see any data throughput in your Ethernet adapter?


Could you please check if you computer is set to DHCP:

1. Navigate to “Control panel” Now click “Network and Internet”,click “Network and Sharing Center”, click “Change Adapter Settings”

2. Right click the desired connection you want to change and click “Properties”

3. Navigate to and click “Internet Protocol Version 4(TCP/IPv4)”, click “Properties”

Select the top radio buttons on each selection so it looks like this:

Screen Shot 2014-02-15 at 15.27.01.png

Note: if it was not already set to DHCP run the Network troubleshooter:

In the action tray buttom right of the taskbar right click the LAN icon and click “Troubleshoot Problems”
Screen Shot 2014-02-15 at 15.38.29.png


If that was not the problem bring up an elevated cmd prompt:

:winkey:+ X
:winkey:+ A
type:
"ipconfig /all" - Press enter
Please posts results

Then please type these separate commands:
"ipconfig /release" - press enter
"ipconfig /renew" - press enter
"Ipconfig /flushdns" - press enter

Restart computer.

Try that and then come back to me.

Cheers,
Harry
 

My Computer

System One

  • OS
    Windows Server 2012 R2 / 8.1
#5
Hey there - Thanks for replying! Now unfortunately when I tried to connect with the ethernet cable, I still can't access the internet. It says it's connected, but when I go to a browser I can't connect. I ran diagnostics and got a message that says, "Your computer appears to be correctly configured but the device or resource is not responding."
Of course I can't see the additional help, because it's online. Shoot. Any thoughts? Should I still uninstall the Intel PROset wireless app?
When it appears that you are online but the browser won't go anywhere it's usually required to reset winsock or TCP/IP in order to fix the network stack corruption. Run the following two commands one at a time in an elevated command prompt then reboot the machine and test for connectivity. :)

Code:
netsh int ip reset c:\resetlog.txt
Code:
netsh winsock reset catalog
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
#7
Good post Chev :) Was going to be my next plan of attack :p
I figured you were about to reset winsock etc. because it was the obvious next step. Nice work on the trouble shooting.

Hopefully it works to fix the problem, good luck to the Op. :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

astock

New Member
Posts
12
#8
Thank you SO much! Ok, here's what I've got:

When I look at the properties, there are actually 2 listings for Ethernet. One says not connected, and the other goes way up and way down. It never sends more than 8 Kbps, where as the receiving oscillates between 0 and up to around 50. I'm not sure if that is normal or not. Wifi and Bluetooth both say not connected.

When I went to check the properties, it was already set to obtain teh ip address and dns server automatically. When I click troubleshoot it gives me the message that my broadband modem is having issues and to restart it (but I'm connected to this computer on it and I've restarted it dozens of times.)

When I go to ipconfig, I get that windows ip configuration is me, set up as hybrid node type, but then says that ip routing and wins proxy enabled are set to no.

For Wireless LAN adapter wifi, Ethernet adapter Local area connection, Ethernet adapter Bluetooth, I get media disconnected for each, but dhcp is enabled for all of them.

For ethernet adapter ethernet, it shows everything enabled. I can't copy paste exactly what it says because it's on the computer that won't connect to anything, ugh! Anything particular I should be looking for?

I've also already flushed dns but just tried again. Restarted and...halleluah! Ethernet is working again. Wireless still kaput though. Thanks so much! Any ideas for wireless?
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

astock

New Member
Posts
12
#11
Sorry that one re-sent by accident - Yes, I went through all the steps. Just reset winsock and still nothing.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

Harrylowt

New Member
Pro User
UK

Posts
333
#12
Can you check that the wifi device is enabled:

Press:
:winkey: + X
Click "Device manager"

Then locate your wifi adapter right click it and see if you can enable it. Also after that you can click in to it and on the first page it should give you a device status.

next step is to check you do not have airplane mode on:

http://www.eightforums.com/tutorials/5355-airplane-mode-turn-off-windows-8-a.html

Cheers,
Harry
 

My Computer

System One

  • OS
    Windows Server 2012 R2 / 8.1

astock

New Member
Posts
12
#13
When I ran wireless proset again, it still says I fail the association test.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

Harrylowt

New Member
Pro User
UK

Posts
333
#14
Hey Astock,

Right so did you install the application for the intel pro wireless again? we where looking to uninstall that and just have windows controlling the wireless connections. if you can try disabling that and running windows wireless controller.

To do that got to the right hand side of the of the taskbar on the intel proser wireless can you right click the icon and click "Use Windows to manage wi-fi"

Then bring up run:
1. :winkey: + R
2. Type: "Control", click "ok"
3. click on "network and internet", click "​network and sharing centre", click "Change Adapter settings"
4. right click your wireless adapter, click "Properties"
5. on the top bars click "Wireless networks"
6. Click the tick box "Use windows to configure my wireless network", click "ok"

Then can you bring up run:
1. :winkey: + R and type "services.msc", click "Ok"
2. locate "WLAN autoconfig" make sure it is started.

Now Windows should be controlling the wireless, try connect to the wireless using the windows method, click the windows taskbar wireless icon this should bring up the wireless connection available on the left try connect to your network SSID.

if this does not work also are you able to connect to any other wireless connections?

do you have any security setting in your router enabled? if so you can momentarily try disabling it once tested renable.

Also is your router broadcasting the ssid?
two things we can try around wireless account controls is:
1. delete your current profiles
should find in network and sharing then manage wireless network
2. add your SSID manually
Then bring up run:
1. :winkey: + R
2. Type: "Control", click "ok"
3. click on "network and internet", click "​network and sharing centre
4. Click "Set-up a new Network Connection or Network"
5. click "Manually Connect to a wireless network"
6.enter your information
7. follow the onscreen instructions

also in your router you could try changing the channel you are broadcasting.

That is a few things of the top of my head try.

Have ago and report back.

cheers,
Harry
 
Last edited:

My Computer

System One

  • OS
    Windows Server 2012 R2 / 8.1

astock

New Member
Posts
12
#15
Hey There,

Thanks for the reply! So I can't seem to do the first thing you are talking about - when I click on "change adapter settings" and properties, I don't get anything that says wireless at the top. I just see networking and sharing. I don't see where it says to let Windows configure my wireless. When I got to services, I don't see anything called "wireless zero configuration." Maybe I should see if I can download that?

That being said, I have already deleted and readded the profile several times and that didn't seem to do anything. I've also disabled the security on the router and still nothing. Also, none of my other computers/devices (5 in total - iPad, MacBook, Windows 7 machines, Android tablet) can connect just fine. When my boyfriend used his iPhone as a hotspot, I was able to connect to that wireless fine also, so I don't think the hardware is busted, I just think there is a miscommunication between this machine and my router.

Thanks so much! Let me know if you think of anything else.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

Harrylowt

New Member
Pro User
UK

Posts
333
#16
The service name is different, I was going from memory and got it wrong needed to update my brain to windows 8 :think:

You will want to start these two services and automatic:

Screen Shot 2014-02-16 at 21.47.43.png

Screen Shot 2014-02-16 at 21.50.45.png
 

My Computer

System One

  • OS
    Windows Server 2012 R2 / 8.1

astock

New Member
Posts
12
#17
Ah ok, done and done. I noticed the wired one was not running. I also noticed there is another service called wireless PAN DHCP Server that is not running, and when I tried to start it, I got an error - 1067, The service terminated unexpectedly.

Think that matters?

Thank you so much again!
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

Harrylowt

New Member
Pro User
UK

Posts
333
#18
Hey Astock,

I am going to have to find out some more information of how your system currently looks. I am not sure what you have of have not done.

Firstly how are you managing your network is it through the Intel utility or the inbuilt windows 8 wireless control?

Can you please go to device manager - :winkey: + X < click device manager, go to networks adapters > click in to your wireless adapter. Please make sure this setting is turned off:

wifi.PNG

Also please go over to the driver tab and screenshot the driver version.
can you please re-run these steps:

:winkey:+ X
:winkey:+ A
type:
"ipconfig /all" - Press enter
Please posts results

Then please type these separate commands:
"ipconfig /release" - press enter
"ipconfig /renew" - press enter
"Ipconfig /flushdns" - press enter
"ipconfig /registerdns" - press enter

Reboot and test connectivity

please can you then type in another command prompt:

ping 8.8.8.8

^ please post results


Can you please turn off your router for 30 seconds and then turn it back on and try connect.


Afterwards please can we:


netsh int ip reset c:\resetlog.txt


netsh winsock reset catalog

Again restart and test connection.


Also please can you show me a screenshot of what is happening when you are trying to connect to the wireless so I can get a better understanding of what is happening.

Can you check what WIFI standard you network card is to this bring up and elevated cmd prompt again.

Type

netsh wlan show interface

Post screenshot of results

Also inside of your router can you check what you are using the correct WIFI Standard. if you need help to do this please tell me router you have and will be able to help direct you.

Cheers,
Harry
 

My Computer

System One

  • OS
    Windows Server 2012 R2 / 8.1

astock

New Member
Posts
12
#19
Hey there - my responses are listed here.


Firstly how are you managing your network is it through the Intel utility or the inbuilt windows 8 wireless control?
I don't know - I thought I was using the windows 8 wireless control, but I had tried the Intel too. Intel is what told me I was having the association failure. I did turn the WLAN Autoconfig to running in services.

Can you please go to device manager - :winkey: + X < click device manager, go to networks adapters > click in to your wireless adapter. Please make sure this setting is turned off:
That's done.
Also please go over to the driver tab and screenshot the driver version.
driver.PNG
can you please re-run these steps:

:winkey:+ X
:winkey:+ A
type:
"ipconfig /all" - Press enter
Please posts results
ipconfig1.PNG
ipconfig2.PNG
Then please type these separate commands:
"ipconfig /release" - press enter - It won't perform all the releases...See screenshot
iprelease.PNG
"ipconfig /renew" - press enter - When I try to do this, it says I can't... See screenshot
iprenew.PNG
"Ipconfig /flushdns" - press enter - done
"ipconfig /registerdns" - press enter - done

I'm assuming that is where I'm having a problem so I'm going to pause here before I move forward. Let me know if I should go through with the rest of the steps or not (by the way have tried all of this before. eeks!) Thank you again so much for your help!
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo IdeaPad z580

Harrylowt

New Member
Pro User
UK

Posts
333
#20
Is your wireless card bound to a virtual switch?

For example do you have hyper-v running and a vswitch bridged to the wifi card so that the virtual machine can get interent via wifi?

Cheers,
Harry
 

My Computer

System One

  • OS
    Windows Server 2012 R2 / 8.1