What's new

Solved Windows 8 refuses to mount .iso image because image is 'sparse'

MarkR

New Member
Just thought I would share the solution I found to my problem mounting .iso images in Windows 8 Pro.

The very helpful error message I was getting was this:
Capture2.PNG
and in powershell I got this:
Capture3.PNG

Essentially the problem is that windows .iso mounting does not like 'sparse' files. I had used Acronis backup to backup my original .iso files and this DOES use sparse files. You can check if a file is 'sparsed' by looking at the files details in properties. The 'P' in the attributes represents a sparse file. See the screenshot below.

The result? When I restored my .iso images I could no longer mount them.

The simplest solution I have found is to just copy the .iso to a new file - this seems to create the new file without the sparse flag set.

Hope this helps somebody!

Capture.PNG
 

My Computer

System One

  • OS
    Windows 8 Pro

Mystere

Power User
VIP Member
Power User
For anyone that is curious.. Sparse files are files that have "reserved" space in them that is not technically part of the data. An application can create a sparse file so that it leaves room to expand it in the middle without having to recopy all the data. I can understand why Acronis would do this for a backup image.

Shouldn't Acronis also have a file viewer?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    CPU
    Intel i7 3770K
    Motherboard
    Gigabyte Z77X-UD4 TH
    Memory
    16GB DDR3 1600
    Graphics Card(s)
    nVidia GTX 650
    Sound Card
    Onboard Audio
    Monitor(s) Displays
    Auria 27" IPS + 2x Samsung 23"
    Screen Resolution
    2560x1440 + 2x 2048x1152
    Hard Drives
    Corsair m4 256GB, 2 WD 2TB drives
    Case
    Antec SOLO II
    Keyboard
    Microsoft Natural Ergonomic Keyboard 4000
    Mouse
    Logitech MX

medeiom

New Member
cannot mount iso

Has anyone found a solution to this issue within Win8.1? I am receiving the same error msg. I tried associating the .iso extension but it does not exist.

Any help appreciated.
 

My Computer

System One

  • OS
    8.1

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top