• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows 8 Pro - BSOD / Crashing / Automatic Repair Loop


Asomatoul

New Member
Posts
4
#1
I have had crashing in the past few days (not sure what caused it - that's what I'm hoping to figure out). It started with the PC not shutting down. I would shut down and it would just restart instead.

Afterwards it again BSOD'd on me twice - the second time it went into an automatic repair loop and after several hours of attempting to get it working I ended up doing a PC Refresh.

I ran Memtest 5.01 overnight (~9 hours) and no errors on 5+ passes.

Started messing around in windows again this morning (trying to figure out how to read these .dmp files - any insight there?) and it has crashed again.

Since I had to do the refresh I do not have any programs on here and have not loaded any drivers or anything, so I'm not sure that that would be an issue, but hoping it's not hardware.

I have been running an overclock ([email protected] volts) for about 2 years now without issue - ran the memtest with default clock settings and XMP profile (which I checked - all the settings match the corsair recommended).

Also ran WindowSmart 2013 - no errors on the SSD; can't check the HDD since it's a RAID array.

Any other thoughts?

See attached the SF folder. Also, I have some files uploaded here as well:

My minidump file is located here: http://sdrv.ms/GC2leL

Windows also created the following log files on my windows folder (now windows.old) during the automatic repair:

http://sdrv.ms/1bztopg and http://sdrv.ms/1bztpcV

Here are the new memory dumps from this morning:

http://sdrv.ms/1cjw2Py

http://sdrv.ms/17IXvGE

Hardware Specs:
Motherboard: P8Z68-V PRO/GEN3
Processor: i7-2600K
Memory: Corsair Vengeance 16GB
Boot Drive: Crucial m4 256
Hard Drive: 2x WD 1TB Black Raid 0
Video Card: EVGA GTX 670
PSU: Corsair 1200W
 

My Computer

System One

  • OS
    8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Cusom
    CPU
    i7-2600K
    Motherboard
    P8Z68-V PRO/GEN3
    Memory
    Corsair Vengeance 16GB
    Graphics Card(s)
    EVGA GTX 670
    Browser
    Firefox
    Antivirus
    Norton Internet Security

Asomatoul

New Member
Posts
4
#2
So I've gotten some feedback from other forums, but still no confirmation on what is actually causing this.

I reverted to stock clocks (with XMP) and have still gotten crashes (although they are less frequent now). I ran prime95 this morning to see if it might be a heat or cpu issue; it crashed after about 30 minutes of running hitting about 60C max.

I will be running memtest again overnight with 1 of the 4 memory sticks to see if I can definitively figure out that it's not the memory.

With the prime95 test failure though I'm tempted to believe it's the board or cpu - everything is under warranty thank goodness, but I want to make sure I'm sending the right piece(s) back so that I'm not out of commission here for too long.

Any advice on tests to rule out the psu? I've tried using Everest and speedfan, but neither of those is giving me a reading on the 12V (and I don't have any physical tools to read the psu).

Still looking for help with reading the dmp files too to see if there is any insight there into what's going on.
 

My Computer

System One

  • OS
    8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Cusom
    CPU
    i7-2600K
    Motherboard
    P8Z68-V PRO/GEN3
    Memory
    Corsair Vengeance 16GB
    Graphics Card(s)
    EVGA GTX 670
    Browser
    Firefox
    Antivirus
    Norton Internet Security

usasma

Mr. Cranky Pants
VIP Member
Guru
Posts
5,139
#3
To test the PSU - remove a lot of non-essential stuff.
It'll cause less "pressure" on the PSU - so problems should be less frequent.
Otherwise, try another PSU.

OCCT has a PSU test: Home

Prime95 stresses 3 components:
- CPU
- memory controller
- RAM

More info on Prime95: Prime95

SSD's were temperamental when they first came out, but their reliability has improved greatly over the last year or two. There are 2 things that MUST be checked on systems with BSOD's and SSD's:
1) That the SSD firmware is the latest available for the SSD. I usually can't see this info in the reports, so I rely on you to check it.
2) That the storage controller drivers on the motherboard are the most recent. They must date from late 2012 or later. This is ALL controllers, not just the one that the SSD is attached to. If involved these should be visible in the memory dump - but it doesn't hurt to check manually.
I don't have time right now to check the memory dumps.
Please post back if you'd like me to do that - and I'll get to it within the next morning or two (Eastern Time in the US)
 

My Computer

System One

  • OS
    Win8.1Pro - Finally!!!
    Computer type
    Laptop
    System Manufacturer/Model
    Samsung/NP780
    CPU
    Came with the laptop (i7 of some sort)
    Motherboard
    Pretty sure that it has one, but haven't checked inside the case!
    Memory
    upgraded to 12 gB from 8 gB
    Graphics Card(s)
    has switchable - Intel/ATI - Used wrong drivers, now ATI card is inop :( Will have to fix it soon!
    Sound Card
    I'm nearly deaf, so this isn't used often
    Monitor(s) Displays
    Touchscreen on laptop/32" Toshiba on HDMI (laid the Sharp TV on a mouse and cracked the screen!)
    Screen Resolution
    800x600
    Hard Drives
    One Samsung 1tB drive - 5400 rpm. Gonna switch to a 7200/10000 rpm or an SSD (if I can find $500 for a 1tB SSD!)
    - Switched to 500 gB Samsung 840 series SSD - WOW!!!
    PSU
    Why do we ask this for laptops?
    Case
    Silver with a neat Samsung logo
    Cooling
    sub-par, gotta get around to working on it soon Worked on it - still sub-par! :(
    Keyboard
    Microsoft Natural - the same one I've used since it orignally came out around 1995
    Mouse
    no Mouse - Trackball!!!!
    Internet Speed
    too slow when I'm waiting for a download to finish
    Browser
    Yes, I use this (Firefox mostly, w/IE next most)
    Antivirus
    Windows Defender and Windows Firewall
    Other Info
    I'm handsome and a snappy dresser :0)

Asomatoul

New Member
Posts
4
#4
Thanks for the help - if you do get a chance to check the memory dumps I would appreciate it.

I have now run each memory stick through Memtest 5.01 individually:

  1. ~10 Hours / 8 Passes / 0 Errors
  2. ~11 Hours / 7 Passes / 0 Errors
  3. ~13 Hours / 14 Passes / 0 Errors
  4. ~12 Hours / 11 Passes / 0 Errors

The only thing that strikes me as unusual is that the number of passes completed is pretty different between the sticks, but with them being tested for that long I imagine the memory is not the problem.

To your notes:
  • The SSD firmware is the latest; running 070H Crucial 2.5 SSD Firmware
  • The storage controllers were not all up to date - I did not have the JMicron or Marvell drivers installed. These were disabled in the BIOS (as I do not use them or intend to at this point). Do these still need to be installed and up to date if they are disabled?

Two new issues that have crept up since starting the various testing:
  • USB drives are ejected (not physically... obviously) and a note pops up that they are not recognized. I pull them out and put them back in and they are recognized immediately again. The time it takes to eject varies.
  • The internet connection is sometimes terminated, and then pops back up again a few minutes later - no tweaking on my part to get it to reconnect.

The PSU seems to be in good shape at least on the software tests. I ran the OCCT test as you suggested and the voltages are pretty rock stable.

I'll keep posting any other developments or a solution if I find one.
 

My Computer

System One

  • OS
    8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Cusom
    CPU
    i7-2600K
    Motherboard
    P8Z68-V PRO/GEN3
    Memory
    Corsair Vengeance 16GB
    Graphics Card(s)
    EVGA GTX 670
    Browser
    Firefox
    Antivirus
    Norton Internet Security

usasma

Mr. Cranky Pants
VIP Member
Guru
Posts
5,139
#5
I have seen systems pass Memtest and then fail Prime95 due to memory. It's a matter of each using a different test method.
Still, unless further hardware problems present themselves - I'd figure it wasn't RAM for now.

Devices disabled in the BIOS do not need drivers. Devices disabled in Device Manager do need updates - as they load the drivers before the system disables the device.

No Windows Updates installed. Most systems have 80 - 100 or more. Please visit Windows Update and get ALL available updates (it may take several trips to get them all).

Drivers for these devices aren't installed. Please install them:
PCI Simple Communications Controller PCI\VEN_8086&DEV_1C3A&SUBSYS_844D1043&REV_04\3&11583659&0&B0 The drivers for this device are not installed.

Not Available USB\VID_0CF3&PID_3000\6&DF2EE03&0&7 The drivers for this device are not installed.
The first one is most likely the Intel(R) Management Engine Interface (MEI); while the second one is most likely your Atheros Bluetooth
Interestingly, the dump reports do show the drivers for the Intel MEI are loaded.

Have you turned Driver Verifier on? If so, please turn it off.
One of the memory dumps is verifier enabled - but doesn't have the usual drivers (video) blamed.
It blames Ironx64.sys - a Symantec/Norton driver.

To resolve this, please:
Anti-Virus Removal:
Please do the following:
- download a free anti-virus for testing purposes: Free AntiVirus If using Windows 8, enable Windows Defender and the Windows Firewall instead (after removing Norton).
- un-install the Norton from your system (you can reinstall it, if so desired, when we're done troubleshooting)
- remove any remnants of Norton using this free tool: http://us.norton.com/support/kb/web_view.jsp?wv_type=public_web&docurl=20080710133834EN
- IMMEDIATELY install and update the free anti-virus (if using Win8, enable Windows Defender), then check to ensure that the Windows Firewall is turned on.
- perform a full system scan to ensure that no malware has snuck onto your system while the anti-virus was malfunctioning.
- check to see if this fixes the BSOD's
NOTE: NEVER run more than 1 anti-virus, firewall, Internet Security/Security Center application at the same time.
MSI Afterburner (along with Riva Tuner and EVGA Precision) are known to cause BSOD's in some Windows systems (it's driver is usually RTCore64.sys). Please un-install it immediately!

If you're overclocking, please stop the overclock while we're troubleshooting. Feel free to resume the overclock once the system has been stabilized.

If using Corsair Link2 or Razer GameBooster - please uninstall them (and don't update them as suggested below). If using RealTemp or another program that uses the WinRing libraries it's OK to update them as suggested below.

Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable! :

WinRing0x64.sys Sat Jul 26 09:29:37 2008 (488B26C1)
many different programs that center around the using of the WinRing libraries (RealTemp, Corsair Link2 (known BSOD issues w/Win8), Razer GameBooster, etc)
http://www.carrona.org/drivers/driver.php?id=WinRing0x64.sys

HECIx64.sys Tue Oct 19 19:33:43 2010 (4CBE2AD7)
Intel Management Engine Interface
http://www.carrona.org/drivers/driver.php?id=HECIx64.sys

iaStorV.sys Mon Apr 11 14:48:16 2011 (4DA34CF0)
Intel Matrix Storage Manager driver (base) (now is the Rapid Storage Technology (RST) driver)
http://www.carrona.org/drivers/driver.php?id=iaStorV.sys



Analysis:
The following is for informational purposes only.
Code:
[font=lucida console]**************************Sun Oct  6 08:14:37.005 2013 (UTC - 4:00)**************************
Loading Dump File [C:\Users\John\SysnativeBSODApps\100613-7500-01.dmp]
Windows 8 Kernel Version 9200 MP (8 procs) Free x64
Built by: [B]9200[/B].16384.amd64fre.win8_rtm.120725-1247
System Uptime:[B]0 days 0:46:33.676[/B]
Probably caused by :[B]GenuineIntel[/B]
BugCheck [B]124, {0, fffffa800f7aa028, be200000, 5110a}[/B]
BugCheck Info: [url=http://www.carrona.org/bsodindx.html#0x00000124]WHEA_UNCORRECTABLE_ERROR (124)[/url]
Arguments: 
Arg1: 0000000000000000, Machine Check Exception
Arg2: fffffa800f7aa028, Address of the WHEA_ERROR_RECORD structure.
Arg3: 00000000be200000, High order 32-bits of the MCi_STATUS value.
Arg4: 000000000005110a, Low order 32-bits of the MCi_STATUS value.
BUGCHECK_STR:  0x124_GenuineIntel
PROCESS_NAME:  prime95.exe
FAILURE_BUCKET_ID: [B]0x124_GenuineIntel_PROCESSOR_CACHE[/B]
CPUID:        "Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz"
MaxSpeed:     3400
CurrentSpeed: [B]3400[/B]
  BIOS Version                  3603
  BIOS Release Date             11/09/2012
  Manufacturer                  System manufacturer
  Product Name                  System Product Name
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Sat Oct  5 15:06:29.137 2013 (UTC - 4:00)**************************
Loading Dump File [C:\Users\John\SysnativeBSODApps\100513-10906-01.dmp]
Windows 8 Kernel Version 9200 MP (8 procs) Free x64
Built by: [B]9200[/B].16628.amd64fre.win8_gdr.130531-1504
System Uptime:[B]0 days 0:05:55.848[/B]
*** ERROR: Module load completed but symbols could not be loaded for Ironx64.SYS
Probably caused by :[B]Ironx64.SYS[/B]
BugCheck [B]C4, {62, fffffa800ff218d8, fffffa800ff33e10, 6}[/B]
BugCheck Info: [url=http://www.carrona.org/bsodindx.html#0x000000C4]DRIVER_VERIFIER_DETECTED_VIOLATION (c4)[/url]
DRIVER_VERIFIER_DETECTED_VIOLATION (c4)
Arguments: 
Arg1: 0000000000000062, A driver has forgotten to free its pool allocations prior to unloading.
Arg2: fffffa800ff218d8, name of the driver having the issue.
Arg3: fffffa800ff33e10, verifier internal structure with driver information.
Arg4: 0000000000000006, total # of (paged+nonpaged) allocations that weren't freed.
    Type !verifier 3 drivername.sys for info on the allocations
    that were leaked that caused the bugcheck.
BUGCHECK_STR:  0xc4_62
PROCESS_NAME:  services.exe
FAILURE_BUCKET_ID: [B]0xc4_62_LEAKED_POOL_IMAGE_Ironx64.SYS[/B]
CPUID:        "Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz"
MaxSpeed:     3400
CurrentSpeed: [B]3400[/B]
  BIOS Version                  3603
  BIOS Release Date             11/09/2012
  Manufacturer                  System manufacturer
  Product Name                  System Product Name
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
[/font]
3rd Party Drivers:
The following is for information purposes only.
Any drivers in red should be updated or removed from your system. And should have been discussed in the body of my post.
Code:
[font=lucida console]**************************Sun Oct  6 08:14:37.005 2013 (UTC - 4:00)**************************
[COLOR=RED][B]WinRing0x64.sys             Sat Jul 26 09:29:37 2008 (488B26C1)[/B][/COLOR]
[COLOR=RED][B]iaStorV.sys                 Mon Apr 11 14:48:16 2011 (4DA34CF0)[/B][/COLOR]
e1i63x64.sys                Wed Feb 29 22:25:14 2012 (4F4EEC1A)
nvlddmkm.sys                Mon Jun 18 16:47:19 2012 (4FDF93D7)
intelppm.sys                Wed Jul 25 22:26:48 2012 (5010AAE8)
cpuz136_x64.sys             Sat Aug 24 04:56:35 2013 (52187543)
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Sat Oct  5 15:06:29.137 2013 (UTC - 4:00)**************************
[COLOR=RED][B]HECIx64.sys                 Tue Oct 19 19:33:43 2010 (4CBE2AD7)[/B][/COLOR]
PxHlpa64.sys                Tue Apr 24 13:26:29 2012 (4F96E245)
btfilter.sys                Fri Jun 29 03:00:07 2012 (4FED5277)
Ironx64.SYS                 Mon Jul 23 20:34:50 2012 (500DEDAA)
SYMEVENT64x86.SYS           Wed Aug 22 01:33:18 2012 (50346F1E)
lvrs64.sys                  Mon Oct 22 22:11:24 2012 (5085FCCC)
lvuvc64.sys                 Mon Oct 22 22:12:08 2012 (5085FCF8)
intelppm.sys                Mon Nov  5 22:55:02 2012 (50988A16)
wacomrouterfilter.sys       Thu Dec 20 17:19:54 2012 (50D38F0A)
SYMEFA64.SYS                Fri Jan 18 19:31:37 2013 (50F9E969)
SRTSPX64.SYS                Fri Jan 25 16:30:05 2013 (5102F95D)
[COLOR=RED][B]RTCore64.sys                Mon Mar 11 01:32:06 2013 (513D6C56)[/B][/COLOR]
ccSetx64.sys                Thu Mar 21 23:02:33 2013 (514BC9C9)
SYMNETS.SYS                 Tue Apr  9 19:24:13 2013 (5164A31D)
SYMDS64.SYS                 Thu Apr 25 19:19:47 2013 (5179BA13)
wachidrouter.sys            Tue Apr 30 13:16:27 2013 (517FFC6B)
nvhda64v.sys                Sun Jun 16 08:38:07 2013 (51BDB1AF)
IDSvia64.sys                Thu Jul 25 20:11:40 2013 (51F1BEBC)
dump_iaStorA.sys            Thu Aug  1 21:39:52 2013 (51FB0DE8)
iaStorA.sys                 Thu Aug  1 21:39:52 2013 (51FB0DE8)
eeCtrl64.sys                Wed Aug 21 17:36:34 2013 (521532E2)
EraserUtilRebootDrv.sys     Wed Aug 21 17:36:34 2013 (521532E2)
nvlddmkm.sys                Thu Sep 12 01:16:00 2013 (52314E10)
[/font]
http://www.carrona.org/drivers/driver.php?id=WinRing0x64.sys
http://www.carrona.org/drivers/driver.php?id=iaStorV.sys
http://www.carrona.org/drivers/driver.php?id=e1i63x64.sys
http://www.carrona.org/drivers/driver.php?id=nvlddmkm.sys
http://www.carrona.org/drivers/driver.php?id=intelppm.sys
http://www.carrona.org/drivers/driver.php?id=cpuz136_x64.sys
http://www.carrona.org/drivers/driver.php?id=HECIx64.sys
http://www.carrona.org/drivers/driver.php?id=PxHlpa64.sys
http://www.carrona.org/drivers/driver.php?id=btfilter.sys
http://www.carrona.org/drivers/driver.php?id=Ironx64.SYS
http://www.carrona.org/drivers/driver.php?id=SYMEVENT64x86.SYS
http://www.carrona.org/drivers/driver.php?id=lvrs64.sys
http://www.carrona.org/drivers/driver.php?id=lvuvc64.sys
http://www.carrona.org/drivers/driver.php?id=intelppm.sys
http://www.carrona.org/drivers/driver.php?id=wacomrouterfilter.sys
http://www.carrona.org/drivers/driver.php?id=SYMEFA64.SYS
http://www.carrona.org/drivers/driver.php?id=SRTSPX64.SYS
http://www.carrona.org/drivers/driver.php?id=RTCore64.sys
http://www.carrona.org/drivers/driver.php?id=ccSetx64.sys
http://www.carrona.org/drivers/driver.php?id=SYMNETS.SYS
http://www.carrona.org/drivers/driver.php?id=SYMDS64.SYS
http://www.carrona.org/drivers/driver.php?id=wachidrouter.sys
http://www.carrona.org/drivers/driver.php?id=nvhda64v.sys
http://www.carrona.org/drivers/driver.php?id=IDSvia64.sys
http://www.carrona.org/drivers/driver.php?id=dump_iaStorA.sys
http://www.carrona.org/drivers/driver.php?id=iaStorA.sys
http://www.carrona.org/drivers/driver.php?id=eeCtrl64.sys
http://www.carrona.org/drivers/driver.php?id=EraserUtilRebootDrv.sys
http://www.carrona.org/drivers/driver.php?id=nvlddmkm.sys
 

My Computer

System One

  • OS
    Win8.1Pro - Finally!!!
    Computer type
    Laptop
    System Manufacturer/Model
    Samsung/NP780
    CPU
    Came with the laptop (i7 of some sort)
    Motherboard
    Pretty sure that it has one, but haven't checked inside the case!
    Memory
    upgraded to 12 gB from 8 gB
    Graphics Card(s)
    has switchable - Intel/ATI - Used wrong drivers, now ATI card is inop :( Will have to fix it soon!
    Sound Card
    I'm nearly deaf, so this isn't used often
    Monitor(s) Displays
    Touchscreen on laptop/32" Toshiba on HDMI (laid the Sharp TV on a mouse and cracked the screen!)
    Screen Resolution
    800x600
    Hard Drives
    One Samsung 1tB drive - 5400 rpm. Gonna switch to a 7200/10000 rpm or an SSD (if I can find $500 for a 1tB SSD!)
    - Switched to 500 gB Samsung 840 series SSD - WOW!!!
    PSU
    Why do we ask this for laptops?
    Case
    Silver with a neat Samsung logo
    Cooling
    sub-par, gotta get around to working on it soon Worked on it - still sub-par! :(
    Keyboard
    Microsoft Natural - the same one I've used since it orignally came out around 1995
    Mouse
    no Mouse - Trackball!!!!
    Internet Speed
    too slow when I'm waiting for a download to finish
    Browser
    Yes, I use this (Firefox mostly, w/IE next most)
    Antivirus
    Windows Defender and Windows Firewall
    Other Info
    I'm handsome and a snappy dresser :0)

Asomatoul

New Member
Posts
4
#6
I have seen systems pass Memtest and then fail Prime95 due to memory. It's a matter of each using a different test method.
Still, unless further hardware problems present themselves - I'd figure it wasn't RAM for now.

Devices disabled in the BIOS do not need drivers. Devices disabled in Device Manager do need updates - as they load the drivers before the system disables the device.

No Windows Updates installed. Most systems have 80 - 100 or more. Please visit Windows Update and get ALL available updates (it may take several trips to get them all).

Drivers for these devices aren't installed. Please install them:
PCI Simple Communications Controller PCI\VEN_8086&DEV_1C3A&SUBSYS_844D1043&REV_04\3&11583659&0&B0 The drivers for this device are not installed.

Not Available USB\VID_0CF3&PID_3000\6&DF2EE03&0&7 The drivers for this device are not installed.
The first one is most likely the Intel(R) Management Engine Interface (MEI); while the second one is most likely your Atheros Bluetooth
Interestingly, the dump reports do show the drivers for the Intel MEI are loaded.

Have you turned Driver Verifier on? If so, please turn it off.
One of the memory dumps is verifier enabled - but doesn't have the usual drivers (video) blamed.
It blames Ironx64.sys - a Symantec/Norton driver.
Interesting. When I was first getting the BSOD's I ended up having to do a system 'refresh' under windows. That may explain why the one dump file shows the MEI installed and working (I didn't think to reinstall all windows updates / drivers after the refresh).

I will update them now and see what happens then. I just checked now, and I do not have anything installed other than what comes with windows 8 and the various monitoring / testing programs that I've put on (realtemp, prime95, speedfan, etc.). My antivirus is not installed again yet.

The driver verifier was on for one of the dump files (the first one); I have not turned it back on since.

Thanks for the help.
 

My Computer

System One

  • OS
    8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Cusom
    CPU
    i7-2600K
    Motherboard
    P8Z68-V PRO/GEN3
    Memory
    Corsair Vengeance 16GB
    Graphics Card(s)
    EVGA GTX 670
    Browser
    Firefox
    Antivirus
    Norton Internet Security

Users Who Are Viewing This Thread (Users: 0, Guests: 1)