• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows 8 Metro Fonts Glitch?


revendel

New Member
Posts
2
#1
I do a lot of design work and therefore have a huge collection of fonts. After upgrading to Windows 8, I installed my pack of 25000 fonts. Now, whenever I go to use any Metro app and the start screen, all my icons and some Metro fonts are garbled up. I'm surprised that this has happened and am wondering if there is any fix for this.

1.png 2.png 3.png

Thanks
 

My Computer

System One

  • OS
    Windows 8
#3
Hello,

I'm experiencing exactly the same!

aaaqb.png
(Text scrambled on purpose)

Were you able to solve it?

Thank you very much in advance,

/[email protected]
www.macs.cat
 

My Computer

System One

  • OS
    Windows 8 64 Bits
    System Manufacturer/Model
    Sony VAIO
    CPU
    Intel Core i7-3632QM
    Motherboard
    Intel Ivy Bridge HM77
    Memory
    12.0 GB Dual-Channel DDR3
    Graphics Card(s)
    VAIO_LCD ([email protected]) :: NVIDIA GeForce GT 640M LE | Intel HD Graphics 4000
#4
Issue SOLVED!

Do this:
1. From the DVD (you'll need 7-Zip, Power ISO or so) you have to open install.wim, then go to Windows/Fonts and extract them all in any directory. (Alternatively, you could copy the same folder from another -CLEAN- Windows 8 system you have).
2. Select all (ctrl+a) the fonts from the dir you've extracted them and right-click and Install..,
3. When asked, say Replace (also check to do so for all the files)
4. You are done! (Though you may need to re-boot, but it wasn't my case).
 

My Computer

System One

  • OS
    Windows 8 64 Bits
    System Manufacturer/Model
    Sony VAIO
    CPU
    Intel Core i7-3632QM
    Motherboard
    Intel Ivy Bridge HM77
    Memory
    12.0 GB Dual-Channel DDR3
    Graphics Card(s)
    VAIO_LCD ([email protected]) :: NVIDIA GeForce GT 640M LE | Intel HD Graphics 4000

MrShowdown

Well-Known Member
Power User
Jakarta, Indonesia

Posts
1,048
#5
Actually you just need to copy the file for the font:
"Segoe UI Symbol"
 

My Computer

System One

  • OS
    Windows 10 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo Y520
    CPU
    Intel Core i5 7300HQ
    Motherboard
    OEM Lenovo
    Memory
    4GB DDR4-2400
    Graphics Card(s)
    NVIDIA GeForce GTX 1050
    Sound Card
    Realtek HD
    Monitor(s) Displays
    1 (2)
    Screen Resolution
    1920x1080
    Hard Drives
    Seagate 1TB 5400 RPM
    Keyboard
    OEM Lenovo
    Mouse
    Logitech G502 Proteus Core
    Internet Speed
    100 Mbps
    Browser
    Google Chrome
    Other Info
    PC:

    AMD Athlon X4 760K
    8GB DDR3-1866
    AMD Radeon RX 460
    Seagate 500 GB 7200 RPM

Users Who Are Viewing This Thread (Users: 0, Guests: 1)