What's new

Windows 8.1 Update 1, PC Settings, PC and Devices crash

banger

New Member
Member
Hi

Just updated to Update 1 on Win 8.1 on two machines. When I open the PC Settings App from Start Screen or Taskbar all the options are ok except PC and devices. When I select this on the app menu the app crashes back to the desktop. Anyone suggest a fix I suspect it's the new Drive Manager in that menu option. Other machine works fine with this option. Any Fixes?

Tim
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender

banger

New Member
Member
Further investigation shows that if I create a new local account the app works fine and I can access the Device Settings etc. I tried deleting my main MS account off the machine and re-creating it but got myself in a bit of a mess so restored from a system image a few days ago. Is there a troubleshooting list somewhere. I seem to have found it on this site the other day but lost it again?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender

banger

New Member
Member
Fixed



Apparently the Lock Screen doesn't like the local OneDrive folder for its pictures and looks in the old location I originally had my pictures (on XP) which was G:\User\Documents\Pictures. Once I copied the pictures folder back to the original install location (Win 8) no more app crash.



regards



Tim
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender

woody345

New Member
I had several apps do this as well, but I just uninstalled them and then reinstalled them to get them working again, no new user account required.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit
    Computer type
    PC/Desktop
    CPU
    Intel i5 3570K
    Motherboard
    ASRock Z77 Extreme4
    Memory
    8 Gb
    Graphics Card(s)
    Intel HD 4000
    Sound Card
    On board

banger

New Member
Member
You cant uninstall PC Settings its an app bug.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender

banger

New Member
Member
Now its crashing when I select Devices in PC and Devices. Tried sfc /scannow but it said it couldnt repair files. Any clues how to repair?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender

banger

New Member
Member
Think I fixed it, did DISM restorehealth, then sfc scannow and it seems to be ok now.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender

Cliff S

Missing my GIF avatars:(
Pro User
You could try repairing PC settings by opening an Admin Command Prompt and copy & paste this in
Code:
[COLOR=#333333][FONT=Verdana]powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\ImmersiveControlPanel\AppxManifest.xml[/FONT][/COLOR][FONT=Verdana][COLOR=#333333][/COLOR][/FONT]
 

My Computer

System One

  • OS
    Windows 8.1 Update Pro in Hyper-V/Windows 10 Pro 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Cliff's Black & Blue Wonder
    CPU
    Intel Core i9-9900K
    Motherboard
    ASUS ROG Maximus X Hero
    Memory
    32 GB Quad Kit, G.Skill Trident Z RGB Series schwarz, DDR4-3866, 18-19-19-39-2T
    Graphics Card(s)
    ASUS GeForce RTX 3090 ROG Strix O24G, 24576 MB GDDR6X
    Sound Card
    (1) HD Webcam C270 (2) NVIDIA High Definition Audio (3) Realtek High Definition Audio
    Monitor(s) Displays
    BenQ BL2711U(4K) and a hp 27vx(1080p)
    Screen Resolution
    1920 x 1080 x 32 bits (4294967296 colors) @ 60 Hz
    Hard Drives
    C: Samsung 960 EVO NVMe M.2 SSD
    E: & O: Libraries & OneDrive-> Samsung 850 EVO 1TB
    D: Hyper-V VM's -> Samsung PM951 Client M.2 512Gb SSD
    G: System Images -> HDD Seagate Barracuda 2TB
    PSU
    Corsair HX1000i High Performance ATX Power Supply 80+ Platinum
    Case
    hanteks Enthoo Pro TG
    Cooling
    Thermaltake Floe Riing RGB TT Premium-Edition 360mm and 3 Corsair blue LED fans
    Keyboard
    Trust GTX THURA
    Mouse
    Trust GTX 148
    Internet Speed
    25+/5+ (+usually faster)
    Browser
    Edge; Chrome; IE11
    Antivirus
    Windows Defender of course & Malwarebytes Anti-Exploit as a
    Other Info
    Router: FRITZ!Box 7490
    Sound system: SHARP HT-SBW460 Dolby Atmos Soundbar
    Webcam: Logitech BRIO ULTRA HD PRO WEBCAM 4K webcam with HDR

banger

New Member
Member
Well the success was short lived. It is doing it again, As soon as a goto Devices the window minimizes and when I open it again it restarts PC settings. Tried the Poweshell command but the problem remains, I wonder if it is one of the connected devices?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender

Cliff S

Missing my GIF avatars:(
Pro User
Capture.PNG
How about the desktop version? Do you have any problems accessing it? It can be slow loading sometimes depending on how many devices are connected. Also any yellow flags:)warn:) in device manager?
 

My Computer

System One

  • OS
    Windows 8.1 Update Pro in Hyper-V/Windows 10 Pro 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Cliff's Black & Blue Wonder
    CPU
    Intel Core i9-9900K
    Motherboard
    ASUS ROG Maximus X Hero
    Memory
    32 GB Quad Kit, G.Skill Trident Z RGB Series schwarz, DDR4-3866, 18-19-19-39-2T
    Graphics Card(s)
    ASUS GeForce RTX 3090 ROG Strix O24G, 24576 MB GDDR6X
    Sound Card
    (1) HD Webcam C270 (2) NVIDIA High Definition Audio (3) Realtek High Definition Audio
    Monitor(s) Displays
    BenQ BL2711U(4K) and a hp 27vx(1080p)
    Screen Resolution
    1920 x 1080 x 32 bits (4294967296 colors) @ 60 Hz
    Hard Drives
    C: Samsung 960 EVO NVMe M.2 SSD
    E: & O: Libraries & OneDrive-> Samsung 850 EVO 1TB
    D: Hyper-V VM's -> Samsung PM951 Client M.2 512Gb SSD
    G: System Images -> HDD Seagate Barracuda 2TB
    PSU
    Corsair HX1000i High Performance ATX Power Supply 80+ Platinum
    Case
    hanteks Enthoo Pro TG
    Cooling
    Thermaltake Floe Riing RGB TT Premium-Edition 360mm and 3 Corsair blue LED fans
    Keyboard
    Trust GTX THURA
    Mouse
    Trust GTX 148
    Internet Speed
    25+/5+ (+usually faster)
    Browser
    Edge; Chrome; IE11
    Antivirus
    Windows Defender of course & Malwarebytes Anti-Exploit as a
    Other Info
    Router: FRITZ!Box 7490
    Sound system: SHARP HT-SBW460 Dolby Atmos Soundbar
    Webcam: Logitech BRIO ULTRA HD PRO WEBCAM 4K webcam with HDR

banger

New Member
Member
Two devices with yellow flags which I have removed. Desktop version works fine, but still PC settings devices crashes out. I have tried my other machine a desktop also and that sometimes crashes out too.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    MSI MS7360
    CPU
    Intel E8400 (Wolfdale)
    Motherboard
    MS 7360 P35 V1.0
    Memory
    4 GB
    Graphics Card(s)
    MSI Geforce GT610
    Sound Card
    Realtek Onboard
    Monitor(s) Displays
    Dell 19" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    3 x 500 GB Hitachi and Seagate Drives
    PSU
    Corsair 500W
    Case
    Generic
    Cooling
    2 case fans, Artic CPU Cooler
    Keyboard
    Logitech G19
    Mouse
    MS Comfort 4500
    Internet Speed
    19 mbps
    Browser
    Firefox
    Antivirus
    MS Defender
Top