Windows 8.1 refuses to sleep

I've read through the first 17 pages of this forum but I'm still having issues.

When I run powercfg last_wake nothing comes up and event viewer has no record of my computer waking up and on the off chance it does Windows has no idea what woke it.

Something else odd is that my power button only puts the computer to sleep probably 25% of the time, the other 75% it does nothing, even when holding the button down to the point of when a force shutdown should happen.

I have an AsRock Z77 Extreme6 motherboard with Intel i7 3770k. I have installed all the newest drivers and software from Asrocks's website. Action Center says to update my INF drivers and chipset drivers though no matter what I do.
 

My Computer

System One

  • OS
    Win 8 Pro.1 w/ media center (Both)
    Computer type
    PC/Desktop
    System Manufacturer/Model
    BYOS (Dekstop)/XPS L502X (Laptop)
    CPU
    i7 3770k (Desktop)/3rd gen i5 (Laptop)
    Motherboard
    ASRock 7zz Extreme 6 (Desktop)/Dell (Laptop)
    Memory
    16 GB (Both)
    Graphics Card(s)
    ATI Radeon HD 6970 (Desktop)/Nvidia GFource 640M (Laptop)
    Sound Card
    N/A
    Monitor(s) Displays
    3/1
    Screen Resolution
    1920x1080/1920x1080
    Case
    Cooler Master Storm Enforcer (Desktop)
    Keyboard
    Logitech G110 (Desktop)
    Mouse
    Razer Naga (Desktop)
    Internet Speed
    30 down - 5 up (If TWC decides to give me what I pay for)
    Browser
    Chrome
    Antivirus
    Malwarebytes/MSE
Zenix, perhaps you could explain more thoroughly what problems you are having. I can see what problems you have with the power button but it is not clear about the rest.

Does your comp sleep but not wake (you mention waking investigation)? This area is not spelt out. Have another go!

Has your comp ever slept properly with the power button, like with another win version?
 

My Computer

System One

  • OS
    Win 8.1
    CPU
    I5
    Motherboard
    ASUS P8H77-M Pro
    Memory
    8GB
After about 2 hours during the day my computer will wake itself up and never go back to sleep on its own. When I run powercfg lastwake after that nothing comes up, just "Wake History [0]"

Pressing the power button does nothing most of the time even though it is set in power options to send the computer to sleep.

Everything worked with Windows 8, just not 8.1.
 

My Computer

System One

  • OS
    Win 8 Pro.1 w/ media center (Both)
    Computer type
    PC/Desktop
    System Manufacturer/Model
    BYOS (Dekstop)/XPS L502X (Laptop)
    CPU
    i7 3770k (Desktop)/3rd gen i5 (Laptop)
    Motherboard
    ASRock 7zz Extreme 6 (Desktop)/Dell (Laptop)
    Memory
    16 GB (Both)
    Graphics Card(s)
    ATI Radeon HD 6970 (Desktop)/Nvidia GFource 640M (Laptop)
    Sound Card
    N/A
    Monitor(s) Displays
    3/1
    Screen Resolution
    1920x1080/1920x1080
    Case
    Cooler Master Storm Enforcer (Desktop)
    Keyboard
    Logitech G110 (Desktop)
    Mouse
    Razer Naga (Desktop)
    Internet Speed
    30 down - 5 up (If TWC decides to give me what I pay for)
    Browser
    Chrome
    Antivirus
    Malwarebytes/MSE
After about 2 hours during the day my computer will wake itself up and never go back to sleep on its own. When I run powercfg lastwake after that nothing comes up, just "Wake History [0]"

Pressing the power button does nothing most of the time even though it is set in power options to send the computer to sleep.

Everything worked with Windows 8, just not 8.1.

I provided a solution that has worked for me & other people on this forum. You can check it out:
http://www.eightforums.com/general-support/28226-windows-8-1-refuses-sleep-49.html#post312742
 

My Computer

System One

  • OS
    Windows 8.1 (64-bit)
    Computer type
    PC/Desktop
Whow! I have been out of the loop from this post for a while!

I am doubtful for all the folks that have "solved" the problem by turning off various things. I have pretty much two identical machines, one is an Ivy Bridge and one is a Haswell, but that is about it. One sleeps with Win8.1 release and one does not. They are running all of the exact same programs, same settings, same logon, same Homegroup, same Skydrive, same third party programs, same windows defender, same firewall settings.

If anything, I would guess that there is something different in HARDWARE rather than any software, especially Windows software.

I too have solved the sleep issue MANY TIMES. Leaving Homegroup solved it, turning off Skydrive solved it, turning off power services solved it, rebooting every night solved it, using a local account solved it. Until they all didn't solve it. The issue always came back! Sometimes I could sleep for 4-5 times, once I went a week but it came back!

If you can get it to work for you, then that is terrific! But most of us here have tried all these latest fixes without luck. Just do not get your hopes up.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS
Whow! I have been out of the loop from this post for a while!

I am doubtful for all the folks that have "solved" the problem by turning off various things. I have pretty much two identical machines, one is an Ivy Bridge and one is a Haswell, but that is about it. One sleeps with Win8.1 release and one does not. They are running all of the exact same programs, same settings, same logon, same Homegroup, same Skydrive, same third party programs, same windows defender, same firewall settings.

If anything, I would guess that there is something different in HARDWARE rather than any software, especially Windows software.

I too have solved the sleep issue MANY TIMES. Leaving Homegroup solved it, turning off Skydrive solved it, turning off power services solved it, rebooting every night solved it, using a local account solved it. Until they all didn't solve it. The issue always came back! Sometimes I could sleep for 4-5 times, once I went a week but it came back!

If you can get it to work for you, then that is terrific! But most of us here have tried all these latest fixes without luck. Just do not get your hopes up.
I have two systems, one 32 bit & the other 64 bit, both were running fine with Windows 8 Pro. When I upgraded to Windows 8.1 (Clean Install), I started to get this Sleep issue. I tried all kinds of things to fix this, but the final solution I found was switching to a Local Account.
 

My Computer

System One

  • OS
    Windows 8.1 (64-bit)
    Computer type
    PC/Desktop
I have also been having problems with both automatic sleep and automatic hibernation since updating my home computer from 8 to 8.1. It worked fine in Windows 8. I have a Dell XPS18 that is < 5 months old and has not given me any other significant issues up to this point.

I have attempted (I believe) every solution suggested in this thread, with no success. I disabled Skydrive using the registry hack that was posted previously (I don't have Pro or Enterprise and didn't feel like paying $100 to get gpedit only to have the solution not work). I went into my power settings and turned off hybrid sleep, and set multimedia to allow the computer to sleep. I disabled all sharing on the computer and ditched HomeGroup (there are no other HomeGroup members on my network). I converted to a Local account per maliksaad's suggestion above. All of these solutions have failed to correct the issue.

One thing I wanted to mention that I did not see in previous discussions in this thread is that I can't even set up automatic hibernation on this computer anymore. The sleep timer is being ignored for sure, but I can't even set a Hibernate time anymore.
What's happening is that something is setting the Hibernate timers for my active power plan to Never, no matter what I do. To be specific: in Power Options, my machine is set to the Dell power plan. When I click Change Plan Settings, then Change Advanced Power Settings, I expand Sleep, then Hibernate, and it's set to Never. I change these to any number at all (preferably 15 on battery and 30 plugged in, but I've tried larger values just for giggles), then Apply, then OK. If I then go immediately back into the advanced power settings for the Dell plan, expand Sleep and then Hibernate, they have changed themselves back to Never.

If I go into the advanced settings for the other power plans which are not active, I can set the Hibernate values to whatever I want, hit OK, then go back into the advanced editor and look at it, and the values I entered are still there. However, if I then select that power plan as my active power plan, and then go back to the advanced settings, the Hibernate settings are once again set to Never.

I tried running powercfg -requests to see if there is a power request issue, but all listings say None. I don't see that being the issue anyway, because I can't even set Hibernate to anything other than Never in the first place.

I thought it might be an admin rights issue, where maybe it can't write my changes to the registry. Problem with that theory is, there's only one user account on the computer and it is designated as an administrator, plus all my other changes to the advanced settings seem to stick (whether they actually kick in is a different story). This is the same reason I don't think my AV is responsible - if my AV were locking my settings, it would be locking all of them, not just the Hibernate timers. I did try disabling my AV anyway, but no dice.

I even tried creating a brand new power plan, and I have the same exact problem. Something is looking at my active power plan and actively changing the Hibernate timers to Never. I imagine it's the same thing that's causing it to not sleep (though the "turn off display" timers are working just fine), but I just have absolutely no idea what's causing it at this point. I'm beginning to think it's just something that's broken in 8.1 that MS needs to fix. But if anyone has any other bright ideas, I'm all ears.
 

My Computer

System One

  • OS
    Windows 8.1 Home x64
    Computer type
    Tablet
    System Manufacturer/Model
    Dell XPS 18
    CPU
    Intel Core i7-3537U @ 2 GHz
    Memory
    8 GB
I have two systems, one 32 bit & the other 64 bit, both were running fine with Windows 8 Pro. When I upgraded to Windows 8.1 (Clean Install), I started to get this Sleep issue. I tried all kinds of things to fix this, but the final solution I found was switching to a Local Account.

I concur, problem solved once I switched to local acc. It has been more than a week and sleep timer finally works as intended on 8.1.
 

My Computer

System One

  • OS
    Windows 8.1 pro 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dell XPS 8500 LE
    Memory
    12 gb
    Graphics Card(s)
    ATI Radeon HD 7870 GHz Edition 2GB DDR5
    Hard Drives
    2tb
Update: It appears that sleep mode may be corrected now for me, even though I have switched back to a standard Microsoft account and re-enabled SkyDrive via the registry hack previously posted. However, I am still having the issue where my active power plan, no matter which plan that is, is being set to Never for the automatic hibernate times. Unfortunately I don't know enough about all this to know whether that's related to the sleep issues being discussed, or if that's a truly separate and unique problem.
 

My Computer

System One

  • OS
    Windows 8.1 Home x64
    Computer type
    Tablet
    System Manufacturer/Model
    Dell XPS 18
    CPU
    Intel Core i7-3537U @ 2 GHz
    Memory
    8 GB
Sleep issues in 8.1 and SkyDrive and Non-Microsoft Account

My issue is not unlike most of the other posts. I updated to 8.1 and since then I have been unable to get sleep to work without manually putting the computer to sleep. I have also experienced the issue of the computer waking up whenever it decides its time to wake up even though I have disabled the advanced sleep options regarding responding to 'wake up' both in bios and in advanced windows power configuration dialog box. And like others have reported,, the second computer on my network with windows 8.1 will allow my main computer to sleep if it is on and active. Three other computers have windows 7 and there is no issue with them. My question is how to set up a non-Microsoft account in windows 8.1? I have tried but am informed that you cannot do that with SKYDRIVE. Whenever I disable SkyDrive in my task menu it comes back on immediately! Any suggestions? I don't know why this issue has not been addressed by Microsoft. There is no way to get rid of SkyDrive so it seems I am stuck with a 'broken' computer.

I finally read the post on how to change to local account. Following this change, the system still does not sleep -- unless manually -- and it still wakes up spontaneously! I have switched back to Microsoft account.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    ibuypower
    CPU
    AMD PhenomII x 6 T1100T 3.3
    Motherboard
    Gigabyte Technology GA 890GPA UD3H
    Memory
    16 Gb
    Graphics Card(s)
    AMD HD6900 Series
    Browser
    IE 11
    Antivirus
    Norton Security Suite
I just wanted to pipe in to add that I've been encountering this problem (computer won't sleep on a timer) since upgrading to Windows 8.1 from Windows 8 (both 64 bit) the day it was released. I have read this entire thread thoroughly (as well as several others in other forums) and have tried every single idea which has been brought up and more through testing on my own. I even created a Win8.1 DVD (that was an adventure) and re-installed Win8.1-64 from scratch - no change. I use a Microsoft Account to sign into Windows. As others have posted, after a reboot my computer might sleep a handful of times before eventually hitting the insomnia mark upon which time it won't sleep on a timer again. Manually putting the thing to sleep works fine and the computer stays asleep. I did not have the same problem in Win8-64 or Win7-64.

I have found that only one of two things work reliably for me and these are workarounds, most certainly not solutions. If I SIGN OUT the computer sleeps reliably after the two hour timer I've set passes. I also created a NON MS Account for testing purposes. If I sign into that account the computer sleeps reliably on a timer.

The only other thing I want to try before chalking this up to yet another famous MS bug and moving on is LOCKING the computer instead of actually signing out. I doubt this will work but plan on trying it anyway.

And when I say I've tried everything in this thread, I do mean every single idea with multiple hours of testing for each one. I've been following the thread since close to the day OP posted and just felt I should share my experience to possibly help out as so many others have done.

EDIT:
I just noticed that after signing out from my MS Account, verifying the computer sleeps, then signing back in using the MS Account the computer sleeps again a handful of times, as when I described it does temporarily after a reboot.

EDIT again:
Didn't seem worth making another post for this but using <windows>+L to lock the computer instead of signing out the user did not allow the computer to sleep. This is what I expected would happen.
 
Last edited:

My Computer

System One

  • OS
    Win8.1-64 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Homemade
    CPU
    Intel Core i7/960 3.2GHz Quad
    Motherboard
    ASUS P6T7 WS Supercomputer
    Memory
    Corsair XMS3 12GB DDR3 1600 triple channel
    Graphics Card(s)
    EVGA GeForce (nVidia) GTX 670
    Sound Card
    Creative Sound Blaster X-Fi Titanium Fatal1ty
    Monitor(s) Displays
    Dell U2410
    Screen Resolution
    1920x1200
    Hard Drives
    300GB Intel SSD 320 series;
    600GB Intel SSD 320 series;
    2TB RAID 0 array on an LSI MegaRAID 9260-4i card using 1TB Hitachi SATA drives
    PSU
    Corsair 750W CMPSU-750HX
    Case
    Cooler Master Centurion 690
    Cooling
    Air/fans
    Keyboard
    Logitech G110
    Mouse
    Logitech M500 black laser
    Internet Speed
    58/12
    Browser
    IE11 (64 bit)
    Antivirus
    Windows Defender
    Other Info
    WinXP-32 as a "server" maintaining my household phone system and running Ubuntu Linux as a web server in VMware Workstation. Another copy of Ubuntu running on hardware serving being used for NAS to store imaging backups. And a slow horrid WD MyBook World Edition II NAS device.
Still no improvement for me with yesterday's wave of new updates - so there's at least no definitive solution before 2014. Perhaps Microsoft wants us to sit it out until Windows 9 is released?
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom-built silent Mini-ITX workhorse
    CPU
    Intel Core i7-3770, 4x 3.40GHz
    Motherboard
    ASRock Z77E-ITX
    Memory
    2x8GB GeIL Black Dragon PC3-12800U
    Graphics Card(s)
    Intel HD 4000 (integrated)
    Monitor(s) Displays
    Eizo
    Hard Drives
    Intel SSD 530 240GB, Intel SSD 520 120GB, WD 1TB
    Mouse
    Lenovo Trackpoint Mouse
    Browser
    Firefox, Chrome
    Antivirus
    Windows Defender
Hmmm, I've been following this thread, & others, since the release of 8.1. I originally installed it using the Windows Store & struggled with the 'Sleep' problem so I did a clean install using the ISO which made no difference either. I've tried the fixes mentioned but my Sleep problem always returns. The most success I had was to turn network discovery off, but that made it awkward to access my NAS.
In the end I reinstalled Win 8.0 & my desktop now sleeps perfectly again. I was hoping that MS would issue a fix for this problem so that I could try 8.1 again, but no luck so far.
 

My Computer

System One

  • OS
    Windows 8.0
In the end I reinstalled Win 8.0 & my desktop now sleeps perfectly again. I was hoping that MS would issue a fix for this problem so that I could try 8.1 again, but no luck so far.

Yeppers, that's about what I did too, except that my new HP 500-056 crashed and burned with Windows 8.1 and had to go back to the factory for reinstall/repair of Windows 8.

She's working fine on Win 8, and I'm not afraid of reinstalling 8.1, I just don't want the several headaches it causes . . . For now, I'll stay with Win 8.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    HP Pavilion 500-056
    CPU
    AMD Elite Quad-Core A8-6500
    Memory
    8 GB
    Graphics Card(s)
    AMD Radeon HD 8570D
    Monitor(s) Displays
    Acer 23"
    Screen Resolution
    1920 X 1080
    Hard Drives
    1 TB
    Keyboard
    Logitech Wave K350
    Mouse
    Logitech M510
    Internet Speed
    Fast
    Browser
    Firefox
    Antivirus
    Windows Defender
I've been following this thread for a while and the only thing that worked for me was switching to a local account. I rarely use the app store and find skydrive to unreliable, so not a major issue. I'm just happy It now sleeps when it should.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64bit with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel i7 2600k @ 4.4Ghz @ 1.30v
    Motherboard
    Asus P8P67 Deluxe
    Memory
    Corsair Dominator GT DDR3 16gb
    Graphics Card(s)
    2 x ATI HD6970 (Crossfire)
    Monitor(s) Displays
    LG E2251 x 3 - 22"
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung SSD 840 Pro, 250Gb
    Seagate Barracuda 500Gb x 3
    PSU
    Coolermaster Silent Pro Gold 1000W Modular
    Case
    Coolermaster HAF962
    Cooling
    Megahalems
    Keyboard
    Logitech K520
    Mouse
    Logitech Performance MX Mouse (Darkfield)
    Internet Speed
    120Mb Down/12Mb Up
    Browser
    Firefox 39.0
    Antivirus
    Kaspersky Total Security
    Other Info
    Logitech 5.1 Speaker System
    Logitech T650 Touchpad
Good news, Microsoft has resolved this issue in today's Windows 8.1 updates.
 

My Computer

System One

  • OS
    Windows 8.1 (64-bit)
    Computer type
    PC/Desktop
Good news, Microsoft has resolved this issue in today's Windows 8.1 updates.


I have not yet updated my computers, but it is possible that you are correct. Apparently, the following update was included with this month's updates. I don't know if it fixes our problems or not, but it was the only one that I saw which seemed like a possible fix:

KB2909528 - Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2-based computer never enters a DRIPS

I'm very curious to know if any one else had performed the updates and had any success? It would be a relief to finally hear some positive news!

Note: This update is included as part of update rollup KB2903939.




Interestingly, I also saw that there was an update for Skydrive (KB2913320). However, I'm not sure that it is related to our problems though.

Also, I read this paper from Microsoft about a new technology called "Connected Standby". This sounds really promising: Introduction to Connected Standby
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.
Good news, Microsoft has resolved this issue in today's Windows 8.1 updates.

O . . . K . . .

How like Microsoft to never acknowledge the problem, then quietly go about fixing the problem without even telling us they're working on it. That is, if your information is correct.

I'll wait a few days to hear from others in this thread.

Now I'm wondering if MS will quietly fix the NumLock problem . . .
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    HP Pavilion 500-056
    CPU
    AMD Elite Quad-Core A8-6500
    Memory
    8 GB
    Graphics Card(s)
    AMD Radeon HD 8570D
    Monitor(s) Displays
    Acer 23"
    Screen Resolution
    1920 X 1080
    Hard Drives
    1 TB
    Keyboard
    Logitech Wave K350
    Mouse
    Logitech M510
    Internet Speed
    Fast
    Browser
    Firefox
    Antivirus
    Windows Defender
Not for me

Good news, Microsoft has resolved this issue in today's Windows 8.1 updates.
The update you cite has done nothing for my issue -- my computer still refuses to sleep and continues to wake up spontaneously after it is manually put to sleep.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    ibuypower
    CPU
    AMD PhenomII x 6 T1100T 3.3
    Motherboard
    Gigabyte Technology GA 890GPA UD3H
    Memory
    16 Gb
    Graphics Card(s)
    AMD HD6900 Series
    Browser
    IE 11
    Antivirus
    Norton Security Suite
Been a while! Welcome to Tomdaws and magilla to the Eightforums. Check out the tutorials on the site, they are terrific!

I too have noticed a couple of things after the latest update. Suddenly my Newegg app is running again so MS did something to fix it as I have not changed anything with it.

As for sleep, I THINK it is sleeping now. It certainly is not doing so quickly as it still takes a few minutes with the hard drive light flashing away randomly and sometimes showing a lot of activity. But it is progress!

As someone posted to turn off logging into MS Live, I turned that off and uninstalled a program called Tuneup Utilities that "cleans the drive".

As for folks like magilla, check out post #168 on page 17 that has the MOST COMMON reasons why the computer will not sleep. It sounds like you have the network adapter allowing wake ups in the device manager-properties-advanced power setting enabled.

As with ALL "fixes" we have posted, time will tell if it is really fixed!
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS
Back
Top