Windows 8.1 refuses to sleep

Yep, I am just about sleeped out as well. Thanks to all for the testing and comments. I, too, will keep looking on here but have lost confidence that I can find the cause.

For me, it's disable the Power svc and carry on.
 

My Computer

System One

  • OS
    Win 8.1
    CPU
    I5
    Motherboard
    ASUS P8H77-M Pro
    Memory
    8GB
Same here, I feel lucky to have stumbled on this forum. The local account with skydrive shut down solution for sleep timer works for me. I will stick to it until something better comes up!
 

My Computer

System One

  • OS
    Windows 8.1 pro 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dell XPS 8500 LE
    Memory
    12 gb
    Graphics Card(s)
    ATI Radeon HD 7870 GHz Edition 2GB DDR5
    Hard Drives
    2tb
Right ladies...

I have a solution to this problem. It isn't a permanent fix, in fact it isn't a fix at all, but it's a reliable workaround.

First, download WIZMO, which is a .Net command executor for the command line in Windows 7 and 8, it's designed to implement .NET features instead of Rundll32, which corrupts the stack in newer Windows OSses if you execute power management functions like hibernate and standby from Rundll32 calls.

The link for WIZMO is here:
https://www.grc.com/WIZMO/WIZMO.HTM

1) Place WIZMO in your PATH (i.e. System32 or whatever path you like which is in the environment variables.)
2) Go to CPanel -> Power Options -> Change When Sleeps -> Set to Never
3) Go to Task Scheduler and create a task.
4) Set task to run whether logged on or not with highest privileges (it needs to run as admin to work).
5) Go to Triggers -> Create Trigger -> On Idle, save and close that applet.
6) Go to Conditions. Select start task only if idle for (x minutes, however long you want). Under wait for idle, select 'Do Not Wait'.
7) Select stop if computer ceases to be idle, select restart if idle state resumes.
8) Go to Settings. Select 'Allow Task to Run On Demand'. Select 'Run as soon as possible ... schedule missed'. Select stop task if runs: longer than 3 days. Select 'If does not stop when requested, force stop'.
9) Go to Actions. Create an Action. Under Action, select 'Start a Program'. Below, type the path to WIZMO (e.g. C:\wizmo.exe). Under arguments, type 'standby' without quotes.
10) Save your task and test. Note: this will only work if your system is capable of being idle and if the background service is enabled for task scheduler (default is enabled on fresh install, if not enable by running services.msc).

I hope that helps everybody. For the guy above, please don't disable power management service as this will cut off your audio and put up your electricity bill significantly as everything will be running at 100% power state.

Comments invited below with questions or thanks.
 

My Computer

System One

  • OS
    Windows 8.1
WhiteTiger, welcome to the eightforums! Check out the tutorials on this site as there are some very good ones.

Thanks for the tip about the Power service. I realized in the advanced power services menu was the listing for processor power throttle down to like 5%. Makes sense that would also get turned off. I also found that I could only play MP3s in stereo instead of 5.1 settings. Good to know.

I did start fooling with task scheduler and realized that I could probably kludge together a timer setup. It would defeat the purpose of the ability to quickly change the sleep timer tho, which is a key thing that I use a lot. Someone pulled up a gem that turned on an extra timer in the advanced sleep setting that seemed to work as well, but again involved more steps to change than I was willing to make every time I wanted to give myself more time before sleep (it's buried in here somewhere in all these posts, I swear!).

I just leave my sleep set to 3 hours and use the power button which I am getting very used to. If sleep does work, great! otherwise, I will manually sleep it the next I am on the computer.

Thanks folks for the attaboys. We gave it a GREAT run for the money and I am amazed at the creativity and sheer perversity which we tackled the problem!
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security
I too have have mostly given up on fixing my sleep problem, for now. I have put too much time into this without resolution. Disabling Skydrive has helped but is not the answer. Interesting that my PC will sleep reliably as long as I do not have a browser open. Any browser open will stop sleep. Well, since I always have multiple browser windows open, my PC never sleeps unless I remember to force sleep. Well, that's the problem, I usually walk away from my desk and forget. I too am trying to develop a habit of forcing sleep. Thanks for all of the help here. I will continue look here for a permanent solution. It really bothers me that my Win 8.1 laptop sleeps without fail and I can't figure this out for my desktop.
 

My Computer

System One

  • OS
    win 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    dell xps 8500
morning... mine is still slightly unreliable with skydrive disabled..... so I have finally taken the step of unlinking my account from my Microsoft account. The is an easy way, without creating a new login, or creating a new profile (I have read blogs which say that's the way)...

steps

1. Go to the user accounts settings window (settings from metro, change pc settings at the bottom, then accounts on the right.)2. Instead of creating a new account, select "Your Account."
3. Select "Disconnect" under your email address.
4. Enter your MS Live password.
5. Enter your local user account name and password.
6. You are now back to a local user account
 

My Computer

System One

  • OS
    Windows 8 X64
    Computer type
    PC/Desktop
    CPU
    Intel i5
    Motherboard
    ASUS p755d-deluxe
    Memory
    8Gb
    Graphics Card(s)
    ATI 6700
Rob, did me no good to go to a local account (and I tried many times). Right now, I am back to where I was (Logged into MS Live, Skydrive enabled, Homegroup enabled, etc) and I sleep just about as much BEFORE I did all that. Don't bother.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS
Tried the whitetiger workaround. Didn't work. Manually running the task invokes sleep so it is not the action bit that is wrong.

The long and short of it for me seems to be that the idle state is not being recognised. And asking the scheduler to detect the idle state doesn't change the basic defect. This conclusion is also reinforced with the screen shutoff when running a video.

Ho hum. Back to ground zero.
 

My Computer

System One

  • OS
    Win 8.1
    CPU
    I5
    Motherboard
    ASUS P8H77-M Pro
    Memory
    8GB
I don't want to pop any bubbles, but I have to confirm that Windows 8.1 isn't broken. All the troubles I had with it, came from third party software and drivers it seems.

How did I manage to fix it.

Well, I went back to Windows 8 (the image I made just before upgrading to 8.1.)

From this point, I uninstalled all the programs I knew that had trouble with 8.1.

- Adobe Creative Cloud
- Adobe Dreamweaver CC
- Oracle VirtualBox
- iolo System Mechanic
- anti-virus software (my case AVG.)

And also some other programs that had accumulated during the year, especially if any toolbars had managed to get installed. I did this with Revo Uninstaller, because this program also deletes the stuff that stays behind in the Registry and maps on the hard disk.

And then, I did my upgrade again from the store.

SkyDrive worked just fine and my Apps as well. This problem was solved immediately.


After I was done checking, I managed to install the Adobe software again. There was an update for the Creative Cloud software, and I knew that Dreamweaver could be installed, it only couldn't be installed before the upgrade. I believe the other CC Adobe software causes the same problems as well. So, uninstalling before the upgrade is the best way to go.


I then tried my sleep function for a full day, before I added any other software. It worked for me, until the next day. In the morning, when I woke up the PC, it was suddenly stuck. My screen stayed black while the PC started but didn't do anything. Obviously a crash of something, but I couldn't find any information about it in the logs.

Then I deactivated Hyper sleep. Same result the next day. I then deactivated Hibernation, again same result the next day. Although, I did notice that the tasks the PC had to do in the morning, had been done. So, the PC only crashed after I invoked it to wake up.


This could have several causes, although, because it seemed that my PC did try to wake up but that my screen didn't receive the wake up call, I decided to look for new drivers for my Graphic card. It's an AMD Radeon HD 5800 Series, btw. I found the Catalyst Control Center version 13.9 and installed it on my PC.


And from that moment on, my PC slept and woke up without problems. I reactivated Hibernation yesterday, and this morning, the PC woke up again as when Windows 8 was on it. :)


The only thing I noticed, that is different from before, is that as long as my TV is on, which is connected with a HDMI cable to the PC, the PC stays awake as long as I'm watching it. :) Now, for me, this isn't a bad thing, because I have also some stuff on the PC that I sometimes watch through the network connection with my Cable digicorder. In the past, I had to get up to start my PC if I wanted to watch something on it. :) And, the good thing is, after I shutdown my TV and Cable box, it takes about 2 minutes for my PC to go to sleep.


For me, it seems Windows 8.1 wasn't the guilty one, but some of the other software that I had installed that I now have removed from my PC. Btw, Oracle's VisualBox 4.3.2 isn't buggy anymore. I presumed it was, because my PC didn't go to sleep after installing it, but I was watching TV while I waited it to go to sleep. At that point, I didn't knew this kept my PC awake.


The Toshiba laptop, I also reinstalled again by removing everything from my PC and to do a clean install. It has less software on it and doesn't take too long to reinstall.

On my Acer netbook, I could reverse the things iolo System Mechanic had done to it, and after I had done this and removed the software, it works now also as it should.


During the whole process, I made one little mistake. I did most of my troubleshooting on the Toshiba laptop, and when I had done a clean install, for some stupid reason, I had installed iolo System Mechanic on it without thinking. :( If I hadn't done that, maybe I had found a solution much earlier. Slap to the head! ;)


I hope that you guys can find a solution for your problems as well. At least, I can confirm now that Windows 8.1 can work as it should, if you can find the guilty party.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 32/64
    Computer type
    PC/Desktop
With regards to software being a potential issue, I don't really have that much installed (none of the stuff that I see other people having to uninstall or play with to get sleep to work right). And it is all the same programs I had when running Win 8 which did actually sleep as needed.

That being said, since 8.1 is newer, there could still be incompatibilities with software that worked fine under 8. I don't know...
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel i7-3770K
    Motherboard
    Asus P8Z77-V PRO
    Memory
    G.SKILL Ripjaws X Series 32GB 240-Pin DDR3 1600
    Graphics Card(s)
    EVGA GeForce GTX 550
    Sound Card
    Motherboard.
    Monitor(s) Displays
    Dell U2711 & 2707WFP
    Hard Drives
    Crucial MX100 512GB SSD x1
    Hitachi 4TB 5200rpm HD x4
    PSU
    Seasonic X-660
    Case
    CoolerMaster CM690 II Advanced USB 3.0 version
    Keyboard
    Logitech K800
    Mouse
    Logitech Performance MX
    Antivirus
    Eset NOD 32
I was having the same issue but when I switched to a 'Local Account', the issue was resolved.
 

My Computer

System One

  • OS
    Windows 8.1 (64-bit)
    Computer type
    PC/Desktop
I was having the same issue but when I switched to a 'Local Account', the issue was resolved.
I switched to a local account an hour ago and my comp slept reliably with a 35ish sec delay. (In my view, anything more than 7 sec is very suspicious, but, hey, this was reliable).

Until I tried the video play test. This, too, was reliable. It reliably slept at around 95 sec (one min plus the 35 sec delay). This is a bit different than previously as it now goes into sleep mode whereas, before, it only blanked the screen.

Once again, failure rules the day! It just is not picking the idle state properly.

@Rudy. Thanks for the further input. I don't seem to have the already discovered problem programs but there must be something here that is problematic. But, even when started in Diagnostic mode (minimal things running), it still is not right.

Cheers, all, and keep smiling!!
 

My Computer

System One

  • OS
    Win 8.1
    CPU
    I5
    Motherboard
    ASUS P8H77-M Pro
    Memory
    8GB
Is this issue still happening with the OP or are there new OPs with this issue?
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.
Well, I guess there is workaround around this, but you need to choose witch feature you can sacrifice.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Motherboard
    ASUS P5Q SE PLUS
It's the Windows, not the third-party software. The issue is with the SkyDrive app. I have fresh-installed Windows 8.1 three times. I did not update, did not install any third-party software, but still the same problem. I have tried this on 2 PCs, same issue.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 (64-bit)
    Computer type
    PC/Desktop
I tested another thing. I killed the 'SkyDrive Sync Engine Host' process and after that, the computer was able to go into sleep right at the chosen time. By the way the [FONT=Segoe UI, Arial, sans-serif]HomeGroup is off too[/FONT]

[FONT=Segoe UI, Arial, sans-serif]Just turning off the [/FONT]HomeGroup[FONT=Segoe UI, Arial, sans-serif] didn't solve the issue. You definitely need to kill [/FONT]the 'SkyDrive Sync Engine Host' process.
 

Attachments

  • sleep_issue.jpg
    sleep_issue.jpg
    92.7 KB · Views: 98
Last edited:

My Computer

System One

  • OS
    Windows 8.1 (64-bit)
    Computer type
    PC/Desktop
maliksaad, I firmly believe that there is more than one problem source which is why we can't find the one solution. I don't have the skydrive sync svc going, and no homedrive set up, but I still have the sleep problem.
 

My Computer

System One

  • OS
    Win 8.1
    CPU
    I5
    Motherboard
    ASUS P8H77-M Pro
    Memory
    8GB
Back
Top