Windows 8.1 refuses to sleep

VooDoo

New Member
Messages
21
Hi,

Hope someone can help me.

Windows 8.1(full fresh install) will not go to sleep/shut down etc. This has been happening since I installed 8.1 a few weeks back. It works/worked fine in Windows 7 and windows 8.0 till this install. I have narrowed it down to the Ethernet Chipset ( on board Realtec RTL8110 SC )

Through all the threads on here, W7 and Vista sites and the rest of the tech sites around the web I have tried most things over the past few weeks. All the settings in the divice manager the powercfg commands etc etc. Disabling in device manager does not help either

Then today I have found out, in an almost eureka moment, that when you take the Ethernet Cable out of the computer............it goes to sleep. :shock: Why did I not try this before? ? ? When I remove the cable from the router, it stays awake when plugged in at the computer end.


I am out of ideas and patience!!! Your help or ideas appreciated!

Thanks

Edit to add: Once asleep it stays that way and if I get it to sleep by other means - PWR Button\Sleep Option in W 8.1, it stays sleeping.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 - Win10
    Computer type
    PC/Desktop
    CPU
    i7 4770
    Memory
    12MB
    Hard Drives
    Samsung 840 - 500GB

Deihmos

New Member
Messages
59
Hi everyone,

I've been reading this thread and searched the net for long about this problem, but nothing worked completely for me; Anyway In the past few days I came to a possible solution, I hope.

The problem I had regarding the auto-sleep was only due to "srvnet" driver that sometimes (randomly) keeps the power request stuck even with no network activity at all (eg disconnecting LAN cable or disabling NIC); when working correctly, srvnet request disappear after about 3 min.

So I thought that this behavior was caused by a bug in the srvnet driver that doesn't remove the request sometime; in fact when it happens, stopping and restarting the server with "net stop /y srv" and "net start /y srv" commands solves the problem, temporarily.
I also read that some users started to have sleep problems when they upgraded from Windows 8 to Windows 8.1, and that Windows 10 Tech Preview seemed to auto-sleep properly; this gave me an idea.

Since I have Windows 10 TP installed in another PC to test it, I thought to swap the W8.1 srvnet.sys driver with the W10 one.

When I found "srvnet.sys" in "C:\Windows\System32\drivers" folder, I noticed that there are another 2 files regarding network and sharing: srv.sys (Server driver) and srv2.sys.

First I swapped srvnet.sys files, but when I restarted the system the server didn't start at all and the sharing was not working, so I restored the original srvnet.sys;
then I swapped srv2.sys and the result was the same so I restored the original one;
at the end I swapped srv.sys driver and... finally everything seemed to work well!

I kept this configuration for about a week and srvnet never got stuck in power request;
so I decided to do a countercheck, swapping srv.sys with original W8.1 driver and I didn't had to wait too much before the srvnet power request got stuck forever, again.

In a nutshell, all you have to do to try this solution is to swap the W8.1 "srv.sys" file located in "C:\Windows\System32\drivers" directory with the W10 TP one.

I attached a zip containing the one I took from my W10 system.
Note that to do this you have to take ownership of the file and be sure that you have the full control (read and write) of it (there are thousands guides on how to do this).


View attachment 58865

Also, would be interesting doing the same with the "srv.sys" from Windows 8, but i couldn't find it.

I hope this could help someone. :)

Bye!

This is a good find. I always had problems with that driver keeping the PC awake for a very long time but replacing the file solved it. I always knew there was a bug but never understood why it was never fixed.

I switched my HTPC to a local account and turned off file sharing and did not have any issues with sleep. I wonder if I use a online account and replace srv driver and turn on file sharing if it will solve the sleep issues? I can do without an online account on my HTPC. When I used an online account on the HTPC sometimes the PC wouldn't sleep even though nothing was requested.
 

My Computer

System One

  • OS
    Windows 8.1

EnricoS

New Member
Messages
9
Hi everyone,

I've been reading this thread and searched the net for long about this problem, but nothing worked completely for me; Anyway In the past few days I came to a possible solution, I hope.

The problem I had regarding the auto-sleep was only due to "srvnet" driver that sometimes (randomly) keeps the power request stuck even with no network activity at all (eg disconnecting LAN cable or disabling NIC); when working correctly, srvnet request disappear after about 3 min.

So I thought that this behavior was caused by a bug in the srvnet driver that doesn't remove the request sometime; in fact when it happens, stopping and restarting the server with "net stop /y srv" and "net start /y srv" commands solves the problem, temporarily.
I also read that some users started to have sleep problems when they upgraded from Windows 8 to Windows 8.1, and that Windows 10 Tech Preview seemed to auto-sleep properly; this gave me an idea.

Since I have Windows 10 TP installed in another PC to test it, I thought to swap the W8.1 srvnet.sys driver with the W10 one.

When I found "srvnet.sys" in "C:\Windows\System32\drivers" folder, I noticed that there are another 2 files regarding network and sharing: srv.sys (Server driver) and srv2.sys.

First I swapped srvnet.sys files, but when I restarted the system the server didn't start at all and the sharing was not working, so I restored the original srvnet.sys;
then I swapped srv2.sys and the result was the same so I restored the original one;
at the end I swapped srv.sys driver and... finally everything seemed to work well!

I kept this configuration for about a week and srvnet never got stuck in power request;
so I decided to do a countercheck, swapping srv.sys with original W8.1 driver and I didn't had to wait too much before the srvnet power request got stuck forever, again.

In a nutshell, all you have to do to try this solution is to swap the W8.1 "srv.sys" file located in "C:\Windows\System32\drivers" directory with the W10 TP one.

I attached a zip containing the one I took from my W10 system.
Note that to do this you have to take ownership of the file and be sure that you have the full control (read and write) of it (there are thousands guides on how to do this).


View attachment 58865

Also, would be interesting doing the same with the "srv.sys" from Windows 8, but i couldn't find it.

I hope this could help someone. :)

Bye!

This is a good find. I always had problems with that driver keeping the PC awake for a very long time but replacing the file solved it. I always knew there was a bug but never understood why it was never fixed.

I switched my HTPC to a local account and turned off file sharing and did not have any issues with sleep. I wonder if I use a online account and replace srv driver and turn on file sharing if it will solve the sleep issues? I can do without an online account on my HTPC. When I used an online account on the HTPC sometimes the PC wouldn't sleep even though nothing was requested.

Hi Deihmos, this seems good, is everything else working fine after replacing the file on you PC? And for how long are you testing it?

About your HTPC, you should try, you can always revert back.

Regarding the case in which nothing appears in power requests but the system doesn't sleep anyway, it happened to me too, but I found out that it was due to some maintenance tasks that the system starts when idle or due to syncing tasks (especially when using online account);
anyway I simply have let end these tasks and the system sleeped fine, very rarely they could take some time but nothing to worry about.
 

My Computer

System One

  • OS
    Windows 8.1 x64

Deihmos

New Member
Messages
59
How much time? I have left it for over 48 hrs and it does not end. Using a local account has solved it.

Changing the file did not cause any problems and does not solve the problem with sleeping with online accounts. I have tried it.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1

bru

Member
Member
Messages
149
Seems as if Win 8.1 is extremely sensitive when it comes to sleep.

After some tweaks my Win 8.1 laptop has been sleeping reliably. I started using Chrome as my browser and I noticed right away the computer would not sleep. A check of powercfg -requests showed Chrome.exe as the culprit. I set an override and of course the computer now sleeps. On my Win 7 machines Chrome doesn't cause a sleep issue.

Googling I saw a few reports of Chrome.exe causing this issue on various systems, but it did not seem widespread. Wondering why it caused an issue for me?
 

My Computer

System One

  • OS
    Windows 7 Home Premium on 2 Windows 8.1 on 1
    Computer type
    PC/Desktop

NCguy

New Member
Power User
Messages
286
Seems as if Win 8.1 is extremely sensitive when it comes to sleep.

After some tweaks my Win 8.1 laptop has been sleeping reliably. I started using Chrome as my browser and I noticed right away the computer would not sleep. A check of powercfg -requests showed Chrome.exe as the culprit. I set an override and of course the computer now sleeps. On my Win 7 machines Chrome doesn't cause a sleep issue.

Googling I saw a few reports of Chrome.exe causing this issue on various systems, but it did not seem widespread. Wondering why it caused an issue for me?

Are you by any chance hosting a google cloud printer on that pc?
 

My Computer

System One

  • OS
    W8.1 Pro 64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom Build Desktop
    CPU
    Core I7-4770 Haswell
    Motherboard
    Intel DH87RL
    Memory
    16GB
    Graphics Card(s)
    Onboard 4600 with (3) DVI monitors
    Sound Card
    On board
    Monitor(s) Displays
    (3) 19" LG L1942PE DVI
    Screen Resolution
    1280 x1024
    Hard Drives
    HD Green 4TB

    Samsung SSD

bru

Member
Member
Messages
149
Are you by any chance hosting a google cloud printer on that pc?
No. Not even signed in to my Google account.

Under power requests it specifically shows:

EXECUTION:
[PROCESS] \Device\HarddiskVolume4\Program Files (x86)\Google\Chrome\Application\
chrome.exe
Uploading data.

Even when I just have one Chrome tab open, on Yahoo or whatever.
 

My Computer

System One

  • OS
    Windows 7 Home Premium on 2 Windows 8.1 on 1
    Computer type
    PC/Desktop

NCguy

New Member
Power User
Messages
286
Are you by any chance hosting a google cloud printer on that pc?
No. Not even signed in to my Google account.

Under power requests it specifically shows:

EXECUTION:
[PROCESS] \Device\HarddiskVolume4\Program Files (x86)\Google\Chrome\Application\
chrome.exe
Uploading data.

Even when I just have one Chrome tab open, on Yahoo or whatever.

I know chrome changed a while back and now there's a piece that stays resident and in the tray. I'm not sure though if it does this for all configurations. Maybe that has something to do with it?
 

My Computer

System One

  • OS
    W8.1 Pro 64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom Build Desktop
    CPU
    Core I7-4770 Haswell
    Motherboard
    Intel DH87RL
    Memory
    16GB
    Graphics Card(s)
    Onboard 4600 with (3) DVI monitors
    Sound Card
    On board
    Monitor(s) Displays
    (3) 19" LG L1942PE DVI
    Screen Resolution
    1280 x1024
    Hard Drives
    HD Green 4TB

    Samsung SSD

ACraigL

New Member
Messages
6
In a nutshell, all you have to do to try this solution is to swap the W8.1 "srv.sys" file located in "C:\Windows\System32\drivers" directory with the W10 TP one.

I just wanted to take a minute to thank you for this. My situation was actually a bit unique, as compared to what I had read elsewhere. My computer had absolutely no issues sleeping, but because it had been operating for well over a year, I began to see some performance issues. It's at this point I usually reinstall the OS. I was "smart enough" to have created a clean-install image so I could do this rapidly. Oddly, sleep was an issue from the get-go once the image was up and running.

srvnet was an issue, but the powercfg override was not working (I recall that fixed it in the past). Disabling IPv6 got me half-way there, as it would sleep, but only the first time. After a wakeup, it would not go back to sleep again. I happened upon this post and tried the netstop/start on the service. Shocker! It fell back to sleep on its own. I figured that was enough to try your replacement driver.

I did so, tested, and everything continued to work as expected. I then began adding items back into the mix (keyboard, mouse, background apps, foreground apps) one at a time and each time, sleep continued.

What I don't understand is why, with the same code base/install, this became a problem now, when it was not before, particularly when using the same configuration, software and hardware. I'm not sure I'll ever know, but very happy that this is finally working the way it should. Thanks again for the information and the replacement driver.
 

My Computer

System One

  • OS
    Windows 8.1

EnricoS

New Member
Messages
9
In a nutshell, all you have to do to try this solution is to swap the W8.1 "srv.sys" file located in "C:\Windows\System32\drivers" directory with the W10 TP one.

I just wanted to take a minute to thank you for this. My situation was actually a bit unique, as compared to what I had read elsewhere. My computer had absolutely no issues sleeping, but because it had been operating for well over a year, I began to see some performance issues. It's at this point I usually reinstall the OS. I was "smart enough" to have created a clean-install image so I could do this rapidly. Oddly, sleep was an issue from the get-go once the image was up and running.

srvnet was an issue, but the powercfg override was not working (I recall that fixed it in the past). Disabling IPv6 got me half-way there, as it would sleep, but only the first time. After a wakeup, it would not go back to sleep again. I happened upon this post and tried the netstop/start on the service. Shocker! It fell back to sleep on its own. I figured that was enough to try your replacement driver.

I did so, tested, and everything continued to work as expected. I then began adding items back into the mix (keyboard, mouse, background apps, foreground apps) one at a time and each time, sleep continued.

What I don't understand is why, with the same code base/install, this became a problem now, when it was not before, particularly when using the same configuration, software and hardware. I'm not sure I'll ever know, but very happy that this is finally working the way it should. Thanks again for the information and the replacement driver.

Hi,
I'm happy that my solution helped you too (so far:))!

Although it is very strange that the srvnet issue started only after you reinstalled the OS, it is more or less what happened to me; everything was working fine for about a year since W8.1 installation, then srvnet suddenly started to prevent the auto sleep, and that without any HW or SW changes. I think this is going to remain a mystery:huh:.
 

My Computer

System One

  • OS
    Windows 8.1 x64

willsMC1

Why Am I Doing This?
Messages
23
Location
Tucson, Arizona

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Sony Vaio VPCEB-13FX
    CPU
    Intel i5
    Memory
    4gb
    Graphics Card(s)
    None
    Monitor(s) Displays
    Built In
    Screen Resolution
    1366x768
    Hard Drives
    5tb
    Internet Speed
    75mb/s
    Browser
    Chrome
    Antivirus
    Windows Defender

ACraigL

New Member
Messages
6
In a nutshell, all you have to do to try this solution is to swap the W8.1 "srv.sys" file located in "C:\Windows\System32\drivers" directory with the W10 TP one.

I just wanted to take a minute to thank you for this. My situation was actually a bit unique, as compared to what I had read elsewhere. My computer had absolutely no issues sleeping, but because it had been operating for well over a year, I began to see some performance issues. It's at this point I usually reinstall the OS. I was "smart enough" to have created a clean-install image so I could do this rapidly. Oddly, sleep was an issue from the get-go once the image was up and running.

srvnet was an issue, but the powercfg override was not working (I recall that fixed it in the past). Disabling IPv6 got me half-way there, as it would sleep, but only the first time. After a wakeup, it would not go back to sleep again. I happened upon this post and tried the netstop/start on the service. Shocker! It fell back to sleep on its own. I figured that was enough to try your replacement driver.

I did so, tested, and everything continued to work as expected. I then began adding items back into the mix (keyboard, mouse, background apps, foreground apps) one at a time and each time, sleep continued.

What I don't understand is why, with the same code base/install, this became a problem now, when it was not before, particularly when using the same configuration, software and hardware. I'm not sure I'll ever know, but very happy that this is finally working the way it should. Thanks again for the information and the replacement driver.

Hi,
I'm happy that my solution helped you too (so far:))!

Although it is very strange that the srvnet issue started only after you reinstalled the OS, it is more or less what happened to me; everything was working fine for about a year since W8.1 installation, then srvnet suddenly started to prevent the auto sleep, and that without any HW or SW changes. I think this is going to remain a mystery:huh:.

Grrr. Spoke too soon. I got a day out of it,, but it is not sleeping again. No idea why. I'm sure a reboot would help, but this getting SO irritating.
 

My Computer

System One

  • OS
    Windows 8.1

EnricoS

New Member
Messages
9
Hi AcraigL,

when it doesn't suspend automatically, you could try to detach the LAN cable and then wait for the auto-sleep timeout; if it now sleeps, then something is really being shared.
Before replacing the driver, my system wouldn't sleep even with no LAN cable connected, so it's worth a try;).
 

My Computer

System One

  • OS
    Windows 8.1 x64

ACraigL

New Member
Messages
6
Hi AcraigL,

when it doesn't suspend automatically, you could try to detach the LAN cable and then wait for the auto-sleep timeout; if it now sleeps, then something is really being shared.
Before replacing the driver, my system wouldn't sleep even with no LAN cable connected, so it's worth a try;).


Disconnecting the LAN cable definitely allowed to sleep. After some poking around I noticed that the network and sharing settings was set to control access via a homegroup, even though I never joined one. I set that to username/password, but also altogether disabled file and printer sharing from all profiles.

Still never slept.

Then I had an epiphany. I have a media center HTPC and I recalled that I had some media libraries to share my PC. I removed those from the HTPC, and sure enough the computer is sleeping properly again. The easiest things are so often overlooked. Thanks for pointing me in the direction that solved my issue!
 

My Computer

System One

  • OS
    Windows 8.1

BazzaG

Member
Messages
52
Oh dear, I thought I would never have to come back to this thread.

For 11 months, almost to the day since I last did a full re-install of Windows 8.1.1 (6th June 2014), my PC has been sleeping just fine.

Over that time in terms of hardware, networked devices, etc. nothing has changed. I can almost say the same for software installed on all the PC's in the house. On the 3rd of May I installed a bunch of Windoz updates, all of 'em, "optional". Since then bl##dy SRVNET has reared it's ugly head again. Not to mention several hard system failures which occur shortly after the PC has gone to sleep:

The computer has rebooted from a bugcheck.
The bugcheck was: 0x0000009f (0x0000000000000003, 0xffffe0015fbec060, 0xffffd00143fe9960, 0xffffe00165b608f0).

I really thought all this was behind me.
 

My Computer

System One

  • OS
    Windows 8.1.1 PRO 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Homebuilt
    CPU
    Intel BX80646I54670 Core i5-4670
    Motherboard
    ASUS H87M-PRO
    Memory
    Corsair Vengeance LP CML16GX3M2A1600C9 16GB (2x8GB)
    Graphics Card(s)
    Onboard
    Sound Card
    Onboard
    Monitor(s) Displays
    Samsung SyncMaster PX2370
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung 840 Pro 256GB SSD + about 12 Seagate HDD's of various sizes (used for video archiving)
    PSU
    Silverstone Strider 550W Gold ST55F-G
    Case
    Silverstone GD05B (HTPC Style Case)
    Cooling
    Stock Intel
    Keyboard
    Logitech
    Mouse
    Logitech
    Internet Speed
    Cable
    Antivirus
    Bitdefender 2014 AV
    Other Info
    Lite-on IHES312 Blu-Ray

ACraigL

New Member
Messages
6
Oh dear, I thought I would never have to come back to this thread.

For 11 months, almost to the day since I last did a full re-install of Windows 8.1.1 (6th June 2014), my PC has been sleeping just fine.

Over that time in terms of hardware, networked devices, etc. nothing has changed. I can almost say the same for software installed on all the PC's in the house. On the 3rd of May I installed a bunch of Windoz updates, all of 'em, "optional". Since then bl##dy SRVNET has reared it's ugly head again. Not to mention several hard system failures which occur shortly after the PC has gone to sleep:

The computer has rebooted from a bugcheck.
The bugcheck was: 0x0000009f (0x0000000000000003, 0xffffe0015fbec060, 0xffffd00143fe9960, 0xffffe00165b608f0).

I really thought all this was behind me.

Could you just do a system restore to that date and see if it returns to normal behavior?
 

My Computer

System One

  • OS
    Windows 8.1

ACraigL

New Member
Messages
6
Hi AcraigL,

when it doesn't suspend automatically, you could try to detach the LAN cable and then wait for the auto-sleep timeout; if it now sleeps, then something is really being shared.
Before replacing the driver, my system wouldn't sleep even with no LAN cable connected, so it's worth a try;).


Disconnecting the LAN cable definitely allowed to sleep. After some poking around I noticed that the network and sharing settings was set to control access via a homegroup, even though I never joined one. I set that to username/password, but also altogether disabled file and printer sharing from all profiles.

Still never slept.

Then I had an epiphany. I have a media center HTPC and I recalled that I had some media libraries to share my PC. I removed those from the HTPC, and sure enough the computer is sleeping properly again. The easiest things are so often overlooked. Thanks for pointing me in the direction that solved my issue!


I thought I was out of this, but it's still not sleeping on a daily basis. If I reboot, it seems fine, but at some point during the night, it refuses to sleep. I found a suspect entry in the event viewer:

Process C:\Windows\System32\svchost.exe (process ID:3272) reset policy scheme from {381b4222-f694-41f0-9685-ff5bb260df2e} to {381b4222-f694-41f0-9685-ff5bb260df2e}

Event ID: 12
Source: UserModePowerService​

Once this occurred, no sleep after that. Unfortunately, since this is a generic process, I'm kind of stuck on where to go from here.
 

My Computer

System One

  • OS
    Windows 8.1

BazzaG

Member
Messages
52
Could you just do a system restore to that date and see if it returns to normal behavior?

Not unless Windows did a "system" backup itself & from my experience it causes too many other problems, given that a "system" backup is not really a proper backup. Personally I would only do a system restore in an emergency.

However, I did a full system backup using Macrium Reflect before hand installing the updates. If things get really bad, I will consider going back after I've copied various stuff that I've created since then.

I did log the changes made to my PC by the updates and SRVNET wasn't changed.

The NET start & stop cmds in EnricoS post work a treat.
 

My Computer

System One

  • OS
    Windows 8.1.1 PRO 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Homebuilt
    CPU
    Intel BX80646I54670 Core i5-4670
    Motherboard
    ASUS H87M-PRO
    Memory
    Corsair Vengeance LP CML16GX3M2A1600C9 16GB (2x8GB)
    Graphics Card(s)
    Onboard
    Sound Card
    Onboard
    Monitor(s) Displays
    Samsung SyncMaster PX2370
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung 840 Pro 256GB SSD + about 12 Seagate HDD's of various sizes (used for video archiving)
    PSU
    Silverstone Strider 550W Gold ST55F-G
    Case
    Silverstone GD05B (HTPC Style Case)
    Cooling
    Stock Intel
    Keyboard
    Logitech
    Mouse
    Logitech
    Internet Speed
    Cable
    Antivirus
    Bitdefender 2014 AV
    Other Info
    Lite-on IHES312 Blu-Ray

EnricoS

New Member
Messages
9
I thought I was out of this, but it's still not sleeping on a daily basis. If I reboot, it seems fine, but at some point during the night, it refuses to sleep. I found a suspect entry in the event viewer:

Process C:\Windows\System32\svchost.exe (process ID:3272) reset policy scheme from {381b4222-f694-41f0-9685-ff5bb260df2e} to {381b4222-f694-41f0-9685-ff5bb260df2e}

Event ID: 12
Source: UserModePowerService​

Once this occurred, no sleep after that. Unfortunately, since this is a generic process, I'm kind of stuck on where to go from here.

Hi ACraigL,

since, as you sad, disconnecting the LAN cable allows it to sleep, when the system is not sleeping automatically you could try these commands in the CMD (Administrator): "openfiles" and "net session"; they will show all the active sharings.

Hi BazzaG,

The NET start & stop cmds in EnricoS post work a treat.

since these commands are working for you, you could try to replace the srv.sys driver that i posted here,
if you haven't already.

Bye!
 

My Computer

System One

  • OS
    Windows 8.1 x64

ACraigL

New Member
Messages
6
Hi ACraigL,

since, as you sad, disconnecting the LAN cable allows it to sleep, when the system is not sleeping automatically you could try these commands in the CMD (Administrator): "openfiles" and "net session"; they will show all the active sharings.

Thanks. Those commands revealed nothing useful (or at all, frankly). The good news is that my PC is sleeping once again. I changed 2 more things -- or maybe it just got tired of me messing with everything and finally nodded off :rolleyes: -- and it's been working for a few days now.


  1. (likely the solution) I changed my login from an online to a local account. It was historically a local account. I think some app suckered me into changing it and I forgot about it.
  2. (maybe?) I installed the Logitech SetPoint software for my wireless keyboard/mouse. This was the same hardware I had prior to windows reinstall, but I never bothered to put this on and was on previously. Perhaps it handles power events better than the windows drivers for this product?

Thanks for all the tips. Crazy it was this challenging.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1

EnricoS

New Member
Messages
9
Hi ACraigL,

since, as you sad, disconnecting the LAN cable allows it to sleep, when the system is not sleeping automatically you could try these commands in the CMD (Administrator): "openfiles" and "net session"; they will show all the active sharings.

Thanks. Those commands revealed nothing useful (or at all, frankly). The good news is that my PC is sleeping once again. I changed 2 more things -- or maybe it just got tired of me messing with everything and finally nodded off :rolleyes: -- and it's been working for a few days now.


  1. (likely the solution) I changed my login from an online to a local account. It was historically a local account. I think some app suckered me into changing it and I forgot about it.
  2. (maybe?) I installed the Logitech SetPoint software for my wireless keyboard/mouse. This was the same hardware I had prior to windows reinstall, but I never bothered to put this on and was on previously. Perhaps it handles power events better than the windows drivers for this product?

Thanks for all the tips. Crazy it was this challenging.

Hi,


I'm quite sure that your problem is no more related to sharing and srvnet etc; maybe changing to a local account solved your problem because the system isn't performing synchronization tasks anymore.
In fact many synchronization and planned maintenance tasks prevent the system to sleep automatically, even without "power requests"; also, I think, these task are usually performed when the system is idling, just when we want to make it sleep.
Logitech driver/software will help for sure but I think that the auto-sleep works well with Windows bundled drivers. Good luck!!:D
 

My Computer

System One

  • OS
    Windows 8.1 x64
Top