• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Windows 8.1 fails after Windows Updates installed


Lazbel

New Member
Posts
2
#1
Hello everyone. After i made a research about my problem, i finally came here, hoping that someone might have an answer to what is happening to my laptop (a Samsung Chronos Series 7 laptop).

Some days ago (august 24th), i recieved a notification from Windows Update telling me that update KB2919355 was ready to be installed as soon as i restarted my machinne. Another update was also avaliable, "Advanced Micro Devices, Inc. - Graphics Adapter WDDM 1.3 AMD Radeon 8600/8700M" (that's my dedicated graphics card, the other one is an Intel HD Graphics 4000). I installed both updates to my computer and the system automatically created a restore point, then i clicked "Update and restart" button. Every time since the installation of these updates, my laptop fails when tries to startup, all i can see is Samsung logo and those funny dots moving in circles indicating that files are loading and, after that, a black screen without any mouse cursor or pretty much anything else. At this point the keyboard, the touchpad and other devices don't respond, so i end up holding down the power button to end my laptop's misery.
The next thing i did was to use the startup repair tool that comes with Windows 8, without any positive results. I tried booting into safe mode, safe mode with networking, safe mode with command prompt, run sfc /scannnow, run bootrec /fixboot, bootrec /fixbcd, bootrec /rebuildbcd, chkdsk and none of this methods could pass that annoying black screen. Then, i used the system restore, roll backed graphics card drivers and everything worked fine (apparently). However, whenever i shutdown or restart my computer, that black screen comes back the next time i startup Windows, even if i refused install KB2919355 and my graphics card updates before shuting down. Something curious is that even when i choose to shutdown, my laptop restarts instead.
The only way i can still use my laptop is by repairing startup using system restore, and then, never shuting down or restart, but only hibernate or put to sleep my computer when i'm not using it.

I think the source of the problem is that for some reason, windows tries to load the new graphics card drivers instead the ones it really has (the ones within my restore point files). But those are just my guesses.
I would like to know if anybody else have experienced something like this before i try to refresh my computer (something i don't want to do, because it will be difficult to reinstall all the 3rd party programs i have right now).
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Samsung Chronos Series 7
    CPU
    Intel Core i7 3635QM CPU @ 2.40 GHz
    Graphics Card(s)
    AMD Radeon HD 8600/8700M, Intel HD Graphics 4000
    Sound Card
    Realtek High Definition Audio
    Antivirus
    Kaspersky Pure 3.0

Lazbel

New Member
Posts
2
#2
Well, Windows Update notified me about a new update, i installed it, rebooted my laptop and the problem apparently is solved.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Samsung Chronos Series 7
    CPU
    Intel Core i7 3635QM CPU @ 2.40 GHz
    Graphics Card(s)
    AMD Radeon HD 8600/8700M, Intel HD Graphics 4000
    Sound Card
    Realtek High Definition Audio
    Antivirus
    Kaspersky Pure 3.0