• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Windows 8.1 doesn't detect Windows Phone (Lumia 1020)


sukle

New Member
Posts
7
#1
Hi,

Ever since the latest WP update (currently on WP8.1 Update, firmware 3051.50009.1424.0003) my Windows 8.1 PC doesn't detect my Lumia. I get "The latest device malfunctioned and Windows does not recognize it. There is also Unknown USB device (Device descriptor request failed) listed under Universal Serial Bus controllers in Device manager. Nothing under Portable devices section.

What I have tried:
- replacing usb cable (using original one) -> no luck
- soft reset phone -> no luck
- turning the phone off and plug it in -> no go
- manually uninstalling the device from device manager, restarting the PC and try again -> nope
- plugged brother's lumia 930 -> works like a charm

I'm slowly losing my mind, I have no idea what else can I try.

Any help is appreciated.

Edit. Ok so I've got access to laptop, plugging my phone there and the same problem happens at first - the device can't be recognized but a few moments later somehow it gets recognized and connected. The problem seems to be on my PC, can anyone help me out completely removing all the Phone drivers (including registry entries) so I can install them fresh?

Thanks
 

My Computer

System One

  • OS
    Windows 8.1

Joan Archer

Gadget Mad Granny.
VIP Member
Power User
#2
Welcome to the forum sukle.

Can't really help with your problem but a few ideas while you wait for one of the experts to come along and help.

Is your phone completely up to date ? Do you have the 8.1 update on your phone ?

I only have the Lumia 520, I have no problems with this on my 8.1 Update 1 Asus Notebook, I've just plugged it in so of course it's charging, usually charge through the mains adapter so very rarely plug it into the computer as everything can be done from the phone.

Sorry I can't help but I'm sure someone will be along soon to help you out. :)
 

My Computer

System One

  • OS
    Windows 7 Ultimate SP1 32 bit/ Windows 8.1 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Zoostorm/ Asus K55A Notebook
    CPU
    Intel Core 2 Duo E4600 @ 2400 MHz
    Motherboard
    Foxconn 45CMX/45GMX/45CMX-K
    Memory
    2048 MB (2 x 1024 DDR2-SDRAM)/8GB DDR3
    Graphics Card(s)
    Intel Corp 82945G Integrated Graphics Controller
    Sound Card
    Onboard Realtek
    Monitor(s) Displays
    Hanns.G HH221 22" Widescreen
    Screen Resolution
    1920 x 1080
    Hard Drives
    ExcelStor (250GB)
    Keyboard
    Microsoft Natural Ergonomic Keyboard 4000 (UK)
    Mouse
    Microsoft Optical Wheel Mouse
    Internet Speed
    Just under 4MB download it's ADSL.
    Other Info
    Epson Stylus SX415 All-in-one Printer,
    Seagate Expansion 500GB External Desktop Drive

OldGuyGeek

New Member
Power User
Posts
216
#3
Try going to device manager and view your USB connections. Plug in the phone. You should see the device appear, but you should another 'usb composite device' appear under USB Serial Bus Controllers.

With the phone plugged in see if you can uninstall it. Be careful if you already have one listed. You don't want to uninstall the wrong one. You can check the device id in the properties.

Once it uninstalls, the system will ask to reboot. Unplug the phone and let it reboot. Once booted, plug in the phone it should go into the 'installing device drivers' routine.

Hopefully it will find your phone, detect the correct hardware and install the right drivers.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built
    CPU
    Intel I-7 860
    Motherboard
    Asus P7B
    Memory
    8GB
    Graphics Card(s)
    Nvidia 580
    Monitor(s) Displays
    Acer (Primary), Asus (secondary), Sony TV (third)
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston 128GB SSD Windows 8 Boot Drive
    WD Black 1 TB (2 ea)
    WD Red 3 TB
    WD Black 500GB
    Keyboard
    MS 1000
    Mouse
    MS Flip
    Internet Speed
    Verizon FIOS 35/35
    Browser
    IE 11, Google Chrome, Firefox, Opera, Safari
    Antivirus
    Windows 8 Defender (MS Security Essentials)

sukle

New Member
Posts
7
#4
Hi,

I have tried everything described above with no luck whatsoever. So I did a complete format of my PC (it was long overdue anyway). Long story short, I plugged in my Lumia, the drives were successfully installed and everything is working as intended.

I'm sorry I can't offer a "cleaner" solution.

Cheers
 

My Computer

System One

  • OS
    Windows 8.1

Users Who Are Viewing This Thread (Users: 0, Guests: 1)