What's new

Solved Window not stretching to fit screen at lower resolutions.

Wyatt

New Member
Basically, my laptop has a dense native resolution of 3200x1800, meaning there is literally no way I can expect to run games at my native resolution without horrible lag.

But when I try to run the game at a lower resolution (in fullscreen) it doesn't stretch the image, but rather just leaves a tiny rectangle among a massive black border.

Dark Souls II specifically, will stretch, and fit beautifully.
Dragon Age: Inquisition, however, doesn't.




Also, its worth noting some programs act like this as well.
For example, Steam renders appropriately (although fuzzy), but origin renders 'to-scale', and looks tiny.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

theveterans

New Member
Member
On some games/programs , you must use 100% scaling and low res, e.g. 720p to get rid of the black boxes around since those programs don't support scaling.
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64 with Media Center
    Computer type
    Tablet
    System Manufacturer/Model
    Surface Pro 3
    CPU
    Core i5 4300U @ 1.9 GHz
    Motherboard
    Surface Pro 3
    Memory
    8092 MB DDR3-L 1.35 V SDRAM @ 1600 MHz
    Graphics Card(s)
    Intel HD 4400 @ 200 MHz
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    Built-in 3:2 display
    Screen Resolution
    2160 x 1440
    Hard Drives
    256 GB SSD + 128 GB micro SD
    PSU
    36 Watt power brick
    Cooling
    Active
    Keyboard
    On Screen Keyboard
    Mouse
    Surface pen
    Internet Speed
    300 / 20 TWC
    Browser
    IE 11 Metro, IE 11 Desktop
    Antivirus
    Windows Defender

Wyatt

New Member
Can you elaborate on that some?
I don't mess with this stuff, and I've never had this problem before, so I'm kind of flying blind here.

What exactly am I doing to fix the issue?
Like, how do I affect scaling and all that?
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Berton

Member
Power User
Some monitors have a setting for filling the screen. But your System Specs gives nothing about the computer's hardware.
 

My Computer

System One

  • OS
    WinXP, WinVista, Win7, Win8.1, Win10, Linux Mint 20
    Computer type
    PC/Desktop
    System Manufacturer/Model
    2 Customs and 12 OEM/Brands
    CPU
    AMD and Intel

Wyatt

New Member
Its a Lenovo Yoga 2 Pro running windows 8.1

8 Gigs of ram, 64 bit OS, with an i7 processor.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Berton

Member
Power User
Since it's a Notebook/Laptop there's fewer choices than with a Desktop with its separate monitor.
 

My Computer

System One

  • OS
    WinXP, WinVista, Win7, Win8.1, Win10, Linux Mint 20
    Computer type
    PC/Desktop
    System Manufacturer/Model
    2 Customs and 12 OEM/Brands
    CPU
    AMD and Intel

Wyatt

New Member
Yeah, I'm not that new, I obviously know that there are fewer options, but that doesn't contribute to the issue at all.


If you don't know exactly how to help me, that's fine, I get it, but I asked for information.
I'm sorry if I come off crass, and I don't mean to sound rude, but I would just like some actual help. This is bothering me a lot, because as I said, there are clearly exceptions, and I want to know what's causing this and how it works, that way I can figure out how best to deal with it.
There is clearly a system that renders certain things at a different scale to make up for the density of my screen, which is small in size, but has a very high resolution. Can someone tell me about that? Because i'll bet that has something to do with my problem.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Berton

Member
Power User
Revisiting my response shows it isn't all there, salients points in the second paragraph are missing and your 'crass' may be called for based upon what is visible, or not.
 

My Computer

System One

  • OS
    WinXP, WinVista, Win7, Win8.1, Win10, Linux Mint 20
    Computer type
    PC/Desktop
    System Manufacturer/Model
    2 Customs and 12 OEM/Brands
    CPU
    AMD and Intel

Wyatt

New Member
Do you want to explain this to me or not?
I just want to understand why these programs behave this way.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

sygnus21

Member
VIP Member
Power User
I don't have a full explanation which solves your issue, but as you noted, your issue is the extreme resolution here 3200x1800. Most programs today aren't quite ready for such high resolutions and will behave strangely, especially games. If you Google your resolution you will notice posts where people have issues at that res. Here's a thread here regarding gaming at that res - Problems Gaming at 3200x1800 (New Razer Blade 14)

As to your solution, the obvious thing is to try and find a resolution that works best for you in the meantime. As one poster in the thread I linked to suggested, you may have to downgrade your resolution for gaming purposes.

Sorry if there is no easy answer but these extreme resolutions on these new monitors are going to be problematic until programmers account for them on a regular basis.

With regards to Dragon Age: Inquisition, which I have, it appears the highest "native" resolution of the game is 1900 x 1200. However this article here may be of some interest - Dragon Age: Inquisition 5k screenshot gallery.

Aside from trying that tweak you could try figuring out what the aspect ratio (the proportional relationship between a monitor's height and width) of your monitor is and choose a lower resolution in that range through your video card settings that might suit all your gaming needs.

Good luck.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built by me
    CPU
    Haswell i7-4770K
    Motherboard
    Gigabyte G1 Sniper 5 (BIOS F9)
    Memory
    Corsair Dominator Platinum 32 gig (1866MHz)
    Graphics Card(s)
    Sapphire R9-280 Vapor X
    Sound Card
    Soundblaster ZXR
    Monitor(s) Displays
    NEC PA242W - 24 inch
    Screen Resolution
    1920 x 1200
    Hard Drives
    Samsung 512gig 850 Pro SSD (OS), Samsung 256gig 840 Pro SSD (photo editing), Western Digital Caviar Black 2TB HD
    PSU
    EVGA Supernova 1000 G2
    Case
    Cooler Master HAF X
    Cooling
    Corsair H100i Closed Loop Cooler
    Keyboard
    Logitech Wireless Wave
    Mouse
    Logitech Performance MX
    Internet Speed
    High Speed
    Browser
    IE11
    Antivirus
    Norton Security
    Other Info
    RAM Speed: 1866MHZ @ 9-10-10-27-2T, 1.5v

Wyatt

New Member
Thanks for the advice sygnus, but I actually just solved the issue.

Turns out the problem was DPI. My laptop defaults at 250% DPI to compensate for the large resolution. Some programs apparently are only set to run at 100% and so don't compensate for it.

All I have to do is turn down the DPI when I want to play certain games and it fills the screen perfectly.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Hopachi

Polyhedric Stellation
VIP Member
Pro User
I see it's solved. DPI hmmm...

You can also try to disable DPI only for the particular game/program through compatibility mode:

dpi-comp.png

That way you won't need to disable and restore 250% DPI, if it looks good for the rest.

Also, if your main (on cpu) graphics is Intel, you can enable scaling/stretching in the graphics options:

intel-scaling.png

Applies to lower than native resolutions.
 

My Computer

System One

  • OS
    Windows 10 x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP Envy DV6 7250
    CPU
    Intel i7-3630QM
    Motherboard
    HP, Intel HM77 Express Chipset
    Memory
    16GB
    Graphics Card(s)
    Intel HD4000 + Nvidia Geforce 630M
    Sound Card
    IDT HD Audio
    Monitor(s) Displays
    15.6' built-in + Samsung S22D300 + 17.3' LG Phillips
    Screen Resolution
    multiple resolutions
    Hard Drives
    Samsung SSD 250GB + Hitachi HDD 750GB
    PSU
    120W adapter
    Case
    small
    Cooling
    laptop cooling pad
    Keyboard
    Backlit built-in + big one in USB
    Mouse
    SteelSeries Sensei
    Internet Speed
    slow and steady
    Browser
    Chromium, Pale Moon, Firefox Developer Edition
    Antivirus
    Windows Defender
    Other Info
    That's basically it.

sygnus21

Member
VIP Member
Power User
Thanks for the advice sygnus, but I actually just solved the issue.

Turns out the problem was DPI. My laptop defaults at 250% DPI to compensate for the large resolution. Some programs apparently are only set to run at 100% and so don't compensate for it.

All I have to do is turn down the DPI when I want to play certain games and it fills the screen perfectly.

Yeah I should have mentioned DPI as I saw that in another post I was reading regarding high res screens. Anyway glad you got your issue resolved.

Looks like this is something I'll have to add to my gaming guide here: Tips on Troubleshooting Game Issues.

Peace :cool:
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built by me
    CPU
    Haswell i7-4770K
    Motherboard
    Gigabyte G1 Sniper 5 (BIOS F9)
    Memory
    Corsair Dominator Platinum 32 gig (1866MHz)
    Graphics Card(s)
    Sapphire R9-280 Vapor X
    Sound Card
    Soundblaster ZXR
    Monitor(s) Displays
    NEC PA242W - 24 inch
    Screen Resolution
    1920 x 1200
    Hard Drives
    Samsung 512gig 850 Pro SSD (OS), Samsung 256gig 840 Pro SSD (photo editing), Western Digital Caviar Black 2TB HD
    PSU
    EVGA Supernova 1000 G2
    Case
    Cooler Master HAF X
    Cooling
    Corsair H100i Closed Loop Cooler
    Keyboard
    Logitech Wireless Wave
    Mouse
    Logitech Performance MX
    Internet Speed
    High Speed
    Browser
    IE11
    Antivirus
    Norton Security
    Other Info
    RAM Speed: 1866MHZ @ 9-10-10-27-2T, 1.5v

Wyatt

New Member
Unfortunately, this still doesn't work on Dragon Age.
The other games are fixed, but the issue still persists on just that one.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

sygnus21

Member
VIP Member
Power User
Did you look through the like I provided for DA:I? I though I saw a tweak you could try through the game's command console.

On a side note, this is one gorgeous looking game. I can only imagine what it looks like on a high res monitor. And I'm not even running it in DX11, but AMD's Mantle instead, and the game runs and looks absolutely amazing.

Anyway hope you get your issue sorted.

Peace :cool:
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built by me
    CPU
    Haswell i7-4770K
    Motherboard
    Gigabyte G1 Sniper 5 (BIOS F9)
    Memory
    Corsair Dominator Platinum 32 gig (1866MHz)
    Graphics Card(s)
    Sapphire R9-280 Vapor X
    Sound Card
    Soundblaster ZXR
    Monitor(s) Displays
    NEC PA242W - 24 inch
    Screen Resolution
    1920 x 1200
    Hard Drives
    Samsung 512gig 850 Pro SSD (OS), Samsung 256gig 840 Pro SSD (photo editing), Western Digital Caviar Black 2TB HD
    PSU
    EVGA Supernova 1000 G2
    Case
    Cooler Master HAF X
    Cooling
    Corsair H100i Closed Loop Cooler
    Keyboard
    Logitech Wireless Wave
    Mouse
    Logitech Performance MX
    Internet Speed
    High Speed
    Browser
    IE11
    Antivirus
    Norton Security
    Other Info
    RAM Speed: 1866MHZ @ 9-10-10-27-2T, 1.5v

Wyatt

New Member
I've found some pretty simple work arounds actually.

There is apparently an option that I never gave much thought to in Dragon Age itself that allows you to change the resolution it renders at without modifying the actual screen resolution. I forgot exactly what it was called, but its very useful for this.

Alternatively I found that decreasing the computer's resolution along with the DPI setting also gets the game to properly use fullscreen at any resolution I want.

Obviously, the game will look muddier, since its not native resolution, but I can still play it well enough to enjoy it.
It doesn't have to be perfect, that's why I have a desktop. I just wanted to be able to play it on the go, since its such a huge game.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

theveterans

New Member
Member
On some games/programs , you must use 100% scaling and low res, e.g. 720p to get rid of the black boxes around since those programs don't support scaling.

I mentioned this 4 days ago. Sorry if I didn't elaborate but 100 % scaling is 96 DPI and 720p is 1280 x 720 resolution. That's what you have to do when running low res games on high settings.
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64 with Media Center
    Computer type
    Tablet
    System Manufacturer/Model
    Surface Pro 3
    CPU
    Core i5 4300U @ 1.9 GHz
    Motherboard
    Surface Pro 3
    Memory
    8092 MB DDR3-L 1.35 V SDRAM @ 1600 MHz
    Graphics Card(s)
    Intel HD 4400 @ 200 MHz
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    Built-in 3:2 display
    Screen Resolution
    2160 x 1440
    Hard Drives
    256 GB SSD + 128 GB micro SD
    PSU
    36 Watt power brick
    Cooling
    Active
    Keyboard
    On Screen Keyboard
    Mouse
    Surface pen
    Internet Speed
    300 / 20 TWC
    Browser
    IE 11 Metro, IE 11 Desktop
    Antivirus
    Windows Defender
Top