• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Win 8 AMD Switchable Graphics FAQ


popeye

New Member
VIP Member
Guru
United States

Posts
3,090
Hi, haven't been here for a while. I have an HPdv7-4283cl with a Radeon 6370 graphics card w/ intel hd
After much trouble, trial and error, I was able to get Windows eight to work by running the drivers in compatibility mode. I've had intermittent problems, mostly with heat, but now internet explorer is acting up and I'd like to try upgrading to 8.1. The last time I tried it, the drivers didn't work and I was left with a blank screen. I was able to get to safe mode (aargh!) and restore back to win 8.0.
Does anyone know of a fix for this? I tried to update the drivers - the Radeon did, but when I did the Intel I was back with a blank screen - agin safe mode and revert to old driver.

If someone has found a fix can you point me to it? Thanks a lot - I was helped the last time and was able to help a couple of others here. Greatly appreciated!
For drivers I would try leshcatlabs.net. What I used when I had an Intel+Amd laptop and they worked very well. Also me sure your BIOS is set to dynamic or switchable.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.

Peterdoubt

Member
Member
Posts
38
Hi, haven't been here for a while. I have an HPdv7-4283cl with a Radeon 6370 graphics card w/ intel hd
After much trouble, trial and error, I was able to get Windows eight to work by running the drivers in compatibility mode. I've had intermittent problems, mostly with heat, but now internet explorer is acting up and I'd like to try upgrading to 8.1. The last time I tried it, the drivers didn't work and I was left with a blank screen. I was able to get to safe mode (aargh!) and restore back to win 8.0.
Does anyone know of a fix for this? I tried to update the drivers - the Radeon did, but when I did the Intel I was back with a blank screen - agin safe mode and revert to old driver.

If someone has found a fix can you point me to it? Thanks a lot - I was helped the last time and was able to help a couple of others here. Greatly appreciated!
For drivers I would try leshcatlabs.net. What I used when I had an Intel+Amd laptop and they worked very well. Also me sure your BIOS is set to dynamic or switchable.

I tried the leshcatlabs drivers when I was first updating to 8.0 but I couldn't get them to work. Are the new ones more stable? Do they work with my machine? And how do you set the bios? Thanks -
 

My Computer

System One

  • OS
    Windows 8

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
I don't know how they will work on your particular machine just that they worked for me back when I had Intel+AMD Acer laptop. You should read the forum there and decide for yourself which version to try.

For BIOS on HP I believe repeatedly tap Esc key on boot, then F10 to get to BIOS.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.

Peterdoubt

Member
Member
Posts
38
That's for the leshcat drivers, right? I'll have to see what the default setting for this machine is. I wonder why the intel driver update didn't work? Oh, well. After my last Windows 8 update, ie10 keeps stopping and trying to restart. I thought maybe the video drivers might be involved. It's always something - I'd go back to Win 7 if I could...
 

My Computer

System One

  • OS
    Windows 8

VBCoder

New Member
Posts
5
Switchable Graphics not working after 14.9 version

Hi,
Few days ago, Raptr informed me that a newer AMD Catalyst driver is available (14.9). After installing it, switchable graphics issues arises as shown in the below image:

Capture.PNG

I uninstalled the graphics driver using AMD cleanup utility and made sure that driver is uninstalled from device manager. I performed clean install then after using Tuneup Utilities to clean any remaining files and of course restarting windows. Same problem exists. I'm not sure what's the problem.

My Graphics card is : AMD Radeon HD 7400M Series / Intel HD Graphics 3000.

Your assistance is appreciated
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    DELL Inspiron N4050
    CPU
    Intel Core i5 2.5 GHz
    Memory
    8 GB
    Graphics Card(s)
    AMD Radeon 7300M Series / Intel HD Graphics 3000
    Browser
    Internet Explorer / Mozilla Firefox / Opera / Google Chrome
    Antivirus
    Bitdefender Total Security
Posts
2
The solution for me.

Guys i've entered to my bios and selected the fixed option in the switcheable graphics menu. i have an hp envy 14 bets edition with amd radeon 6700m and intel graphics hd3000. now in ccc i can select witch gpu i want to use.
i'm sorry for my english i'm from uruguay and we speak spanish here. i hope it works for you too, it has been a rough path haha. i also installed the microsoft update that appers before in this thread.
 

My Computer

System One

  • OS
    windows 8.1
Posts
2
Guys i've entered to my bios and selected the fixed option in the switcheable graphics menu. i have an hp envy 14 bets edition with amd radeon 6700m and intel graphics hd3000. now in ccc i can select witch gpu i want to use.
i'm sorry for my english i'm from uruguay and we speak spanish here. i hope it works for you too, it has been a rough path haha. i also installed the microsoft update that appers before in this thread.
View attachment 52939
 

My Computer

System One

  • OS
    windows 8.1

Haythem91

New Member
Posts
5
Hey Guys!

Toshiba Satellite L50B Windows 8.1 pro 64bit
Intel Core i7 4510
RAM 8 Go
AMD Radeon R7 M260 2GO + Intel HD Graphic 4400


So in Device Manager i have both drivers installed from Toshiba's website

2.png

3.png
Untitled.png

But when i screen resolution>advanced settings i only find the intel internal card with total memory 1.7 gb, and both dedicated and system memories with 0MB

4.png

i tried installing the driver from the amd site but nothing changed, also disabled the intel graphic card but still the amd didn't show up it says microsoft basic display with 253MB total memory.
Any help would be greatly appreciated :)

Edit: I checked the hardware id of both of them and they're not the same.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro

phrozen ghost

Member
Member
Posts
28
Hello,

I am revisiting this thread. I still have my HP Envy 14 1211nr intel hd (1st gen) and amd 5650. I am still having a issue. However, previously I got this to work in earlier in the thread by rolling back to the previous bios update and then loading the drivers. But I actually found a better workaround.... I installed win7 drivers in compatibility mode under windows 8. I am using the drivers from 2010, I will try to update and see what happens. But I can tell you this, switchable graphics with charger removed and back on this works 100 percent. I checked dxdiag and it using the correct drivers as well. Christ I don't know why I didn't try this 2 years ago lol. I did this on a clean install of win 8.1
 

My Computer

System One

  • OS
    windows 8.1 pro x64

Users Who Are Viewing This Thread (Users: 0, Guests: 1)