• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Win 8.1 - TV connected via HDMI not detected as a Display


Posts
9
#1
Hi,
I just did a fresh install of Win 8.1 last week and my TV which is connected via HDMI is not getting detected as a display on my PC. My monitor was detected fine.

When i right click my desktop and go to screen resolution, the TV doesnt show up there even post clicking detect. Same if i go into AMD CCC and click on detect.

However Win 8.1 can detect it. The TV is seen in device manager under digital media device and i can see the TV under Devices and Printers in Control Panel. I've tried troubleshooting it but it says everything is fine.
But I need it to come up as a display so i can use it as a primary display at times or to duplicate display.

I had no such problems with Win 7. It would detect right off the bat.

Things ive tried:-
I've installed the Omega 14.12 drivers and the Beta 15.4 drivers.
I've tried installing them in Win 7 compatibility mode too, but the installer then wouldnt give me the option to install the display driver and the HDMI audio driver.


One thing i notice is that the driver for the TV is provided by Microsoft and the date of the driver is 6/21/2006! So maybe this needs to be updated. I tried to click on update driver but it says my driver is up to date.

I also have all the latest windows updates installed.

so not sure what else to do here.

Please help.
 

My Computer

System One

  • OS
    W7

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#2
The 2006 device driver is simply the generic one which is normal, same one I get when TV is plugged in.
What HDMI port are you using? One on motherboard or one coming directly from GPU? This almost has to be a graphics driver problem.
Why would you try installing drivers in 7 compatibility mode? We are talking 8.1 here right? Have you tried drivers from manufacturers site?
A laptop or desktop? Motherboard and GPU make/model?
So, so many details you've left out.
Would help to have some system specs.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.
Posts
9
#3
I dont have onboard graphics. So video is coming directly from my video card only.

Im using an self assembled desktop. Not from Dell/HP or so. Specs below:-

CPU - Intel Core i5 750
Mobo - Asus P7P55D
Video Card - Sapphire ATI HD 6950 2 GB
RAM - 8 GB Gskill
Storage - 1 TB Seagate SSHD
PSU - Corsair 550W

Microsoft community advised some folks with the same issue like mine to install drivers in Win 7 compatibility as their second display was working in Win 7 but not in Win 8.1.
 

My Computer

System One

  • OS
    W7

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#4
Have you tried the drivers from the Sapphire site? Sapphire Technology Web Site

EDIT: They have 6 different packages listed for your card. I would try them all until you find one that works.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#6
So you didn't try the older ones? Might have to use one. Up to you but I would at least try to see if it works on one of the older ones. Especially since they are the ones the GPU manufacturer has posted.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.