• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Win 8.1 Pro RDP won't accept incoming RDP after restart


Denmark

Posts
3
#1
Hi all!

Yesterday, after my Win 8.1 box did an automatic restart because of updates, I can't connect to it anymore! When I try, the client gives me an error after approx 30 seconds, suggesting that the remote PC might be turned off, or having network related errors! I've been connecting to this machine this way for the last 6 months, and I just doublechecked that incoming RDP is turned on, and a "netstat -a -o" also shows that the port should be listening for connections. I also tried turning the built-in firewall off, no luck.

Anyone with suggestions? I really need RDP, since it's the only way to gain full productivity (ie multiple screens, printing to local printer etc)

/Tommy
 

My Computer

System One

  • OS
    Win 8.1

jimbo45

New Member
VIP Member
Guru
Hafnarfjörður IS

Posts
4,373
#3
Hi there

Firewall settings / outgoing permissions, router outgoing permissions, ports open. ?

Any or all of these could get re-set after an update / re-boot - especially if you made a manual change.

I assume the remote PC hasn't changed and can accept incoming connections.

Try also re-booting your router and check all the parameters again. ISP's also sometimes block ports so you might have to "Tunnel" but that trick is usually only needed from "Work" type computers trying to access your HOME machine.

Routers can block ports so check the setting. Also if you can set up a VM try RDP on a LAN to check at least the machine parameters are correct.

Cheers
jimbo
 

My Computer

System One

  • OS
    Linux Centos 7, W8.1, W7, W2K3 Server W10
    Computer type
    PC/Desktop
    Monitor(s) Displays
    1 X LG 40 inch TV
    Hard Drives
    SSD's * 3 (Samsung 840 series) 250 GB
    2 X 3 TB sata
    5 X 1 TB sata
    Internet Speed
    0.12 GB/s (120Mb/s)
Denmark

Posts
3
#4
Nope, as said nothing was changed on the machine, but after digging around in it (using TeamViewer), I suddenly saw that my ethernet adapter was marked as a public network, which gave me the solution. Changed it to Private, and voila, now everything is back to normal!

I installed a new firewall last Thursday, but AFAIR I was not prompted to select a new network location, and even I was and selected wrong, it beats me why it first gave me problems after a restart 5 days later :/

Well, computers are just computers ;)

/Tommy
 

My Computer

System One

  • OS
    Win 8.1