Win 8.1 on 1GB of RAM and Atom CPU,tweaks and optimization possible?

frozensun

New Member
Messages
3
Hi guys.
I am running Win 8.1 x32 on Asus Transformer T100TA but performance is painfully slow.
Boot up is pretty fast but even with just one Chrome tab opened it freezes and laptop is very slow.
Are there any performance tweaks and optimization because I really don't want to install other OS since this is tablet/touch laptop and not good for Linux ,and Windows 7?
I found some windows debloater but was not able to run it with power shell.
This laptop came preinstalled with Windows 8/8.1.
I'm sending you picture, this is just at boot.
 

Attachments

  • win 8 boot.jpg
    win 8 boot.jpg
    118.2 KB · Views: 111

My Computer

System One

  • OS
    Windows 10
I am running Win 8.1 x32 on Asus Transformer T100TA but performance is painfully slow.
With just 1GB RAM it would be, and unfortunately this model has its RAM soldered in - it cannot be upgraded.

Go to Control Panel > System and click 'Advanced system settings'. Click the Settings button in Performance. Select 'Adjust for best performance' to de-select all options. You may want to re-select 'Smooth edges of screen fonts', but that on its own is not much of a performance hit.

1675012669666.png
 
Last edited:

My Computer

System One

  • OS
    8.1
    System Manufacturer/Model
    Hyper-V
Disable Windows Defender, Windows Search, Diagnostic Services, Sysmain, Windows Update and of course, telemetry.
 

My Computer

System One

  • OS
    Windows 8.1 Professional x64
    Computer type
    PC/Desktop
    CPU
    i7 3770 (non K) @ 4.45 GHZ / Ryzen 5 3600
    Motherboard
    MSI Z77 / MSI B450
    Memory
    16GB DDR3 / 16GB DDR4
    Graphics Card(s)
    GTX 1050 Ti / GTX 970
    Screen Resolution
    x2 1920x1080
    Internet Speed
    10 Mb/s Down | 2Mb/s Up
    Browser
    Google Chrome 109
    Antivirus
    No
    Other Info
    No Windows Update/Windows Defender
I have 8.1 running happily on a little Acer One Netbook, with only 1.5GB of ram, but with a 120GB SSD.
I've disabled all the MS BS, and only run what's 100% needed. Then I do have it tweaked and tuned for MAX performance. Yes, it's still slow, and painfully small and hard to read, but it's a great little traveling companion.
 

My Computer

System One

  • OS
    Win-8.1/Pro/64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Acer X-1200
    CPU
    AMD 2 Core
    Motherboard
    Acer
    Memory
    Crucial, 4GB
    Graphics Card(s)
    NVIDEA GeForce 9200
    Sound Card
    On Board
    Monitor(s) Displays
    24" Acer
    Hard Drives
    Sandisk, SSD 500GB
    PSU
    Acer
    Case
    SFF Slimline
    Keyboard
    emachines 101 key
    Mouse
    Logitech Wireless
    Internet Speed
    5 Meg
    Browser
    Firefox
    Antivirus
    Windows Defender
    Other Info
    Using Classic Shell on Win-8.1 /pro/64
have 8.1 running happily on a little Acer One Netbook, with only 1.5GB of ram, but with a 120GB SSD
I have a little Acer Aspire One AOD270 netbook. Despite the OEM specs saying it only supports up to 2GB RAM, if you install a 4GB stick then it makes 2.99GB available to the OS. That and an SSD is enough to make it capable of running anything up to Windows 11, as in post #1,062 here:


it's still slow, and painfully small and hard to read, but it's a great little traveling companion.
Yes, that's what I use mine for too.
 
Last edited:

My Computer

System One

  • OS
    8.1
    System Manufacturer/Model
    Hyper-V
I have 8.1 running happily on a little Acer One Netbook, with only 1.5GB of ram, but with a 120GB SSD.

a 120gb SSD? weak!
why not a 250gb (or 256gb) SSD or higher?

 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satellite C55Dt-A5306
    CPU
    AMD Quad-Core A6-5200M Accelerated Processor
    Memory
    4 GB
a 120gb SSD? weak!
why not a 250gb (or 256gb) SSD or higher?

120 is enough
 

My Computer

System One

  • OS
    Windows 8.1 Professional x64
    Computer type
    PC/Desktop
    CPU
    i7 3770 (non K) @ 4.45 GHZ / Ryzen 5 3600
    Motherboard
    MSI Z77 / MSI B450
    Memory
    16GB DDR3 / 16GB DDR4
    Graphics Card(s)
    GTX 1050 Ti / GTX 970
    Screen Resolution
    x2 1920x1080
    Internet Speed
    10 Mb/s Down | 2Mb/s Up
    Browser
    Google Chrome 109
    Antivirus
    No
    Other Info
    No Windows Update/Windows Defender
I found some windows debloater but was not able to run it with power shell.
Asking... What script did you find?

Attached a script, before running backup your service configuration and read the comments.

Code:
@echo off

:: Disable CompositeBus Driver
REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\CompositeBus" /V "Start" /F /T REG_DWORD /D 4

:: Disable CDROM Driver ( CD won't function )
REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\cdrom" /V "Start" /F /T REG_DWORD /D 4

:: Disable Windows Error Reporting
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\Windows Error Reporting" /T REG_DWORD /V "Disabled" /D "1" /F

:: Disable Power Throttling
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Power\PowerThrottling" /T REG_DWORD /V "PowerThrottlingOff" /D "1" /F

:: bcdedit
bcdedit /set ems No
bcdedit /set bootems No
bcdedit /set debug No
bcdedit /set hypervisorlaunchtype Off
bcdedit /event off
bcdedit /bootdebug off

:: Disable Volume Shadow Copy and Readyboost Drivers
REG DELETE "HKLM\System\CurrentControlSet\Control\Class\{71a27cdd-812a-11d0-bec7-08002be2092f}" /V "LowerFilters" /F
REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\fvevol" /V "Start" /T REG_DWORD /d "4" /F
REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\rdyboost" /V "Start" /T REG_DWORD /d "4" /F

:: Services
    :: NOTE : No Hyper-V, Printing, Indexing, Bluetooth, Diagnostics, EventLog, Metro Apps

FOR %%I IN (
    DiagTrack
    AppReadiness
    AxInstSV
    AeLookupSvc
    AppIDSvc
    LanmanWorkstation
    workfolderssvc
    wmiApSrv
    wuauserv
    WSService
    W32Time
    WSearch
    WinRM
    WMPNetworkSvc
    lfsvc
    stisvc
    MpsSvc
    Wecsvc
    WerSvc
    WbioSrvc
    FontCache
    WEPHOSTSVC
    wcncsvc
    WcsPlugInService
    VSS
    vm3dservice
    vmvss
    VGAuthService
    TabletInputService
    TapiSrv
    lmhosts
    SENS
    SysMain
    WiaRpc
    svsvc
    sppsvc
    SCPolicySvc
    ScDeviceEnum
    SCardSvr
    LanmanServer
    SensrSvc
    wscsvc
    SamSs
    RemoteAccess
    RemoteRegistry
    UmRdpService
    TermService
    SessionEnv
    RasMan
    RasAuto
    QWAVE
    PcaSvc
    wercplsupport
    PrintNotify
    Spooler
    WPDBusEnum
    PNRPAutoReg
    pla
    p2pimsvc
    p2psvc
    PNRPsvc
    defragsvc
    CscService
    NcaSvc
    Netman
    napagent
    Netlogon
    NetTcpPortSharing
    smphost
    swprv
    MsKeyboardFilter
    MSiSCSI
    wlidsvc
    lltdsvc
    KtmRm
    IEEtwCollectorService
    SharedAccess
    vmicvss
    vmictimesync
    vmicrdv
    vmicheartbeat
    vmicshutdown
    vmicguestinterface
    vmickvpexchange
    hidserv
    HomeGroupProvider
    HomeGroupListener
    hkmsvc
    FDResPub
    fdPHost
    fhsvc
    Fax
    WPCSvc
    Eaphost
    EFS
    MSDTC
    TrkWks
    WdiSystemHost
    WdiServiceHost
    DPS
    DsmSvc
    VaultSvc
    Browser
    PeerDistSvc
    bthserv
    BthHFSrv
    wbengine
    BDESVC
    BITS
    BFE
    AppXSvc
    ALG
    NcbService
    iphlpsvc
) DO (
    REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\%%I" /V "Start" /F /T REG_DWORD /D 4 > NUL 2>&1
)
sc config netprofm depend=/ > NUL 2>&1
sc config NlaSvc depend=/ > NUL 2>&1
sc config Audiosrv depend=/ > NUL 2>&1
sc config AudioEndpointBuilder start= disabled > NUL 2>&1
sc config EventLog start= disabled > NUL 2>&1

pause
 

My Computer

System One

  • OS
    Windows 8.1 Professional x64
    Computer type
    PC/Desktop
    CPU
    i7 3770 (non K) @ 4.45 GHZ / Ryzen 5 3600
    Motherboard
    MSI Z77 / MSI B450
    Memory
    16GB DDR3 / 16GB DDR4
    Graphics Card(s)
    GTX 1050 Ti / GTX 970
    Screen Resolution
    x2 1920x1080
    Internet Speed
    10 Mb/s Down | 2Mb/s Up
    Browser
    Google Chrome 109
    Antivirus
    No
    Other Info
    No Windows Update/Windows Defender
Hi guys.
I am running Win 8.1 x32 on Asus Transformer T100TA but performance is painfully slow.
Old thread, but worth updating.

I've had mixed experiences installing Windows 10 and Windows 8.1 on older devices. By far, Windows 8.1 embedded has been the fastest needing less ram and being quite efficient with the resources. Other than that, a debloated version of Windows 8.1 pro x64.

BUT... I want to describe something relevant with my old Surface 3 that may help with your case (if what I said previously ends up unhelpful)

Bought this Surface 3 second hand, came with Windows 10 latest version (by then), and it was terribly slow (Atom 2G RAM), so I reinstalled Windows 10 1903, it got amazingly better. But over time it became slow (not comparable to the original W10 latest version, but still not the best), so I created a customized Windows 10 version using the official ISO + NLite. I ended up with a very fast Windows 10 personal version (I recommend doing this despite the hard work, instead of downloading weird third party non official versions from the web).

But then, wanted to downgrade to Windows 8.1 (from an official X64 ISO), and it was a terrible experience. I found myself facing many issues others have described: high cpu usage, worse battery life, overheating, blah blah blah. I solved those issues after installing all the drivers and some extra work, but it wasn't what I expected.

So, I went after the official Microsoft recovery for the Surface 3.

This is not only "a different Windows 8.1", it's also fastest, uses less resources, not a single issue!!!. So, what I'm saying is... depending no your case, you may have good luck installing a customized Windows version, or... perhaps the official recovery does wonders instead.

Good luck.
* So far, I've been using my Surface 3 as a brand new device with Windows 8.1, quite fast, quite happy. All my previous 5 Surface were RT (1 and 2)
 

My Computer

System One

  • OS
    Windows 8.1 / Windows 10
Back
Top