• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Will i have to wait? Or is there Display driver for laptop


chris1neji

New Member
Member
Posts
124
#1
I have a Windows 7 laptop, that i Install Windows 8.
I have a Windows 8 on my Toshiba laptop. It has integrated display graphics chip. HD 4200 series from AMD.
It's my laptop that i am using to test out Windows 8. I like the many integration with services anything u guy srecommend?
 

My Computer

System One

  • OS
    Windows 8 Pro 64-Bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    N/A
    CPU
    AMD FX 6300
    Motherboard
    GYGABYTE GA-990FXA-UD3 Rev 3.0
    Memory
    24GB DDR3 (4GB/4GB/8GB/8GB)
    Graphics Card(s)
    Sapphire HD 6850
    Sound Card
    Integrated (Realtek HD Audio)
    Monitor(s) Displays
    3 X 19" monitors
    Screen Resolution
    4580 x 900
    Hard Drives
    WD 80GB
    WD 640GB
    WD 1,000GB
    WD 4,000GB
    PSU
    Rosewill Hive-650
    Case
    Antec 300 V2
    Cooling
    Stock Cooling
    Keyboard
    Saitek Eclipse II
    Mouse
    Logitech G402
    Internet Speed
    D: 60Mbps U: 5Mbps
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    I also have a hub for 6 extra usb port AC powered.
    Microsoft LifeCam 720P
    HP LaserJet Pro M1212NF
    2 x 8 Port GB Switches
    1 X Netgear Router Netgear WNDR3700 v2 W/ DD-WRT
    and Much more

GMan

Banned
Posts
1,851
#2
Hi,

You can install the latest Windows 7 driver for your model from Toshiba's site or mod the .inf for the latest driver from AMD's website.
You'll find option number one the easiest. You might have to use the device manager to install, but probably not.
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

chris1neji

New Member
Member
Posts
124
#3
Drivers where there :)
However sadly my games dont work properly. It's to be expected with a beta.
 

My Computer

System One

  • OS
    Windows 8 Pro 64-Bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    N/A
    CPU
    AMD FX 6300
    Motherboard
    GYGABYTE GA-990FXA-UD3 Rev 3.0
    Memory
    24GB DDR3 (4GB/4GB/8GB/8GB)
    Graphics Card(s)
    Sapphire HD 6850
    Sound Card
    Integrated (Realtek HD Audio)
    Monitor(s) Displays
    3 X 19" monitors
    Screen Resolution
    4580 x 900
    Hard Drives
    WD 80GB
    WD 640GB
    WD 1,000GB
    WD 4,000GB
    PSU
    Rosewill Hive-650
    Case
    Antec 300 V2
    Cooling
    Stock Cooling
    Keyboard
    Saitek Eclipse II
    Mouse
    Logitech G402
    Internet Speed
    D: 60Mbps U: 5Mbps
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    I also have a hub for 6 extra usb port AC powered.
    Microsoft LifeCam 720P
    HP LaserJet Pro M1212NF
    2 x 8 Port GB Switches
    1 X Netgear Router Netgear WNDR3700 v2 W/ DD-WRT
    and Much more

GMan

Banned
Posts
1,851
#4

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

chris1neji

New Member
Member
Posts
124
#5
Battle for middle earth.
It loads up and i can play but during a match a few minutes into it "You have been defeated'.

However i dont dont do anything to lose. It could be anything i dont know
 

My Computer

System One

  • OS
    Windows 8 Pro 64-Bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    N/A
    CPU
    AMD FX 6300
    Motherboard
    GYGABYTE GA-990FXA-UD3 Rev 3.0
    Memory
    24GB DDR3 (4GB/4GB/8GB/8GB)
    Graphics Card(s)
    Sapphire HD 6850
    Sound Card
    Integrated (Realtek HD Audio)
    Monitor(s) Displays
    3 X 19" monitors
    Screen Resolution
    4580 x 900
    Hard Drives
    WD 80GB
    WD 640GB
    WD 1,000GB
    WD 4,000GB
    PSU
    Rosewill Hive-650
    Case
    Antec 300 V2
    Cooling
    Stock Cooling
    Keyboard
    Saitek Eclipse II
    Mouse
    Logitech G402
    Internet Speed
    D: 60Mbps U: 5Mbps
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    I also have a hub for 6 extra usb port AC powered.
    Microsoft LifeCam 720P
    HP LaserJet Pro M1212NF
    2 x 8 Port GB Switches
    1 X Netgear Router Netgear WNDR3700 v2 W/ DD-WRT
    and Much more

GMan

Banned
Posts
1,851
#6
Ya true. That doesn't sound like a video driver issue. I would see if there is an update to the game and patch to latest version.
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

Users Who Are Viewing This Thread (Users: 0, Guests: 1)