• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

WiFi is terrible - please help


Naossoan

Member
Member
Posts
20
#1
Hi all,
Just upgraded to Windows 8 the other night, got Chrome installed and all that and using Chrome right now.
Something that I've noticed that is actually really starting to annoy me is the delay/slow response I get from my internet connection. I'm on WIFI and my router is like 8 feet away. There is a really big difference to Windows 7.


When I load pages there is a noticeable delay from when I click something to when it pops up, to when it actually loads. At worst ~5 seconds. It's worse with any streaming video. There's an annoying, noticeable delay between the page loading and the video starting. When I was on Windows 7 it was pretty much instantaneous, but now it's just really slow. I use Reddit a lot and a good example is even just simply clicking my new mail notification icon. Sometimes it might load up right away, other times it will sit there and I see "sending request" at the bottom and "awaiting response" for several seconds too. This never happened with Windows 7, ever.


Same goes for my actual connection speed as well. I was downloading a game off Steam and it was topping out around 280KBps. Before I changed to Win8 I was getting average 500+ KBps. I'm on DSL so it's not like my connection is shared with anyone else, nor is there anyone else in the home using the connection because I live alone. Same goes for other downloads using SABnzbd etc. My download speeds are just really slow.

I don't know what's up with this but it's really aggravating, makes me want to go back to Win7.
The other thing is when I'm transferring things across the network to or from my Media PC my PC lags like a handsome frog. The mouse pointer gets all jerky when I move it around, clicking stuff is sometimes hit or miss, it's really strange.

I've tried the following to remedy, but none of them helped:


  • Turned off all power saving options for my wireless card (like the card deactivating/shutting off)

  • Upgraded drivers to the official Qualcomm Windows 8 drivers for my wifi card

  • Power mode for my PC itself is on high performance, with everything set to never turn off.
  • un-ticked the "automatically detect settings" box within the Internet Options from Control Panel.

I have a pretty good system here guys and I never had these issues with Windows 7.

Intel i5 3570k
8 GB DDR3 1600
Asus P8Z77-V motherboard has a Qualcomm Atheros Communications Wifi card with externally connecting antenna.

My computer or router has not moved since installing Windows 8.

Anyone else experiencing these issues or know any improvements or remedies to this, save getting a network cable to hook it up physically?

Thanks
 

My Computer

System One

  • OS
    Windows 8

brummyfan

Well-Known Member
VIP Member
Guru
Birmingham

Posts
1,487
#2
Hi Naossoan, welcome to the forums, if you have any security software installed, uninstall that temporarily, reboot and see whether it helps.
 

My Computer

System One

  • OS
    Win 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer Aspire E1-571
    CPU
    i5-3230m
    Motherboard
    Acer Type-2
    Memory
    8GB DDR3 1333MHz
    Graphics Card(s)
    Intel HD 4000
    Sound Card
    High Definiton Audio Device
    Monitor(s) Displays
    Generic
    Screen Resolution
    1366x768
    Hard Drives
    Samsung 850 Pro 256GB
    PSU
    Generic
    Keyboard
    QWERTY
    Mouse
    ELANTECH Touchpad
    Internet Speed
    12.68Mbps
    Browser
    IE11
    Antivirus
    Windows Defender
Posts
5
#3
Hi Naossoan, welcome to the forums, if you have any security software installed, uninstall that temporarily, reboot and see whether it helps.
I'm having the same issue. I uninstalled by security software and rebooted. Still no difference... any suggestions?
 

My Computer

System One

  • OS
    Windows 7
    System Manufacturer/Model Number
    self-built
    CPU
    AMD Penom II X4 955
    Motherboard
    Asus M4A79XTD EVO
    Memory
    16GB DDR3
    Graphics Card(s)
    NVIDEO GeForce GTS250 amd NVIDIA Geforce GT 430

brummyfan

Well-Known Member
VIP Member
Guru
Birmingham

Posts
1,487
#4
Hi jvickers2001,
Welcome to the forums, you could try few things.
1. Switch off the router, leave it for 30secs, switch it on.
2. Go to Network and Sharing centre, click Change Adapter Settings, right click your networks and disable them, reboot and see whether it helps.
 

My Computer

System One

  • OS
    Win 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer Aspire E1-571
    CPU
    i5-3230m
    Motherboard
    Acer Type-2
    Memory
    8GB DDR3 1333MHz
    Graphics Card(s)
    Intel HD 4000
    Sound Card
    High Definiton Audio Device
    Monitor(s) Displays
    Generic
    Screen Resolution
    1366x768
    Hard Drives
    Samsung 850 Pro 256GB
    PSU
    Generic
    Keyboard
    QWERTY
    Mouse
    ELANTECH Touchpad
    Internet Speed
    12.68Mbps
    Browser
    IE11
    Antivirus
    Windows Defender
Posts
5
#5
Hi jvickers2001,
Welcome to the forums, you could try few things.
1. Switch off the router, leave it for 30secs, switch it on.
2. Go to Network and Sharing centre, click Change Adapter Settings, right click your networks and disable them, reboot and see whether it helps.
Thanks for the suggestion. Being the moron that I am, I did not realize that my CPU power was 0% for min and max when plugged in. Changed that and now everything is lightening fast.
 

My Computer

System One

  • OS
    Windows 7
    System Manufacturer/Model Number
    self-built
    CPU
    AMD Penom II X4 955
    Motherboard
    Asus M4A79XTD EVO
    Memory
    16GB DDR3
    Graphics Card(s)
    NVIDEO GeForce GTS250 amd NVIDIA Geforce GT 430

brummyfan

Well-Known Member
VIP Member
Guru
Birmingham

Posts
1,487
#6
Hi jvickers2001,
Welcome to the forums, you could try few things.
1. Switch off the router, leave it for 30secs, switch it on.
2. Go to Network and Sharing centre, click Change Adapter Settings, right click your networks and disable them, reboot and see whether it helps.
Thanks for the suggestion. Being the moron that I am, I did not realize that my CPU power was 0% for min and max when plugged in. Changed that and now everything is lightening fast.
Glad you got it sorted, Thanks for letting us know :thumb:
 

My Computer

System One

  • OS
    Win 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer Aspire E1-571
    CPU
    i5-3230m
    Motherboard
    Acer Type-2
    Memory
    8GB DDR3 1333MHz
    Graphics Card(s)
    Intel HD 4000
    Sound Card
    High Definiton Audio Device
    Monitor(s) Displays
    Generic
    Screen Resolution
    1366x768
    Hard Drives
    Samsung 850 Pro 256GB
    PSU
    Generic
    Keyboard
    QWERTY
    Mouse
    ELANTECH Touchpad
    Internet Speed
    12.68Mbps
    Browser
    IE11
    Antivirus
    Windows Defender