What's new

W8 keeps deleting thumbnail cache (changed folder permission)

Det87

Secret Member
+pushkar1989, it's a late reply, but you can use:

Backup Thumbnails.bat:
Code:
@echo off

:: Choose backup location for "Explorer - Copy":
set location="[I][U]C:\Users\%UserName%\AppData\Local\Microsoft\Windows\[/U][/I]"

:: Go there
cd /d "%location%"

:: Remove previous "Explorer - Copy" backup (2>nul: ignore directory doesn't exist)
rd "Explorer - Copy" /s/q 2>nul

:: Create new one (echo d: copy a directory)
echo d | xcopy "%LocalAppData%\Microsoft\Windows\Explorer" "Explorer - Copy" /y/s/q

Restore Thumbnails.bat:
Code:
@echo off

:: Choose backup location for "Explorer - Copy":
set location="[I][U]C:\Users\%UserName%\AppData\Local\Microsoft\Windows\[/U][/I]"

:: Go there
cd /d "%location%"

:: Kill explorer.exe
taskkill /im explorer.exe /f

:: Copy thumbnails from "Explorer - Copy"
xcopy "Explorer - Copy\thumbcache_*.db" "%LocalAppData%\Microsoft\Windows\Explorer\" /q/y

:: Restart explorer.exe with "start" to auto-close CMD window
start explorer.exe

Attachments below:
 

Attachments

  • Backup Thumbnails.bat
    418 bytes · Views: 15
  • Restore Thumbnails.bat
    440 bytes · Views: 17

My Computer

System One

  • OS
    Arch x64 / Windows 8.1 Pro x64

NuclearMind

New Member
Btw, to have the scripts run silent (no CMD window popping up), use the following VBScript and save it with the .vbs extension:

Code:
Set WshShell = CreateObject("WScript.Shell" )
WshShell.Run chr(34) & "[U][I]C:\Path\to\the.bat[/I][/U]" & Chr(34), 0
Set WshShell = Nothing

Attached:

where to put this file ?
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    PC/Desktop
    Country Flag
    Egypt

war59312

New Member

My Computer

System One

  • OS
    Windows 8.1 x64
    Name
    Will
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom Built
    Memory
    16GB
    Screen Resolution
    1080p
    Occupation
    Student
    Internet Speed
    50Mbps
    Browser
    Chrome Dev
    Antivirus
    NONE!! :D
    Country Flag
    USA
    State/Region Flag
    us south carolina

Mina-Mounir

New Member
I found this on Google search:



I just applied it & will wait to see if it works. :)

Edit- Thumbnail cache disappeard from Disk Cleanup. :)
The size of the cache is 62.5 MBs right now.
I am going to reboot & check it again.
I'll be back.

I'm back.
After restarting, the cache was the same size as before.

It seems to work. :)

Edit- I just noticed similar options are already posted.
I will add a screenshot of permissions to see if they are as others' settings.

A picture:

View attachment 34133
I tried it and I think it's working for me . about day passed and the problem has dissapeared . I hope it continue like this .
Thumbnails are about 95 MB and every thing is fine
I made this account specially to thank you
 

My Computer

System One

  • OS
    Windows 8.1

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top