• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

W8 keeps deleting thumbnail cache (changed folder permission)


Quaresma

Member
Member
Posts
11
#1
Hi.

Normally in windows 7 I would change the folder persmission to deny "detele files and folders", but these options are greyed out on my windows 8. I'm the admin, and even if I log in as super administrator it's still greyed out.

How can I fix this problem and prevent W8 from deleting thumbnail cache?
 

My Computer

System One

  • OS
    W7 x64
Posts
4
#2
I too are having this problem. How can I stop the thumbnails from deleting all the time?
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    HP
    CPU
    i7-2720QM
    Memory
    8 GB
    Graphics Card(s)
    ATI

dyablor

New Member
Tulcea

Posts
11
#3
Hello.
I have the same problem regarding thumbnails in windows 8.
You can change the permissions to a folder following the tutorial posted here: Prevent Windows 8 File Explorer From Deleting Image Thumbnail Cache.
But, anyway, this doesn't solve the problem for me. Win 8 is randomly recreating the cache every 10 to 48 hours. I don't know why this is happening and i couldn't find a fix.
 

My Computer

System One

  • OS
    Windows 8 Enterprise x64
    CPU
    Intel E8200, 2.66 GHz
    Motherboard
    Gigabyte GA-P35-DS3L
    Memory
    4 GB Kingmax 1066 MHz
    Graphics Card(s)
    Nvidia Geforce 8600 GT
    Sound Card
    Realtek
    Monitor(s) Displays
    17" LG L1753S
    Screen Resolution
    1280x1024
    Hard Drives
    Seagate 320 GB
    PSU
    Sirtec 500 W
    Case
    Spire
    Keyboard
    Genius Slimstar 320
    Mouse
    Razer Deathadder
    Internet Speed
    100 Mb/s

Anusha

New Member
Member
Kawasaki, Japan

Posts
108
#4
Looks like they broke it trying to fix something else. I have so far given up looking for a solution. :(
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY
    CPU
    Intel Core i7 4790K @4.5GHz
    Motherboard
    Asus ROG Maximus VII Gene
    Memory
    16GB A-DATA DDR3-2400
    Graphics Card(s)
    Gigabyte GTX 970 Gaming G1
    Monitor(s) Displays
    QNIX QX2710
    Screen Resolution
    2560x1440
    Hard Drives
    Samsung 840 series 250GB
    Toshiba DT01ACA300 3TB (Data)
    Western Digital Caviar Green WD30EZRX-00DC0B0 3TB (Backup)
    PSU
    Silversonte G series 750W
    Case
    Silverstone Sugo SG09
    Cooling
    Noctua NH-U12S
    Keyboard
    Generic
    Mouse
    Logitech G602
    Internet Speed
    200Mbps/200Mbps Fibre
    Browser
    Google Chrome
    Antivirus
    Windows Defender

Drybonz

Member
Member
Posts
75
#5
Has anyone found a working fix for this? I have seen a lot of comments that the permissions fix does not work. Have not seen anything that people are consistently saying fixes this problem.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview

tommygun

New Member
Posts
12
#6
....... changing the permissions didn't work for me either

As far as I understand from the tutorials on changing the file permissions is the thumbnail database limited to a certain size.

Is it possible to change the size value for the thumbnail cache somewhere - If yes, where and how ?

It seems that quiet a lot of Windows 8 users having the same thumbnail cache issue and I hope someone is coming up with a solution soon .......
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    Laptop

tommygun

New Member
Posts
12
#7
Solution Found !

....... in my case I found a solution and hope it will work for others as well.
I experimented a little with the permissions after I did what is subscribed here:

Prevent Windows 8 File Explorer From Deleting Image Thumbnail Cache

I addition to that I deleted the original SYSTEM permissions and changed the new created SYSTEM permissions from "Deny" to "Allow" and configured it like shown in the image below and did the same for my user account permissions.

Capture.jpg

That was it and now the thumbnail cache won't rebuild itself over and over again.
If someone is eager to try it out please leave a comment if it worked or not .......
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    Laptop

dyablor

New Member
Tulcea

Posts
11
#9
Fixed, or not

After applying the fix as tommygun said thumbnails aren't deleted anymore but i keep getting explorer.exe crashes:
Faulting application name: Explorer.EXE, version: 6.2.9200.16433, time stamp: 0x50763312
Faulting module name: thumbcache.dll, version: 6.2.9200.16384, time stamp: 0x501080ee
Exception code: 0xc0000005

So i restored permissions to default value.
 

My Computer

System One

  • OS
    Windows 8 Enterprise x64
    CPU
    Intel E8200, 2.66 GHz
    Motherboard
    Gigabyte GA-P35-DS3L
    Memory
    4 GB Kingmax 1066 MHz
    Graphics Card(s)
    Nvidia Geforce 8600 GT
    Sound Card
    Realtek
    Monitor(s) Displays
    17" LG L1753S
    Screen Resolution
    1280x1024
    Hard Drives
    Seagate 320 GB
    PSU
    Sirtec 500 W
    Case
    Spire
    Keyboard
    Genius Slimstar 320
    Mouse
    Razer Deathadder
    Internet Speed
    100 Mb/s

Anusha

New Member
Member
Kawasaki, Japan

Posts
108
#10
We need a proper solution for this. Doesn't Microsoft know about this yet? I wonder if we are doing something wrong here. Something like this shouldn't too hard to catch because everybody seems to be having this.
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY
    CPU
    Intel Core i7 4790K @4.5GHz
    Motherboard
    Asus ROG Maximus VII Gene
    Memory
    16GB A-DATA DDR3-2400
    Graphics Card(s)
    Gigabyte GTX 970 Gaming G1
    Monitor(s) Displays
    QNIX QX2710
    Screen Resolution
    2560x1440
    Hard Drives
    Samsung 840 series 250GB
    Toshiba DT01ACA300 3TB (Data)
    Western Digital Caviar Green WD30EZRX-00DC0B0 3TB (Backup)
    PSU
    Silversonte G series 750W
    Case
    Silverstone Sugo SG09
    Cooling
    Noctua NH-U12S
    Keyboard
    Generic
    Mouse
    Logitech G602
    Internet Speed
    200Mbps/200Mbps Fibre
    Browser
    Google Chrome
    Antivirus
    Windows Defender

dyablor

New Member
Tulcea

Posts
11
#11
They are aware of this for sure, but my belief is that it's not such a priority for them. It's annoying when you have lots of photo and video files, but we can just wait for an official fix. I never encountered this issue in Windows 7, although i saw a lot of users reporting this problem even in Win 7.
 

My Computer

System One

  • OS
    Windows 8 Enterprise x64
    CPU
    Intel E8200, 2.66 GHz
    Motherboard
    Gigabyte GA-P35-DS3L
    Memory
    4 GB Kingmax 1066 MHz
    Graphics Card(s)
    Nvidia Geforce 8600 GT
    Sound Card
    Realtek
    Monitor(s) Displays
    17" LG L1753S
    Screen Resolution
    1280x1024
    Hard Drives
    Seagate 320 GB
    PSU
    Sirtec 500 W
    Case
    Spire
    Keyboard
    Genius Slimstar 320
    Mouse
    Razer Deathadder
    Internet Speed
    100 Mb/s

dyablor

New Member
Tulcea

Posts
11
#13
I just got used to it. Since I moved to Windows 8 and now 8.1 it keeps happening and there is nothing i can do. I just got used to it. I have an idea now that it might be the fact that my SATA hard drives are seen as removable media (no idea why). Maybe that could be the problem, but anyway i just live with the thumbnails caching every time I access a photo folder.
 

My Computer

System One

  • OS
    Windows 8 Enterprise x64
    CPU
    Intel E8200, 2.66 GHz
    Motherboard
    Gigabyte GA-P35-DS3L
    Memory
    4 GB Kingmax 1066 MHz
    Graphics Card(s)
    Nvidia Geforce 8600 GT
    Sound Card
    Realtek
    Monitor(s) Displays
    17" LG L1753S
    Screen Resolution
    1280x1024
    Hard Drives
    Seagate 320 GB
    PSU
    Sirtec 500 W
    Case
    Spire
    Keyboard
    Genius Slimstar 320
    Mouse
    Razer Deathadder
    Internet Speed
    100 Mb/s

packyman

New Member
Posts
3
#14
I found an solution for me!
I copied the file 'thumbcache.dll' out of my last Windows 7 Backup to my Windows 8.1 installation.
By replacing the file, the Thumbcache is managed by Windows 7 technology. Everything works.

You need a tool for replacing system files, I found a simply german app for that. The tool copy the files at next boot automaticaly.
Quell-Datei: here select my thumbcache.dll out of Win7 (81KB)
Ziel-Datei: here select the file to replaced (old) Win8 file Found in C:\Windows\System32\thumbcache.dll


Sorry for rough language, I'm from germany....
 

Attachments

My Computer

System One

  • OS
    Win 8.1

tommygun

New Member
Posts
12
#15
....... does the solution from packyman also works on Windows 8.1 x64 ?

I don't have a Windows 7 x64 backup anymore, if someone here does. please upload a copy of the file here.

The file should be located here: "C:\Windows\SysWOW64\thumbcache.dll"

Would like to try packyman's solution .......

SORRY, that the fix I suggested earlier didn't work as I hoped - In my case after about a week I got the Windows Explorer crashes as well.
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    Laptop
Florida

Posts
4
#16
Packyman's Solution did not work for me. Thumbnails would still regenerate on reboot or shutdown.

It seems some funny things have been done to the thumbnailing in Windows 8.1. I could lock down the permissions in 8, but after the 8.1 update, there is NO way to lock file permissions. I have even tried locking the individual thumbnail .db files in my Explorer folder, but the file permissions reset and change on reboot! The files themselves are not deleted due to creation date not changing, but somehow a process seems to be able to still take ownership, change file permissions, then cause the thumbnails to delete....very frustrating. There must be a hidden user or maybe it may be the built in administrator account?

Anyways, search for a fix continues....
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    Tablet
    System Manufacturer/Model
    Microsoft Surface Pro 128 GB
    CPU
    i5 3317U 1.7 Ghz
    Memory
    4GB
    Graphics Card(s)
    Intel 4000 Integrated
    Screen Resolution
    1920 x 1080
    Hard Drives
    128 GB SSD
    Keyboard
    Type Cover
    Internet Speed
    Centurlink, 10 Mbits Down, 1 MBits Up
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender
#18
I found this on Google search:

Right click on the folder which maintains the Thumbnails cache, here:

Users\{username}\AppData\Local\Microsoft\Windows\Explorer" (where {username} is replaced by the name of the windows user, for example Neil for me)
Click Properties
Click Security
Click Advanced
Click change permissions
Listed are all the users who are allowed to use this folder (I have "System", "Administrator" and my user "Neil". For each user:
Click Edit
Under the "Apply to" drop down list, select: this folder and files
Check the box under deny for: Delete subfolders and files
Check the box under deny for: Delete
Click OK

This stops any users or the system being allowed to delete the thumbnails cache files. Problem solved.

Note: this does also stop the thumbnails being deleted when using disc cleanup!
I just applied it & will wait to see if it works. :)

Edit- Thumbnail cache disappeard from Disk Cleanup. :)
The size of the cache is 62.5 MBs right now.
I am going to reboot & check it again.
I'll be back.

I'm back.
After restarting, the cache was the same size as before.

It seems to work. :)

Edit- I just noticed similar options are already posted.
I will add a screenshot of permissions to see if they are as others' settings.

A picture:

screenshot_2.png
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security
Florida

Posts
4
#19
@Packyman

The file did replace correctly, but for me caused explorer crashes, I ended up using system file checker to revert the changes.

*EDIT* Forgot to mention automatic maintance is also already disabled to stop the defrag bug, so that is also not the problem.

@DavidBailey

That fix worked great for me before I did the Windows 8.1 upgrade, but now even apply those settings doesn't seem to work. I notice that thumbnails stay under Disk Cleanup no matter what I do, and delete and restart. When I cache most of my thumbnails, my cache is 151 Mb/s in size.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    Tablet
    System Manufacturer/Model
    Microsoft Surface Pro 128 GB
    CPU
    i5 3317U 1.7 Ghz
    Memory
    4GB
    Graphics Card(s)
    Intel 4000 Integrated
    Screen Resolution
    1920 x 1080
    Hard Drives
    128 GB SSD
    Keyboard
    Type Cover
    Internet Speed
    Centurlink, 10 Mbits Down, 1 MBits Up
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender
#20
@Packyman


@DavidBailey

That fix worked great for me before I did the Windows 8.1 upgrade, but now even apply those settings doesn't seem to work. I notice that thumbnails stay under Disk Cleanup no matter what I do, and delete and restart. When I cache most of my thumbnails, my cache is 151 Mb/s in size.
I have 8.1 Pro WMC 64 bit.

One thing I did also was to disable Inheritance giving implicit control to every user.
That might make a difference.
A picture:

screenshot2.png
 

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security

Users Who Are Viewing This Thread (Users: 0, Guests: 1)