• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Vista desktop won't let Win 8.1 laptop into Public folder


DrJoanie

New Member
Maine

Posts
2
#1
My two computers, "Vista" and "Win 8.1," are both connected by Ethernet cable to a ComTrend router-modem. Settings on both machines allow Public folder sharing. Vista can enter Win 8.1's Public folder with no problem, deposit files there, take files from there, modify files--whatever. When I double-click on the Vista icon from Win 8.1's Network link in File Explorer, I get the dialog box saying, "Windows cannot access \\Vista\Public. You do not have permission to access \\Vista\Public" etc. I have followed the instructions regarding how to share files between computers running different operating systems multiple times, and the result is always the same.

Here are a few things that might be noteworthy: (1) I finally succeeded last night at sharing the printer that's connected to the Vista machine with the Win 8.1, so the firewall (or whatever) let me through from the Win 8.1 to the Vista for at least that purpose. (2) When I click "Show me all the shared network folders shared on this computer" in the Network and Sharing Center, it says, " Canon printer and Canon printer shared, Public, Users & Printers." (3) Both computers are on WORKGROUP (4) The Network and Sharing Center calls the network that Vista is on "Network 5." The Network and Sharing Center on the Win 8.1 machine calls its network "Network 6." Both networks are private. (5) I am using Norton 360 on both machines. Automatic File/Printer Sharing Control is "on."

I am at my wits' end with this--it has been months (since I had some work done on the Vista machine at a local computer shop) that I haven't had two-way file sharing between these two machines!

Joan
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Hewlett Packard
    CPU
    AMD8-4500M APU
    Memory
    6 GB
    Browser
    Mozilla
    Antivirus
    Microsoft Essentials

DrJoanie

New Member
Maine

Posts
2
#2
Because no one has replied to this question and so many people have viewed it, I wanted to explain how I FINALLY solved the problem I was having and that I am sure other people have, too. The Vista desktop's Security settings were the fly in the ointment. Provided you've done everything else you're supposed to do to set up Public folder sharing in Control Panel>Network and Sharing (i.e., turn on Network Discovery, File Sharing, Public folder sharing & (if you wish) Printer sharing), you should navigate to C:\Users\Public folder and right-click on the Public folder's file name. Then click Properties. Be sure the Sharing tab indicates that the folder is shared, then click the Security tab. There will be a bunch of users names listed there. What worked for me was to add "Everyone" to that list by clicking the Edit button, the Add button, writing the word "Everyone" in the "Enter the object names to select" field, and clicking Checking Names. That should cause "Everyone" to show up underlined, at which point you click OK. Check the boxes under "Permissions for Everyone," click Apply, OK & Close. That should do it! If you've had this problem and been trying unsuccessfully to solve it for months as I have, give yourself a cheer!
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Hewlett Packard
    CPU
    AMD8-4500M APU
    Memory
    6 GB
    Browser
    Mozilla
    Antivirus
    Microsoft Essentials