• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Via High Definition Audio Driver for Win8


Tully

New Member
VIP Member
Member
Dublin, Ireland

Posts
331
#1
I only get a buzzing noise out of my speakers when I play music.
Otherwise I get nothing.
Under device Manager it says;

VIA HIGH DEFINITION Audio
Provider MS
Date 17/02/2012
Version 6.2.8250.0
Signed MS

My Motherboard is an ASUS M5A78L-M USB3

It also gives a warning that "Device is not compatible under current OS"

Happy St Pat's day!! :party:

Tully
 

My Computer

System One

  • OS
    Win 10 Beta
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Assembled
    CPU
    Intel I5
    Motherboard
    ASUS P8Z&&-V LX
    Memory
    8 GB DDR2 SDRAM
    Graphics Card(s)
    Intel on board
    Sound Card
    INTEL ON MB
    Monitor(s) Displays
    Samsung TD390 HDMI
    Screen Resolution
    1920 X 1080
    Hard Drives
    Crucial MX100 512GB SSD
    2TB Storage
    External Seagate "Dashboard" File Backup Drive USB3
    WD "My Cloud" 4TB
    Samsung Super Write Master 24 DVD Writer
    PSU
    Cosair
    Case
    Corsair
    Cooling
    AIR
    Keyboard
    Advent USB Keyboard
    Mouse
    Advent USB
    Internet Speed
    200 MB dwn 30MB up
    Browser
    IE 11 Win 10
    Antivirus
    MS Essentials
    Other Info
    USB2 & USB3
Posts
1,851
#2
Hi,

I have tried my best for someone else and they report back the same issue, even after some hacks I tried.

My advice is to make SURE you are installing with Administrator privileges. That means that if you are installing by device manager, then make sure your current account is as Admin. If you are installing by running a .exe (even on Admin account), then right click that and choose "Run as Administrator".

In the meantime, I will check on your driver and make it so Windows 8 can install it. Maybe you will have better luck. I shall return....

Are you running Windows 8 x64 or x86?

...and your post and your system specs say different motherboards. Which is correct?

You could try installing from ASUS page:

ASUS - Motherboards- ASUS M5A78L-M/USB3
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

Tully

New Member
VIP Member
Member
Dublin, Ireland

Posts
331
#3
I have 3 desktops.

I just built one with an AMD processor it is the ASUS M5A 78L-M USB3 Motherboard.

I built it to test Win8.

I am sure it is 64 Bit, but how do I find out for sure?

Tully



I am sure
 

My Computer

System One

  • OS
    Win 10 Beta
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Assembled
    CPU
    Intel I5
    Motherboard
    ASUS P8Z&&-V LX
    Memory
    8 GB DDR2 SDRAM
    Graphics Card(s)
    Intel on board
    Sound Card
    INTEL ON MB
    Monitor(s) Displays
    Samsung TD390 HDMI
    Screen Resolution
    1920 X 1080
    Hard Drives
    Crucial MX100 512GB SSD
    2TB Storage
    External Seagate "Dashboard" File Backup Drive USB3
    WD "My Cloud" 4TB
    Samsung Super Write Master 24 DVD Writer
    PSU
    Cosair
    Case
    Corsair
    Cooling
    AIR
    Keyboard
    Advent USB Keyboard
    Mouse
    Advent USB
    Internet Speed
    200 MB dwn 30MB up
    Browser
    IE 11 Win 10
    Antivirus
    MS Essentials
    Other Info
    USB2 & USB3
Posts
1,851
#4
lol Happy St. Patty's to you too...I was born in USA but am of partial Irish descent. :)

You can type msinfo32 in the start screen and run the app that shows. Look at System type line.

x86 = 32 bit

x64 = 64 bit
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

Tully

New Member
VIP Member
Member
Dublin, Ireland

Posts
331
#5
It is 64 Bit.

I tried to install the update from Asus & it failed with OS not supported!

However I now get static when sound is played!!

Tully
 

My Computer

System One

  • OS
    Win 10 Beta
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Assembled
    CPU
    Intel I5
    Motherboard
    ASUS P8Z&&-V LX
    Memory
    8 GB DDR2 SDRAM
    Graphics Card(s)
    Intel on board
    Sound Card
    INTEL ON MB
    Monitor(s) Displays
    Samsung TD390 HDMI
    Screen Resolution
    1920 X 1080
    Hard Drives
    Crucial MX100 512GB SSD
    2TB Storage
    External Seagate "Dashboard" File Backup Drive USB3
    WD "My Cloud" 4TB
    Samsung Super Write Master 24 DVD Writer
    PSU
    Cosair
    Case
    Corsair
    Cooling
    AIR
    Keyboard
    Advent USB Keyboard
    Mouse
    Advent USB
    Internet Speed
    200 MB dwn 30MB up
    Browser
    IE 11 Win 10
    Antivirus
    MS Essentials
    Other Info
    USB2 & USB3
Posts
1,851
#6
On the download from ASUS' site - the .exe you've downloaded I mean, if it is one - right click on it and choose Properties then go to Compatibility tab. Check the box for Windows 7 and also check the box to run as admin. Hit ok, then run the program normally again.

In the meantime, I will look into it to see if there is anything I can do if trying that fails.
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

Tully

New Member
VIP Member
Member
Dublin, Ireland

Posts
331
#7
OK!

Thanx!

Tully
 

My Computer

System One

  • OS
    Win 10 Beta
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Assembled
    CPU
    Intel I5
    Motherboard
    ASUS P8Z&&-V LX
    Memory
    8 GB DDR2 SDRAM
    Graphics Card(s)
    Intel on board
    Sound Card
    INTEL ON MB
    Monitor(s) Displays
    Samsung TD390 HDMI
    Screen Resolution
    1920 X 1080
    Hard Drives
    Crucial MX100 512GB SSD
    2TB Storage
    External Seagate "Dashboard" File Backup Drive USB3
    WD "My Cloud" 4TB
    Samsung Super Write Master 24 DVD Writer
    PSU
    Cosair
    Case
    Corsair
    Cooling
    AIR
    Keyboard
    Advent USB Keyboard
    Mouse
    Advent USB
    Internet Speed
    200 MB dwn 30MB up
    Browser
    IE 11 Win 10
    Antivirus
    MS Essentials
    Other Info
    USB2 & USB3

Tully

New Member
VIP Member
Member
Dublin, Ireland

Posts
331
#8
OK!

Thanx!

Tully

Tried it & get message "Does not support this Operating System; WNT_6.2P_64_MCE.

TullY
 

My Computer

System One

  • OS
    Win 10 Beta
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Assembled
    CPU
    Intel I5
    Motherboard
    ASUS P8Z&&-V LX
    Memory
    8 GB DDR2 SDRAM
    Graphics Card(s)
    Intel on board
    Sound Card
    INTEL ON MB
    Monitor(s) Displays
    Samsung TD390 HDMI
    Screen Resolution
    1920 X 1080
    Hard Drives
    Crucial MX100 512GB SSD
    2TB Storage
    External Seagate "Dashboard" File Backup Drive USB3
    WD "My Cloud" 4TB
    Samsung Super Write Master 24 DVD Writer
    PSU
    Cosair
    Case
    Corsair
    Cooling
    AIR
    Keyboard
    Advent USB Keyboard
    Mouse
    Advent USB
    Internet Speed
    200 MB dwn 30MB up
    Browser
    IE 11 Win 10
    Antivirus
    MS Essentials
    Other Info
    USB2 & USB3

RyuHimora

New Member
Posts
1
#9
I'm also having this problem with the ASRock P45DE3 motherboard running Windows 8 x64. Every driver but the Windows default one plays audio but also a crapload of static.
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model Number
    Myself
    CPU
    Intel Core 2 Duo E6550
    Motherboard
    ASRock P45DE3
    Memory
    4 GB DDR3 1333
    Graphics Card(s)
    Nvidia GTX 260 + Nvidia GT 220 (PhysX only)
    Sound Card
    Via HD Audio
    Monitor(s) Displays
    HP S2031
    Screen Resolution
    1600x900
    Hard Drives
    Seagate ST380023AS
    WDC WD800JD-75MSA3
    Internet Speed
    10 Mb Download 5 Mb Upload (Cox)

Dave44

New Member
Member
Posts
205
#10
windows 8 release preview gets released friday so hopefully sound be fixed then
 

My Computer

System One

  • OS
    Windows 8.1 update 1 Pro X64 with WMC
    Computer type
    PC/Desktop
    CPU
    intel i7 2600k
    Motherboard
    Asrock H61M-VG3
    Memory
    16GB
    Graphics Card(s)
    nvidia geforce GTX 560 Ti
    Screen Resolution
    1920x1080
    Internet Speed
    100MB

Tully

New Member
VIP Member
Member
Dublin, Ireland

Posts
331
#11
I hope!

Thanx!

Tully
 

My Computer

System One

  • OS
    Win 10 Beta
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Assembled
    CPU
    Intel I5
    Motherboard
    ASUS P8Z&&-V LX
    Memory
    8 GB DDR2 SDRAM
    Graphics Card(s)
    Intel on board
    Sound Card
    INTEL ON MB
    Monitor(s) Displays
    Samsung TD390 HDMI
    Screen Resolution
    1920 X 1080
    Hard Drives
    Crucial MX100 512GB SSD
    2TB Storage
    External Seagate "Dashboard" File Backup Drive USB3
    WD "My Cloud" 4TB
    Samsung Super Write Master 24 DVD Writer
    PSU
    Cosair
    Case
    Corsair
    Cooling
    AIR
    Keyboard
    Advent USB Keyboard
    Mouse
    Advent USB
    Internet Speed
    200 MB dwn 30MB up
    Browser
    IE 11 Win 10
    Antivirus
    MS Essentials
    Other Info
    USB2 & USB3

Dave44

New Member
Member
Posts
205
#12

My Computer

System One

  • OS
    Windows 8.1 update 1 Pro X64 with WMC
    Computer type
    PC/Desktop
    CPU
    intel i7 2600k
    Motherboard
    Asrock H61M-VG3
    Memory
    16GB
    Graphics Card(s)
    nvidia geforce GTX 560 Ti
    Screen Resolution
    1920x1080
    Internet Speed
    100MB

alphanumeric

slightly off center
VIP Member
Guru
Gold Member
#13
M4N68T-M V2 here with VIA onboard sound. I got the ASUS supplied Windows 7 driver to install and run using compatibility mode. I haven't looked for a driver on the VIA site for a Windows 8 driver yet though.

EDIT: Actually it just occurred to me that it wasn't an ASUS driver, it was downloaded from VIA.
 
Last edited:

My Computer

System One

  • OS
    Windows 10 Education 64 Bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Asus
    CPU
    AMD Phenom II X4 980 Black Edition Deneb 3.7GHz
    Motherboard
    ASUS M4N68T-M V2 µATX Motherboard
    Memory
    8GB 4GBx2 Kingston PC10600 DDR3 1333 Memory
    Graphics Card(s)
    NVIDIA Geforce GT640 2 Gig DDR3 PCIe
    Sound Card
    VIA VT1708s High Definition Audio 8-channel Onboard
    Monitor(s) Displays
    22" LG E2242 1080p and 2 19" I-INC AG191D
    Screen Resolution
    1280x1024 - 1920x1080 - 1280x1024
    Hard Drives
    Crucial MX100 256 GB SSD and 500 GB WD Blue SATA
    PSU
    Thermaltake TR 620
    Case
    Power Up Black ATX Mid-Tower Case
    Cooling
    Stock heatsink fan
    Keyboard
    Logitech Wireless K350 Wave
    Mouse
    Logitech M570 Trackball and T650 TouchPad
    Internet Speed
    80 Mbps Down 30 Mbps Up
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    HP DVD1040e Lightscribe - External USB2

ecou2508

New Member
Posts
1
#15
Yes ! I had the same kind of problem: UNABLE to install official drivers package from VIA for my motherboard ASUS M5A78L-M/USB3 with VIA VINYL HD 8ch AUDIO running windows 8.1. : Windows keeps always its generic microsoft HD audio drivers..............
Spending a few hours on that problem, i finaly got it to work.
here are the steps for a finaly successfull install:
1) Upgrade to BIOS version 1801 older versions DO NOT WORK CORRECTLY:
ASUSTeK Computer Inc. -Support- Drivers and Download M5A78L-M/USB3
pay attention having the right version ! i mean for your motherboard (i made the mistake and got the 1801 for m5A78L (not L-M) and it refused to update hopefully.......
2) Download and install the latest VIA drivers x64 win 8.1 for VIA VINYL HD AUDIO Chip VT1708S => Version 6.0.11.0200C (19 DEC 2013)
Station-Drivers - Via (chipset)
! ! ! ! ATTENTION: WINDOWS 8.1 WON'T CHANGE THE DRIVERS UNTIL YOU FORCE IT TO DO IT ! ! ! !
So, STEP 3 is NECESSARY
3) Go to Device Manager -> Audio devices -> HD Audio -> right-clic -> Update and browse to the folder with the here above decompressed VIA package folder (VIAHDAudio) -> Ok
4) Reboot now and you should be able to use the VIA HD Vdeck, (as it works for me ;-). pay attention that VDECK starts minimized in tray...
VIA Vdeck.jpg
VIA_CP_About.jpg
IF SUCCESSFULL: In device manager, under "Audio, video,.. Controllers" You SHOULD have "VIA HD AUDIO" and not anymore the generic "HD Audio" from microsoft.
M5A78L-M-USB3 - VIA HD OK.jpg
M5A78L-M-USB3 - VIA HD OK2.jpg
Eddy
belgium
PS: 1) I have a "french" windows 8.1 install, so i'm not sure of correct device manager elements names......

2) IF you reinstall the VIA drivers package, you will have to REDO step 3, otherwise, windows WILL return to it's generic driver ! ! !
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS CUSTOM BUILD
    CPU
    FX6350
    Motherboard
    ASUS M5A78M-M/USB3
    Memory
    8 GB
    Graphics Card(s)
    ASUS AMD 7750
    Browser
    Firefox
    Antivirus
    Avast