• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB3 External Hard Drive Issue


steverido

New Member
Posts
17
#1
Hi Guys,

I have bought a 2TB western Digital external USB3 hard drive and installed the Asmedia drivers but windows never picks it up. See the screen capture. The drivers are the ASMedia USB 3 host controller but it seems to show up after a few seconds as USB Root Hub (xHCI) with a triangle. I have tried updating from there and directing it to the drivers and uninstalling and then reinstalling and the drive shows up long enough to copy but then disappears again.

I literally have run out of options.

It seems to be a common theme on the web and especially with Western Diital drives although I think it is windows struggling to recognise them and implement correctly.

What do you think?
 

Attachments

My Computer

System One

  • OS
    Windows 8

otisdog

New Member
Posts
25
#2

My Computer

System One

  • OS
    Windows 7
    System Manufacturer/Model
    Selfbuilt
    CPU
    Intel i5 3570k
    Motherboard
    Intel dz77bh-55k
    Memory
    16 gigs Corsair
    Graphics Card(s)
    EVGA GTX570

steverido

New Member
Posts
17
#3
Hi Jim, thanks for responding. Yes I have uninstalled the ASMedia host driver and rebooted Windows but it still is a problem. Let's see if Microsoft come up with a solution soon.
 

My Computer

System One

  • OS
    Windows 8

Users Who Are Viewing This Thread (Users: 0, Guests: 1)