• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB xHCI Compliant Host Controller driver not working


matteosc2

New Member
NJ

Posts
1
#1
Hi. First, im on a Lenovo Y510p Laptop. Yesterday, windows updated through windows update and when i logged into my computer, none of my usb ports were working. As in: My external mouse and keyboard were not connecting, they were working just before the update though.(they are new.) Device manager said there was an error with some driver so i tried to update, it said it was where it needed to be, so i uninstalled it, restarted the computer and it was fixed. Now, USB ports still not working, i have an error with this driver:

USB xHCI Compliant Host Controller
Under device status, it says:
Windows cannot initialize the device driver for this hardware. (Code 37)


The specified image file did not have the correct format, it did not have an initial MZ.

Im not sure what other information i should give so here is some stuff that may help:

When i press update driver it says that it is running the latest driver.
Obviously, this driver is under Universal serial bus controllers in device manager.
I use the laptop for mostly gaming.
My mouse and keyboard WERE working before the update the same night.
Any more info that could help just let me know, thanks so much.
 

Attachments

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    CPU
    Intel(R) Core(TM) i7-4700MQ CPU @2.40GHz 2.40GHz
    Memory
    16GB
    Graphics Card(s)
    NVIDIA GeForce GT 755M, NVIDIA GeForce GT 755M
    Screen Resolution
    1080p
    Keyboard
    Razer BlackWidow
    Mouse
    Razer Naga Hex
    Browser
    Google Chrome