• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved USB ports not functioning, was working properly before


Sabir

New Member
Posts
10
#1
Recently I installed a fresh, clean install of Windows 8 pro 64 bit on a sony vaio laptop vgn-z540n model, and then did a restoration of Windows settings and files from windows easy transfer (wasn't able to transfer everything though). After that, installed most of the drivers that to make the laptop completely functional (graphics, special key etc.) I wasn't having much issues besides hardware stuff like an unfunctional fingerprint sensor and eject button.
So I'm not sure what has triggered the error I get in device manager that I attached. The usb ports suddenly stopped working. Edit: and it looks like the web camera stopped working too Could it have been Windows update? it was working fine before. Thanks, hopefully I can get a solution
 

Attachments

My Computer

System One

  • OS
    Windows 8

norepli

New Member
Member
Posts
386
#2
I would try uninstalling them (one at a time) and reboot. Hopefully, windows will rediscover them and fix the problem.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    PC/Desktop

Sabir

New Member
Posts
10
#3
I would try uninstalling them (one at a time) and reboot. Hopefully, windows will rediscover them and fix the problem.
I created a restore point, uninstalled each of the usb controllers, rebooted, scanned for hardware changes, and unfortunately nothing happened... now what do i do?
 

My Computer

System One

  • OS
    Windows 8

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#4
Did you install the chipset driver for your mother board ? The chipset driver is responsible to install the drivers for devices on the MB including the USB driver.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

Sabir

New Member
Posts
10
#7
oh by the way, under each of the driver's properties it displays error 52.
I found the solution (at least for me, related to code 52 for drivers), I went into advanced startup settings and disabled driver enforcement as said on the Microsoft Community forums, and right when i logged in after the reboot and an install of windows updates, a driver installed (related to usb). The USB ports were fully functional again. This only lasted until I rebooted, where the usb was totally dysfunctional.
The same link said to also try deleting any values named "LowerFilters" and/or "UpperFilters" under the following key in the registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
After rebooting, the USBs became completely functional without having to reboot into disabled driver signature enforcement mode.
 
Last edited:

My Computer

System One

  • OS
    Windows 8