• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Usb port stopped working. How to fix ?


chocolade

New Member
Posts
36
#1
Not sure why it happened but it did.
The usb ports on the back of my pc are working fine but this on the front 2 usb ports are not working.
I think that if i will shut down my pc or make a restart it will fix it this time.

But i don't want to restart my pc now.

1. Why it happen ? It's not the first time. I think it's due yo insert/remove my smartphone too many time from the usb port in the front. Is there any way to make it will not happen again in the future ?

2. How to fix the problem now without restarting/shutting down the pc ?

I went to device manager and i see under: Universal Serial Bus controllers two controllers out of 8 that have a yellow triangle with a black small line inside like a warning. I tried to make Scan for hardware changes but it didn't fix it.
What else can i do ?

This is a screenshot of this warnings i see:

whatisee.jpg
 

My Computer

System One

  • OS
    windows 8 64 bit

chocolade

New Member
Posts
36
#2
The solution in my case was to disable this both controllers. And enable them back. Now it's working again fine.
I just wonder why it happen in the first place ? And why microsoft can't fix it.

Is ther any fix for this problem ? Or if i will connect and remove my phone from the usb many times it will happen over and over again ? I need my phone for testings i'm doing programming on it.
 

My Computer

System One

  • OS
    windows 8 64 bit

fireberd

Beach Observer
VIP Member
Pro User
Inverness, FL

Posts
1,811
#3
If your phone shows up in the "Safely Remove Hardware" list, you should use that to disconnect it or the port can get corrupted.
 

My Computer

System One

  • OS
    Win 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Built
    CPU
    i7 6700K
    Motherboard
    ASUS ROG Maximus VIII Hero
    Memory
    16 Gb G Skill TridentZ DDR4 3400
    Graphics Card(s)
    Intel (i7 CPU)
    Sound Card
    RealTek Integrated
    Monitor(s) Displays
    27" Dell SE2717HR
    Screen Resolution
    1920X1080
    Hard Drives
    500GB Samsung 850 SSD, 3TB for backups
    PSU
    EVGA Supernova 750 G2
    Case
    BeQuiet Silent Base 600
    Cooling
    Deepcool Captain 120EX
    Keyboard
    Microsoft Wireless
    Mouse
    Logitech wireless
    Internet Speed
    Cable - 100MB Downlink
    Browser
    Edge/Firefox
    Antivirus
    Microsoft
    Other Info
    Sonar Platinum 64 bit recording studio software with MOTU 896Mk3 Hybrid recording interface unit.

hTconeM9user

Windows 10 and Edge No 1
Member
Eastbourne uk

Posts
89
#4
Yes right click the icon for safely remove hardware then remove your phone or whatever otherwise it will do as the other poster has put.
If that happens it will be either a systems restore or a reset to get it all back working again
 

My Computer

System One

  • OS
    Windows 10 x64 Home Version 1803 (Build 17134).472
    Computer type
    Laptop
    System Manufacturer/Model
    HP 15-bw067sa
    CPU
    AMD Dual-Core Processor E1-7010(1.5GHz)
    Motherboard
    HP
    Memory
    4096MB RAM
    Graphics Card(s)
    AMD Radeon tm R2 Graphics
    Screen Resolution
    1366x768 Pixels
    Hard Drives
    Toshiba
    Case
    True Blue
    Cooling
    Fan
    Keyboard
    Prection Touchpad
    Mouse
    Built in with touch keyboard
    Internet Speed
    Fast
    Browser
    Microsoft Edge
    Antivirus
    Windows Defender
    Other Info
    Microsoft Office 365 new version: Fast Track Office 2016
    CCleaner
Posts
884
#5
Just yesterday I had 4 external hard drives plugged into my usb 3 single port using a powered 4 port USB hub..

When I restarted windows, it was just sitting on the restart screen waiting.. So I waited and waited.. And then pulled the USB plug out of the port and all the sudden the computer restarted...

Just great, so now I have to start figuring out why my computer couldn't shut down with one or multiple of the external drives...
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo g750
    CPU
    i5
    Motherboard
    Some Chinese Crap..
    Memory
    8
    Graphics Card(s)
    Nvidia 755
    Antivirus
    Windows Defender

lifetec

New Member
Power User
Posts
660
#6
Just yesterday I had 4 external hard drives plugged into my usb 3 single port using a powered 4 port USB hub..

When I restarted windows, it was just sitting on the restart screen waiting.. So I waited and waited.. And then pulled the USB plug out of the port and all the sudden the computer restarted...

Just great, so now I have to start figuring out why my computer couldn't shut down with one or multiple of the external drives...
Did you maybe change your Bootorder and put USBhdd or USB at first priority and none of the external 4 disk are bootable.

Some external HDD ( like Western Digital My Book ) need additional drivers to let windows boot properly if atttached.
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    self build
    CPU
    Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz
    Motherboard
    Asrock P55 Pro
    Memory
    DDR3 Team--Elite-1333 8 gb
    Graphics Card(s)
    Sapphire R9 280x
    Sound Card
    Realtek Alc 855
    Monitor(s) Displays
    Acer V233H
    Screen Resolution
    1920 x 1020
    Hard Drives
    Samsung evo 850 SSd
    Seagate ST 320 gb
    Samsung HD 750 gb
    Seagate ST 3000gb
    PSU
    OCZ Stealth 600 watt
    Case
    Antec 300
    Mouse
    Speedlink Ledos and Nexus
Posts
884
#7
No no, I mean I had them all plugged in and then Hit "restart.. then the Blue screen shows up saying "Shutting down windows" or maybe it says "Restarting" I can't even remember now but it just sat there and didn't turn off.. know what i Mean?

I didn't even get to the point of the boot.. it was just trying to still quit windows and shut down... make sense now??

and then it was just circle spinning and then i unplugged the usbs and then it restarted..

I wasnt' trying to boot with them.. just restart..

this screen


restarting.png
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo g750
    CPU
    i5
    Motherboard
    Some Chinese Crap..
    Memory
    8
    Graphics Card(s)
    Nvidia 755
    Antivirus
    Windows Defender

Users Who Are Viewing This Thread (Users: 0, Guests: 1)