• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB mouse not working, giving Code 43 in device manager


arcayn

New Member
Posts
1
#1
USB ports, giving Code 43 in device manager

Hello All,

I am running Windows 8.1 on a laptop and almost always use a USB mouse. The aforementioned mouse has never had any problems before, and was working perfectly yesterday. Today, however, I plugged in the mouse and was told that: "The last usb device you connected to this computer malfunctioned", and the mouse was not working, however it did light up as it does when plugged into something. I restarted the computer and tried again, but to no avail. In device manager, where the mouse is usually shown, it simply said "Unknown USB device (Device Descriptor request failed)". I updated the drivers of both the USB port the mouse was plugged into and also attempted to update the drivers of the device, but both times it was said to be "up to date". When plugged into another laptop, the mouse worked fine, and when I plugged a pen drive into the port, it also worked fine. All 4 of my ports work fine with a pen drive, but I recieve this error whichever port I plug the mouse into. I have trawled multiple forums to try and find a solution, but none have worked.

[UPDATE]

I found a suggestion on the MS help forums which suggested to uninstall every single USB device listed in device manger. I am now no longer getting the issue mentioned above. Instead NONE of my USB ports work with ANYTHING, the mouse included, but also my hard drives and pen drives. The mouse still works fine in othe computers. In device manager, all the usual devices are showing up along with 3 that read:

Unknown USB device (Port reset failed)

Please help
[UPDATE 2]

Gaaaah, time is slipping by me and I still have no mouse. Something good has happened this time though, which is that after enabling USB debug mode in the BIOS I now have one port working. STILL HAVING THE SAME ERROR AS BEFORE THE TOTAL BREAKAGE THOUGH, my mouse still is not working.

Help
[UPDATE 3]

It has been a week and I am still mouseless, USB 3-less and having to operate out of one port. I have read somewhere that resetting the BIOS will fix this issue, so I am going to call a technician round to reset it. Will update shortly
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1