• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB 2.0 PCI card Not Seen


Posts
6
#1
I have a Vantec 5 port usb 2.0 pci host card that worked in a computer running winxp but is not seen at all in my new pc build. I have switched the card between both slots number times but nothing....like its not there.the unit did not come with a driver cd. dev manager sees nothing....there are no errors. all the other usb ports work....including the two on the front connected via those tiny wires at the motherboard. i tried plugging in devices that work in the working ports into the ports of the dead unit and nothing.....thinking although its new....that the card is dead but i dont have any other cards to see if the slots are dead....bios appears to have the slots enabled.
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    Custom Build Desktop
    CPU
    AMD II x 3 450
    Motherboard
    ECSMGP61M-M3
    Memory
    4gb DDR3-2sticks
    Graphics Card(s)
    Nvidia geforce on board graphics
    Sound Card
    Onboard GeForce graphics
    Monitor(s) Displays
    Acer 20" display
    Screen Resolution
    1600 x 900
    Hard Drives
    80gb WD 7200rpm IDE HDD(for now)
    PSU
    Diablotek 400w PSU
    Case
    Apex TX-381
    Cooling
    AMD CPU cooler
    Keyboard
    Vakoss Illuminated
    Mouse
    Inland Laser
    Internet Speed
    54Mbps

Users Who Are Viewing This Thread (Users: 0, Guests: 1)