• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Updates Fail Every Time


Posts
6
#1
Hi,

I'm dual booting Windows 8 and Windows 7 on my tower. Each OS sits on a separate hard drive/disk.

Windows 8 updates fail every time. It re-starts, a message says it is configuring updates, then it fails and rolls back.

Is this a known thing? Is there a way to solve this?
 

My Computer

System One

  • OS
    7 and 8

znod

New Member
Power User
Posts
2,156
#2
Don't know what's up. Have tried just doing one update as a test? FWIW, I generally do only a few at a time, although many do as many as available at one time without problem.
 

My Computer

System One

  • OS
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY Rig; MacBook Pro (MBP)/Parallels/Boot Camp; HP Pavilion dv6500t Laptop
    CPU
    Intel i7-2600K (sometimes OC'd to 4.8 GHz)
    Motherboard
    ASUS P8P67 Deluxe Rev B3
    Memory
    16 GB Corsair Vengeance
    Graphics Card(s)
    EVGA 570 SC
    Monitor(s) Displays
    Gateway
    Hard Drives
    Dual Boot:
    Win7 Ult RAID 0 on OCZ Revo x2 and
    Win7 Ult RAID 0 on Caviar Black SATA 3's
    PSU
    Cooler Master Silent Pro 1000W
    Case
    Cooler Master 932 HAF
    Cooling
    Zalman CNPS9900MAX-B CPU Fan
    Keyboard
    Logitech Cordless Desktop MX 5500
    Mouse
    Logitech Cordless Desktop MX 5500
    Internet Speed
    20 Mbps Download/2+ Mbps Upload
    Other Info
    Pioneer Blu-ray Burner/DVD Burner

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#3

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

Brink

Administrator
Administrator
mvp
Posts
23,791
#5
Hello Will,

Could you post the exact full error message and number?

For now, you might see if using OPTION TWO in the tutorial below to reset Windows Update may help.

Windows Update - Reset - Windows 7 Help Forums

Hope this helps, :)
Shawn
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Brink

Administrator
Administrator
mvp
Posts
23,791
#7
What AV or firewall program do you have installed?

If it's a 3rd party program, then you might temporarily disable or uninstall it and try Windows Update again to see if it may be the culprit.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
Posts
6
#8
The firewall is disabled and there's no 3rd party AV s/w.
I even disabled Defender.
I have made the Windows 8 drive the default OS to load in the boot order.
 

My Computer

System One

  • OS
    7 and 8
#9

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
Posts
6
#10
Well, following those many and varied instructions, I'm down to 1 update which stubbornly won't update:

KB2795944.png

KB2795944 damn you!!!

Any suggestions how to put this last one to bed (and thanks for your help so far!).
 

My Computer

System One

  • OS
    7 and 8

Brink

Administrator
Administrator
mvp
Posts
23,791
#11

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
#12
I don't know if this might help but in my similar case the problem was traced to an incompatible program (Nitro pro7) which came with the computer. Updating to Nitro pro 8 solved it, though I suppose I could have uninstalled it.
 

My Computer

System One

  • OS
    Widows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo G780
    CPU
    Intel core i5
    Memory
    6GB
    Browser
    Firefox
    Antivirus
    Win Defender

Pauleduc

New Member
Posts
12
#13
FWIW.. I had this same problem when updating a new copy of Windows 8 on a new computer I just built. I contacted MS, and the problem was caused by the fact that I had not activated my product.


Once I activated my copy of Win 8, the problem disappeared!
 

My Computer

System One

  • OS
    Win 8

whis

New Member
Posts
4
#14
I just solved my problem by running sfc/scannow which found errors but couldn't correct them. So I then used dsim /online/cleanup-image /restorehealth which corrected the file corruption and all updates completed. You have to reboot after dism completes. See my post.
 

My Computer

System One

  • OS
    Win 8
    Computer type
    PC/Desktop
    System Manufacturer/Model
    HP p6-2330
    CPU
    amd

Users Who Are Viewing This Thread (Users: 0, Guests: 1)