What's new

Solved unable to un-share C:\Users folder

namsilat

Member
Member
After discovered that my C:\Users folder was shared by default, I right clicked the folder and unchecked "Share this folder" in Advanced Sharing under Share tab. I also went into Control Panel - Folder Options - View and unchecked "Use Sharing Wizard". However, as soon as the computer restarts, the C:\Users folder is back to being shared again. "Use Sharing Wizard' under Folder Options remains unchecked after reboots. I am using Windows 8 Pro. Any idea the reason the setting is not saved?
 

My Computer

System One

  • OS
    Windows 8 Pro

chev65

Closed
Besides unchecking the advanced sharing for the User folder you will also need to go into the Security tab and remove Everyone from the share with list.

You will want to go to local disk C, right click the User folder, choose "share with" then choose Advanced Sharing, Security tab, highlight Everyone, click edit, click the Remove tab with Everyone highlighted, the Everyone entry will be removed, you will need to hit "Continue" a bunch of times as the new security settings are applied to all User folders.

Your problem should now be fixed. :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Name
    Rob
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Occupation
    Construction Engineer
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
    Country Flag
    USA
    State/Region Flag
    us california

chev65

Closed
Actually I tried that already and Access Denied errors poped up to all folders despite being logged in with Administrator account.

Access denied to your own User folder? Nope you aren't reading it right.

I'm pretty sure what you are seeing is what I mentioned earlier, it says access denied unless you click through all the folders to approve the changes that you just made.

When you see this message Hit "Continue" a bunch of times, this is giving admin approval for all the changes you just made, it will go through all the files you are changing security for, I mentioned this earlier.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Name
    Rob
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Occupation
    Construction Engineer
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
    Country Flag
    USA
    State/Region Flag
    us california

namsilat

Member
Member
I certainly hope if I can use a computer installed with Windows system then I can read properly :]

I checked around and found out the reason for all the access denied popup. The ownership of the folder is set to System, which I guess is higher up than Administrator. I changed ownership of the folder to Administrator, the Access Denied popup no longer happens. Coming back to my original problem, I was then able to remove Everyone from Security tab, but that did not solve the sharing problem.
 

My Computer

System One

  • OS
    Windows 8 Pro

chev65

Closed
I certainly hope if I can use a computer installed with Windows system then I can read properly :]

I checked around and found out the reason for all the access denied popup. The ownership of the folder is set to System, which I guess is higher up than Administrator. I changed ownership of the folder to Administrator, the Access Denied popup no longer happens. Coming back to my original problem, I was then able to remove Everyone from Security tab, but that did not solve the sharing problem.

From what you are saying here, you are seeing the ownership somehow changed to System.

Well by default you should be the owner and have an admin account in your name so I'm not sure how the ownership could have changed. On my machine, System has full control with check marks to show that, and also my Admin account has full control as it should.

My original instructions to un-share the C drive should still be working to fix this issue. I've tried it on my own machine and it worked for me, settings saved no problem.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Name
    Rob
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Occupation
    Construction Engineer
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
    Country Flag
    USA
    State/Region Flag
    us california

alphanumeric

slightly off center
VIP Member
Guru
Gold Member
Are you using "Homegroup"? If memory serves me correctly, in Windows 7 removing the share for the Users folder would break Homegroup. maybe Windows 8 takes it one step further and reshares it automatically if Homegroup is enabled. I don't use Homegroup and have unshared the Users folder without any problems. I also disabled the sharing wizard.
 

My Computer

System One

  • OS
    Windows 10 Education 64 Bit
    Name
    Kerry Waterfield
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    AMD Phenom II X4 980 Black Edition Deneb 3.7GHz
    Motherboard
    ASUS M4N68T-M V2 µATX Motherboard
    Memory
    8GB 4GBx2 Kingston PC10600 DDR3 1333 Memory
    Graphics Card(s)
    NVIDIA Geforce GT640 2 Gig DDR3 PCIe
    Sound Card
    VIA VT1708s High Definition Audio 8-channel Onboard
    Monitor(s) Displays
    22" LG E2242 1080p and 2 19" I-INC AG191D
    Screen Resolution
    1280x1024 - 1920x1080 - 1280x1024
    Hard Drives
    Crucial MX100 256 GB SSD and 500 GB WD Blue SATA
    PSU
    Thermaltake TR 620
    Occupation
    Retired
    Case
    Power Up Black ATX Mid-Tower Case
    Cooling
    Stock heatsink fan
    Keyboard
    Logitech Wireless K350 Wave
    Mouse
    Logitech M570 Trackball and T650 TouchPad
    Internet Speed
    80 Mbps Down 30 Mbps Up
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    HP DVD1040e Lightscribe - External USB2
    Country Flag
    Canada
    State/Region Flag
    ca novia scotia

alphanumeric

slightly off center
VIP Member
Guru
Gold Member
No problem, :thumb:
 

My Computer

System One

  • OS
    Windows 10 Education 64 Bit
    Name
    Kerry Waterfield
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    AMD Phenom II X4 980 Black Edition Deneb 3.7GHz
    Motherboard
    ASUS M4N68T-M V2 µATX Motherboard
    Memory
    8GB 4GBx2 Kingston PC10600 DDR3 1333 Memory
    Graphics Card(s)
    NVIDIA Geforce GT640 2 Gig DDR3 PCIe
    Sound Card
    VIA VT1708s High Definition Audio 8-channel Onboard
    Monitor(s) Displays
    22" LG E2242 1080p and 2 19" I-INC AG191D
    Screen Resolution
    1280x1024 - 1920x1080 - 1280x1024
    Hard Drives
    Crucial MX100 256 GB SSD and 500 GB WD Blue SATA
    PSU
    Thermaltake TR 620
    Occupation
    Retired
    Case
    Power Up Black ATX Mid-Tower Case
    Cooling
    Stock heatsink fan
    Keyboard
    Logitech Wireless K350 Wave
    Mouse
    Logitech M570 Trackball and T650 TouchPad
    Internet Speed
    80 Mbps Down 30 Mbps Up
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    HP DVD1040e Lightscribe - External USB2
    Country Flag
    Canada
    State/Region Flag
    ca novia scotia

chev65

Closed
Turning off Homegroup solved the problem, thank you!

But Homegroup only shares 4 folders by default, not the entire User folder, and it only shares them with other Homegroup machines. It has nothing to do with the share permissions for the C drive User folder which is still viewable by Everyone on the network by default. Those are the directions I gave you.

It's also ridiculously easy to un-share those Homegroup folders. You don't need to turn off the Homegroup in order to un-share the Homegroup folders, you simply right click them and choose "Share With" then choose "Stop Sharing". If you did this with all 4 Homegroup folders then they would be un-shared.

You never once mentioned using Homegroups or that it was a problem with Homegroup folders, you said C drive User folder so I gave you directions to unshared the User folder with Everyone on the network, my answer had nothing to do with Homegroups because that isn't the question you asked.

You might want to check the ownership for system now as that might give you problems in the future.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Name
    Rob
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Occupation
    Construction Engineer
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
    Country Flag
    USA
    State/Region Flag
    us california

alphanumeric

slightly off center
VIP Member
Guru
Gold Member
I'm not meaning to stir things up but why is the Users folder shared to begin with? I know for a fact on my Windows 7 PC's if you unshare it Homegroup doesn't work. Also, turning off Homegroup doesn't unshare the "Users" folder. I don't see the point of it being shared to begin with, which is why I unshare it so it doesn't show up in the Network view. Just my 2 cents.
 

My Computer

System One

  • OS
    Windows 10 Education 64 Bit
    Name
    Kerry Waterfield
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    AMD Phenom II X4 980 Black Edition Deneb 3.7GHz
    Motherboard
    ASUS M4N68T-M V2 µATX Motherboard
    Memory
    8GB 4GBx2 Kingston PC10600 DDR3 1333 Memory
    Graphics Card(s)
    NVIDIA Geforce GT640 2 Gig DDR3 PCIe
    Sound Card
    VIA VT1708s High Definition Audio 8-channel Onboard
    Monitor(s) Displays
    22" LG E2242 1080p and 2 19" I-INC AG191D
    Screen Resolution
    1280x1024 - 1920x1080 - 1280x1024
    Hard Drives
    Crucial MX100 256 GB SSD and 500 GB WD Blue SATA
    PSU
    Thermaltake TR 620
    Occupation
    Retired
    Case
    Power Up Black ATX Mid-Tower Case
    Cooling
    Stock heatsink fan
    Keyboard
    Logitech Wireless K350 Wave
    Mouse
    Logitech M570 Trackball and T650 TouchPad
    Internet Speed
    80 Mbps Down 30 Mbps Up
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    HP DVD1040e Lightscribe - External USB2
    Country Flag
    Canada
    State/Region Flag
    ca novia scotia

chev65

Closed
I'm not meaning to stir things up but why is the Users folder shared to begin with? I know for a fact on my Windows 7 PC's if you unshare it Homegroup doesn't work. Also, turning off Homegroup doesn't unshare the "Users" folder. I don't see the point of it being shared to begin with, which is why I unshare it so it doesn't show up in the Network view. Just my 2 cents.

I'm not sure why the User folders are viewable but not writable by Everyone on the network by default, it may be just to show users that adding the Everyone tag makes folders sharable with Everyone on the network, but you can remove the Everyone share and the Homegroup folders still work fine for me.

And yes that was my point, the Op said he turned off the Homegroup and that magically fixed the problem but that would only un-share the Homegroup folders not the User folder showing up on the network problem which is what I gave directions for but for some reason they weren't followed correctly.

With the Everyone tag removed and with Homegroups set up, you only see the 4 Homegroup folders when you open up the User folder on other Homegroup machines. Apparently just those 4 Homegroup folders are the ones the Op was referring too, it wasn't the entire User folder, they easily could have been removed by right clicking each Homegroup folder and choose to stop sharing them. I think the Op was just confused on which folders were which and that is understandable with this double file system that Windows is using now.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Name
    Rob
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Occupation
    Construction Engineer
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
    Country Flag
    USA
    State/Region Flag
    us california

alphanumeric

slightly off center
VIP Member
Guru
Gold Member
Ok, I got you now. I just assumed turning off Homegroup finally let him un share the folder manually, which he couldn't do before for some reason.
 

My Computer

System One

  • OS
    Windows 10 Education 64 Bit
    Name
    Kerry Waterfield
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    AMD Phenom II X4 980 Black Edition Deneb 3.7GHz
    Motherboard
    ASUS M4N68T-M V2 µATX Motherboard
    Memory
    8GB 4GBx2 Kingston PC10600 DDR3 1333 Memory
    Graphics Card(s)
    NVIDIA Geforce GT640 2 Gig DDR3 PCIe
    Sound Card
    VIA VT1708s High Definition Audio 8-channel Onboard
    Monitor(s) Displays
    22" LG E2242 1080p and 2 19" I-INC AG191D
    Screen Resolution
    1280x1024 - 1920x1080 - 1280x1024
    Hard Drives
    Crucial MX100 256 GB SSD and 500 GB WD Blue SATA
    PSU
    Thermaltake TR 620
    Occupation
    Retired
    Case
    Power Up Black ATX Mid-Tower Case
    Cooling
    Stock heatsink fan
    Keyboard
    Logitech Wireless K350 Wave
    Mouse
    Logitech M570 Trackball and T650 TouchPad
    Internet Speed
    80 Mbps Down 30 Mbps Up
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    HP DVD1040e Lightscribe - External USB2
    Country Flag
    Canada
    State/Region Flag
    ca novia scotia

Shelbyaa1

New Member
I finally found out how windows 8 is sharing the user folder and you can't stop it from being shared. You can do all of the things listed above but when you restart your computer it is being shared again. I had to reinstall windows 8 several times to finally get it from being shared. During setup do not do the recommended setup instead do the custom install. During the custom install it will ask something about letting your devices such as tv and other computer or phones find your computer. Check no or public computer this will prevent Microsoft from sharing the user folder and writing the setting in the boot file. I tried everything that is mentioned above and nothing would work until I made my computer a public computer. I can't believe that Microsoft would be so dumb as to make it a default setup during installation and not give anyone access to change the setting. I hope this answers everyone's question about the user folder being shared.
 

My Computer

System One

  • OS
    windows 8

Shelbyaa1

New Member
I just found this on the internet from Microsoft.


The C:\Users folder is shared when any sub folders from C:\Users\<username>\ is shared

I hope that this helps everyone. Also read the bottom of the page
It says that there is no work around for this problem yet.
It also says that smb will not let you share with anyone on on the computer but I
used another computer in my network and could access any file or folder under my
user folder. The user folder was published to anyone on the internet and to all bots
such as bing and google so that they could get my info and publish it or what ever
they wanted to do with it.
 

My Computer

System One

  • OS
    windows 8

chev65

Closed
I would explain that differently as the link implies that if you share a User folder then all User folders are automatically shared. What this really means is that none of the User folders are sharable unless the main User folder is first shared out. So sharing a single User folder or Library folder can't work unless the main Users folder is shared out.

Sharing a subfolder with sharing turned off on the main User folder may have the effect explained in the link but that doesn't explain how sharing in Windows is meant to work.

The way it works is that you always share the main Users folder , which is why it's enabled by default, then if you want to protect certain User folders from being accessed on the network, you simply right click a Library folder or other User folder and choose the "Share With> Stop Sharing, option. You would do this for each folder that you don't want to be shared.

So rather than trying to share only one User folder which doesn't work, you would share them all then simply Stop Sharing the ones you don't want to be shared out. For some reason it's difficult for people to wrap their heads around this.

Windows 8 even added another tab under Homegroup that shows the User name folders all spread out for easier access to each User folder, as in the picture below.
 

Attachments

  • share with nobody user folders.PNG
    share with nobody user folders.PNG
    102.7 KB · Views: 172

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Name
    Rob
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Occupation
    Construction Engineer
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
    Country Flag
    USA
    State/Region Flag
    us california

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top