unable to rename folders in windows 8.1


New Member

I run Windows 8.1 and out of the blue I've recently found that I cant rename a new folder that I've created (so far I've tried it in music , docs , photos and by creating a folder on desktop so seems pretty universal). I've not installed any programmes (except for the latest windows updates) that could have triggered this.

What happens in that when I try to rename the new folder I get a dialogue box that says "cant find specified file make sure you specify correct path and file name." with the options "try again or cancel. When I click on cancel I get a new box that says "file or folder does not exist" which is odd as I've just created it and it is listed as new folder, When I click on it, it opens normally

The same issue occurs when I try to rename existing folders.

I am logged on as an administrator

any help much appreciated as I'm a bit stuck in term sof my files and folders if I cant rename them

My Computer

System One

  • OS
    windows 8.1
    Computer type
    System Manufacturer/Model

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    System Manufacturer/Model
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Manufacturer Gateway Model SX2110G (P0)
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Opera 24.0
    Avast Internet Security
Just recreated my VistaForums account here to say what worked for me. Please read all of this first before you try. This post is almost a year old. The only Microsoft solution so far that did not work for me ( i.e. PranavMishra5582 Microsoft Support Engineer on 9.19.2014 at this Microsoft site: Unable to rename or move folders. "The file or folder does not - Microsoft Community) is removing KB2984006 which is: The September 2014 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup package that resolves issues, and includes performance and reliability improvements. :shock:

:warn: Try this at your own risk. If you are completely satisfied to experiment, have a backup of your system and/or files and do not necessarily want to go back to an earlier image of 8.1 and lose what is newer you can try this. You will need to find someone with the same Windows 8.1 system. I have 8.1 Pro on both PC and laptop, it does not sound right to try anything other than the very same system.

Open regedit on the good machine as an Administrator, if you are very adventuresome you could open, export and import as System user, I did not need to. I say this because importing the registry keys gave me a partial failure saying that not all keys were able to be included because of files in use and/or privileges. It still worked with the keys that did import. Trying in safemode may be useful. I can rename folders now to my heart's content.

Export the FolderDescriptions keys from both:

And then import these to the machine on the operating table as an Administrator or System user. I have had no issues (yet) and did not try David Bailey's fix (thank you!) which you may want to try first.

My Computer

System One

  • OS
    7 / 8.1 / Virtual 10 / MX-Linux / BSD's