What's new

Unable to find dll when running exe off network drive.


New Member
I am trying to run a program where the exe (which is also 32bit if that's relevant) is sitting on a network drive (on server on the same LAN), which happens to be mapped as G:\ on the PC. When I do this it launches the exe but fails to locate a required dll (amw_run.dll) which is in the C:\amdll directory. The error message is Title: "Fatal error!" messageboxtext: "Unable to load application DLL: 'amw_run.dll". I have added this C:\amdll directory which the dll sits in to the PATH variable, but still no joy.

Some other notes\checks already made:
It is not a DLL that requires registering (i.e. with regsvr32).
When running this configuration from a 32bit XP machine it works fine.
When I run it from a 64bit W8 machine it fails to find the dll (as mentioned)
If I copy the runtime directory off the G:\ drive and onto the C:\ drive of the same 64bit W8 machine it runs fine!! The contents of the G:\ and C:\ runtime directories are otherwise identical.

I would like to retain this as a network app such that all users can access it from this location without having to install numerous local copies and update all these local copies whenever the program requires updating...

Anyone hazzard a guess as to what's going on and how I might get around\fix the issue - I'm completely baffled!

Many Thanks...

My Computer

System One

  • OS
    Windows 8 Pro 64 bit

Users Who Are Viewing This Thread (Users: 0, Guests: 1)