• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Switch to Microsoft account


Posts
3
#1
Hi guys!

I installed Win8CP on my laptop, over my Win7 pro. During the last stage of installation, it asked me to use my Hotmail credentials, but it was impossible because I didn't had Internet connection in that moment. It was mentioned that I can do that later, so I skipped it and used my current User Profile password and Name (Administrator).

When I installed Win8CP, and tried to swich from local to my Hotmail (Microsoft) account, it doesn't realy switch it, just change my name to email address and that wasn't enough because I see on SkyDrive application which says "To use SkyDrive, change your account settings", which is very strange.

But, I tried to create another User on my laptop (NB: I have only one account, with Administrator rights) and that new user profile can associate itself with Hotmail credentials, I can see my Hotmail name and picture on the right corner in Metro and I can use all applications, including SkyDrive.

So, does anybody had simmilar problem and is there a solution for this situation? I ask because all my applications, files and settings are under my primary Profile and it will be very hard to switch to another User.

And, is there any possibility for reinstalation of Win8CP to have my Hotmail (Microsoft) account associated to Win8CP, but to preserve all files as I did when changing from Win7 to Win8CP?



Best,
Ivan S. V.
 

My Computer

System One

  • OS
    Windows 8 CP
Posts
4
#2
My setup went exactly the same as yours, When I could not access my skydrive I created a new Live account and it works fine, I also went back to a local account then removed the PC from the trusted list in my account details, and swapped back to the MS account but it never sent me any request to add the PC into the trusted list. I changed the PC name and added it manually but that made no difference. The new account I created has the old pc name logged in the trusted list.

When I first logged in with the local account I was prompted to enter my live details for email access. Also if I go into pictures I can see the pics in my skydrive but not access the skydrive app.

I too was wondering if the Refresh PC without affecting files button might help.

I think it might have been a good idea to log out of all live software on the PC and rename it before installing.

If it is connected I was unable to install using the web based installer and had to use the 64bit iso.
 

My Computer

System One

  • OS
    Windows 8
Posts
4
#3
Well I sort of fixed it, I swapped to the local account I created and un-installed Live extras. the swapped to the new live account I created. and re-installed. This did nothing ! still did not work, in fact it got worse as I could now no longer change the second account to a local account.. wtf.

In a huff i hit control pannel and Users, here I clicked create new account which took me to the metro accounts app. clicked new and added my main live address as the user name, got a message saying tell this user to connect to the internet before logging in for the first time. Logged out and back in using new user ( main live account) AND IT WORKS! almost.. everything works but is all as a new user, I had to upgrade account to administrator and am copying all my user files over to the new documents folders created. all files are still there but locked to the second live account. It gives me something to do.

Edit. As I logged in I immediately got a security text update on my phone, and now have the manually added PC name and a second instance of it in my Live account manage security info page. I am not going to delete one at this time :)
 

My Computer

System One

  • OS
    Windows 8
Posts
3
#4
Switching back and forward

Do you mean that If a user sign on with the Life account will not be able to access the local resources that uses Local ID & password? There most be a way to login to the local account and have It linked to the Life account automatically (no switching)... when I sign on to the local account I have access to my network shares (at home in a workgroup with 10 other PC and macs sharing external drives using the same LOCAL user name and passwords and never have to type a password to access them, till Win8). When logged in as Local I get a message if I try to access some Life resource like SkyDrive and shopping, OK now I have to switch account to do that, but if now I try to access my local network drive I just get an error !! (that can not be right) I don't like switching back and forward and I'm sure my customers will not either, but at least give me a message to switch back to my local account, hanging or error can NOT be the way. Can any one provide a solution? Thank you.. Summary: I like to sing on to my local account 100% of the time and have windows link me Life account (like always by memorizing by id and password) and do the exchange automatically, after all is my computer. :)
 
Last edited:

My Computer

System One

  • OS
    Windows 8 CR

Calico

New Member
Power User
Posts
828
#5
Do you mean that If a user sign on with the Life account will not be able to access the local resources that uses Local ID & password? There most be a way to login to the local account and have It linked to the Life account automatically (no switching)... when I sign on to the local account I have access to my network shares (at home in a workgroup with 10 other PC and macs sharing external drives using the same LOCAL user name and passwords and never have to type a password to access them, till Win8). When logged in as Local I get a message if I try to access some Life resource like SkyDrive and shopping, OK now I have to switch account to do that, but if now I try to access my local network drive I just get an error !! (that can not be right) I don't like switching back and forward and I'm sure my customers will not either, but at least give me a message to switch back to my local account, hanging or error can NOT be the way. Can any one provide a solution? Thank you.. Summary: I like to sing on to my local account 100% of the time and have windows link me Life account (like always by memorizing by id and password) and do the exchange automatically, after all is my computer. :)
There shouldn't be any problems connecting to network shares, hosted on other operating systems, when logged in with your Live ID. The only connectivity issue I've seen, was the first time I used the Live ID. On that occasion, when attempting to connect to a share on my Windows server, it gave me a path not found message. I simply tried a second time and all was well. it's not happened since.

Obviously, logging in with a Live ID, is only useful for accessing 'live' metro style applications and synchronising some of the Metro bits between Windows 8 PCs. However, I get the feeling MS would like us to simply login with Live IDs and simply forget 'legacy' user accounts.
 

My Computer

System One

  • OS
    Windows 7 x64 Ultimate/Windows 8.1/Linux
    CPU
    FX-8350
    Motherboard
    GA-990XA-UD3
    Memory
    16GB DDR3 Corsair Vengeance
    Graphics Card(s)
    HD7860
    Sound Card
    Xonar Essence STX
    Monitor(s) Displays
    Benq
    Screen Resolution
    1920x1080
    Hard Drives
    Various
    PSU
    Corsair HX 850W
    Case
    Corsair Obsidian
    Cooling
    Thermalright
    Keyboard
    Logitech
    Mouse
    Logitech
    Internet Speed
    50/50
    Browser
    firefox
Posts
3
#6
Hi guys! Thanks for replies.

I still have problem with my Live.com account I tried to implement onto my main User profile. Skydrive application, even if I "switched" to MS account, it gives me an error "Switch to Microsoft account". Also other applications like mail, contacts and calendar doesn't work as they should.

I had an answer from Microsoft blog site that Live.com account cannot be implemented to the main User profile with Administrative rights, because I installed Win8 CP like a clean install, but the problem can be solver with the option "Reset your PC and start over" which is boring for now, because I have to make a backup of all of my data to the other place...

As I mentioned before, if I create any other new User profile on my laptop, and I create it as Mocrosoft account, it works perfect. The thing I cannot understand, is this only a bug or a main User profiles (Administrator accounts) will not be able to became fully Microsoft accounts in the future if you install Win8 with a clean install?
 

My Computer

System One

  • OS
    Windows 8 CP
Posts
3
#7
Just couple of minutes ago, I found a solution on You’re informed to switch to a Microsoft Account when Signing In - Microsoft Answers and it worked great!

Here's the answer from Microsoft. But it's unclear is this a temporary solution or there will be a fix soon. It works for now.

Symptom:
When running some apps such as the XBox Companion, you get a message "To get the most from this app, switch from your local account to a Microsoft Account on the Users page in PC settings". However, you ARE using your connected account and going to the Users control panel, you only see the option to switch to a local account.

Cause:
This issue will surface if

  • You upgraded from Windows 7 and
  • In Windows 7, you had linked an online ID with your Windows 7 account. This would have been done in the Windows 7 User Accounts control panel by clicking 'Link Online IDs'.

Workaround:

WARNING:
This article describes how to make changes to the Windows Registry. Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 8 Consumer Preview. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.


  1. Launch regedit from the search charm. (Hover over the lower right corner of the screen to show the charms bar. Click the Search icon.)
  2. Navigate to HKEY_USERS\S-1-5-18\Software\Microsoft\IdentityCRL\StoredIdentities and find the email address that failed to connect.
  3. For each S-* under the email address look at the keywords node.
  4. If the keywords node only contains the text 'Associated', then double click on keyword to edit it.
  5. Append ;Connected such that the entry now appears as 'Associated;Connected' (without the quotes).
  6. Switch to your local account, then switch back to your Microsoft Account.
  7. Try to launch your desired application. You should be signed in with the connected account.
 

My Computer

System One

  • OS
    Windows 8 CP