• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Surface RT cannot access network folders - Can't authenti


Portugal

Member
Member
Posts
15
#1
Good morning.

So I've some folders in my Desktop that I want to share with all the hosts in my network, so what i did was to create a new users and set all those folders only to read mode and, everytime I wanted to access the folders on those machines I simply access those folders via that user (in Windows hosts I just enter the network path like \\ip_address\folder , windows then asks for the network password, I authenticate with that user and I have access to those folders.

The thing is that in my Surface RT (Windows RT -ARM), every time I try to access those folders via the method above (\\ip_address\folder), I do see the folders, but when I double click on one of them in order to have access, instead of letting me authenticate, it simply returns the following error: Windows Cannot Access \\ip_address\folder

Why is this so? Why doesn't Windows allow me to authenticate? Is this a limitation of the RT platform?

Regards.
 
Last edited:

My Computer

System One

  • OS
    Windows 8 x64

broe23

Retired from the grind
VIP Member
Pro User
Central IL

Posts
3,468
#2
If you are just opening File Explorer, then Network shares, you should be able to find them. Most likely it is an issue with the RT. It does help to know what OS the other computer is running, what is the mfg & model of the router/gateway you are using.
 

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C850D-st3nx1
    CPU
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Memory
    12GB
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    LCD
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Mouse
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Browser
    Google Chrome
    Antivirus
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.

Portugal

Member
Member
Posts
15
#3
If you are just opening File Explorer, then Network shares, you should be able to find them. Most likely it is an issue with the RT. It does help to know what OS the other computer is running, what is the mfg & model of the router/gateway you are using.
Hello broe23.

As I've said in my previous post, I'm indeed able to find the shares folders in my Surface RT, but I'm not able to access them, when I double click in any one of them, it returns me that error Windows Cannot Access\\ip_address\folder You do not have permission to access instead of asking me for the network password and let me authenticate.
I've already marked that folder permission to anyone (read), and I can access it from the Surface RT, but obviously I don't want them to be openly accessible by anyone inside the LAN.

The other computer is running Windows 8 Pro, and all the other hosts, including some Linux based Media Center are able to access the folders successfully.

Regarding the router, I've the AP's so they form an ESS. But it's unlikely it's one of them causing it.

Regards.
 

My Computer

System One

  • OS
    Windows 8 x64

broe23

Retired from the grind
VIP Member
Pro User
Central IL

Posts
3,468
#4
Firewall is one reason. If you are trying from Metro, that is the other reason. Again, can you see the network shares in File Explorer in the Desktop mode?
 

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C850D-st3nx1
    CPU
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Memory
    12GB
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    LCD
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Mouse
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Browser
    Google Chrome
    Antivirus
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.

Portugal

Member
Member
Posts
15
#5
Firewall is one reason. If you are trying from Metro, that is the other reason. Again, can you see the network shares in File Explorer in the Desktop mode?
Hello.

I'm not trying from Metro, I'm trying from the Explorer in Desktop mode, like in all other versions of windows.

I go to the desktop mode, click on the address bar any windows and type \\ip_address\folder I want to connect to.

In desktop mode if I type \\ip_address\folder (being ip address the address of my desktop), I can see all the folders that are shares, but if I double click in any one of them it will return the "Windows Cannot Access\\ip_address\folder You do not have permission to access" instead of asking me for the network password and let me authenticate.

Regarding the firewall, my routers (who are only AP's and L2 switches), don't have any firewall on L2, no access-lists, nor anything. If they did, I would never even see the folders. And as I said on my previous post, if I create a share that's accessible by anyone, I can access to that share from my Surface RT.

Regards.
 

My Computer

System One

  • OS
    Windows 8 x64

broe23

Retired from the grind
VIP Member
Pro User
Central IL

Posts
3,468
#6
You cannot go to an address bar and type in the IP Address\Folder for connecting to Network shares. You have to open the File Explorer, then click on the Network Icon to find computers on the LAN, that are not sharing folders on the LAN. If you are going to connect to these folder shares all of the time. You need to map them on the Surface.

When you type in the IP address and folder. The Web browser will go out to the web looking for that information, not on the Private LAN.

BTW, you also do not need to state L2 for a Switch. The word AP, could mean that you have a Wireless Router or Wireless Gateway. You have to state exactly what is the manufacturer & model of the networking equipment, if it is asked for, which I asked for in my previous post.
 

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C850D-st3nx1
    CPU
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Memory
    12GB
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    LCD
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Mouse
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Browser
    Google Chrome
    Antivirus
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.

Portugal

Member
Member
Posts
15
#7
You cannot go to an address bar and type in the IP Address\Folder for connecting to Network shares. You have to open the File Explorer, then click on the Network Icon to find computers on the LAN, that are not sharing folders on the LAN. If you are going to connect to these folder shares all of the time. You need to map them on the Surface.

When you type in the IP address and folder. The Web browser will go out to the web looking for that information, not on the Private LAN.

BTW, you also do not need to state L2 for a Switch. The word AP, could mean that you have a Wireless Router or Wireless Gateway. You have to state exactly what is the manufacturer & model of the networking equipment, if it is asked for, which I asked for in my previous post.
Hello Broe23, I think there is some miscommunication going on between us.
First, the address bar I'm talking about is this address bar:


And what's happening is this (it does not let me to authenticate):




Instead of asking for my network password, like this:



Regarding to my Routers'/AP/Switch I've three, one Linksys WRT610N, one TP-link TL-WR843ND and one Zon Hub 1.0. They're all with the same SSID and password so they form a ESS.

Regards.
 

My Computer

System One

  • OS
    Windows 8 x64

Wullail

Active Member
Pro User
Posts
467
#8
have you tried

username:p[email protected]

?

Does the same happen when you display the shares by clicking on the entry in the list on the left bottom side of discovered networked devices?

 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

broe23

Retired from the grind
VIP Member
Pro User
Central IL

Posts
3,468
#9
That error happens when SMB is seeing something wrong between the machines. Just try clicking on the Device again in Network, then click on the Sub folder that is shared inside that device. If you still are getting errors, something is not setup correctly on the other computer to allow Private LAN sharing.

Using the IP, the Router can be messed up with not matching IP with Netbios name. That is why I have asked what is going on three times what is the mfg & model of your router/gateway.

Without that information, we are getting nowhere.
 

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C850D-st3nx1
    CPU
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Memory
    12GB
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    LCD
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Mouse
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Browser
    Google Chrome
    Antivirus
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.

Portugal

Member
Member
Posts
15
#10
That error happens when SMB is seeing something wrong between the machines. Just try clicking on the Device again in Network, then click on the Sub folder that is shared inside that device. If you still are getting errors, something is not setup correctly on the other computer to allow Private LAN sharing.
Hello broe23, I still get that error if I click on the device in Network, and then again on the Sub folder.

Regarding of something not being correctly configured on the remote machine (desktop), it's very unlikely given the fact that I've access to those folders with all my other hosts without any problems whatsoever (Windows and non-Windows machines).


Using the IP, the Router can be messed up with not matching IP with Netbios name. That is why I have asked what is going on three times what is the mfg & model of your router/gateway.

Without that information, we are getting nowhere.
I've already provided the model of the Routers.

Regards.
 

My Computer

System One

  • OS
    Windows 8 x64
#11
Good morning.

So I've some folders in my Desktop that I want to share with all the hosts in my network, so what i did was to create a new users and set all those folders only to read mode and, everytime I wanted to access the folders on those machines I simply access those folders via that user (in Windows hosts I just enter the network path like \\ip_address\folder , windows then asks for the network password, I authenticate with that user and I have access to those folders.

The thing is that in my Surface RT (Windows RT -ARM), every time I try to access those folders via the method above (\\ip_address\folder), I do see the folders, but when I double click on one of them in order to have access, instead of letting me authenticate, it simply returns the following error: Windows Cannot Access \\ip_address\folder

Why is this so? Why doesn't Windows allow me to authenticate? Is this a limitation of the RT platform?

Regards.
I believe the Surface RT has the Server Service, "which allows for sharing locally" turned off by default in order to push things into the cloud.

To turn on the Server Service. Go to the Start screen, choose run, type' Services.msc, set the Server service to Automatic and start the server service via the directions in the following link. You will need to restart after making the adjustments. Hope it works.

How To: Enable File & Printer Sharing Windows/Surface RT | Rashed Talukder's Blog
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Portugal

Member
Member
Posts
15
#12
Good morning.

So I've some folders in my Desktop that I want to share with all the hosts in my network, so what i did was to create a new users and set all those folders only to read mode and, everytime I wanted to access the folders on those machines I simply access those folders via that user (in Windows hosts I just enter the network path like \\ip_address\folder , windows then asks for the network password, I authenticate with that user and I have access to those folders.

The thing is that in my Surface RT (Windows RT -ARM), every time I try to access those folders via the method above (\\ip_address\folder), I do see the folders, but when I double click on one of them in order to have access, instead of letting me authenticate, it simply returns the following error: Windows Cannot Access \\ip_address\folder

Why is this so? Why doesn't Windows allow me to authenticate? Is this a limitation of the RT platform?

Regards.
I believe the Surface RT has the Server Service, "which allows for sharing locally" turned off by default in order to push things into the cloud.

To turn on the Server Service. Go to the Start screen, choose run, type' Services.msc, set the Server service to Automatic and start the server service via the directions in the following link. You will need to restart after making the adjustments. Hope it works.

How To: Enable File & Printer Sharing Windows/Surface RT | Rashed Talukder's Blog
Hello chev65.

I've enabled the Server service, but the problem persists.

Regards.
 

My Computer

System One

  • OS
    Windows 8 x64
#13
Good morning.

So I've some folders in my Desktop that I want to share with all the hosts in my network, so what i did was to create a new users and set all those folders only to read mode and, everytime I wanted to access the folders on those machines I simply access those folders via that user (in Windows hosts I just enter the network path like \\ip_address\folder , windows then asks for the network password, I authenticate with that user and I have access to those folders.

The thing is that in my Surface RT (Windows RT -ARM), every time I try to access those folders via the method above (\\ip_address\folder), I do see the folders, but when I double click on one of them in order to have access, instead of letting me authenticate, it simply returns the following error: Windows Cannot Access \\ip_address\folder

Why is this so? Why doesn't Windows allow me to authenticate? Is this a limitation of the RT platform?

Regards.
I believe the Surface RT has the Server Service, "which allows for sharing locally" turned off by default in order to push things into the cloud.

To turn on the Server Service. Go to the Start screen, choose run, type' Services.msc, set the Server service to Automatic and start the server service via the directions in the following link. You will need to restart after making the adjustments. Hope it works.

How To: Enable File & Printer Sharing Windows/Surface RT | Rashed Talukder's Blog
Hello chev65.

I've enabled the Server service, but the problem persists.

Regards.
Enabling the server service should have this all working straight away as it's a common complaint with the Surface RT.

Have you tried adding the credentials of the Surface User account to the Windows credential manager at the desktop machine via the Control Panel?

The anti virus software could also be preventing you from making a connection with the other machines, or there is a system file problem with the surface RT.

I'm a bit confused on how you added users in order to get sharing to work. This shouldn't be required if the files from the main Users account are shared out correctly via the C:\Users folder sharing permissions.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Portugal

Member
Member
Posts
15
#14
I believe the Surface RT has the Server Service, "which allows for sharing locally" turned off by default in order to push things into the cloud.

To turn on the Server Service. Go to the Start screen, choose run, type' Services.msc, set the Server service to Automatic and start the server service via the directions in the following link. You will need to restart after making the adjustments. Hope it works.

How To: Enable File & Printer Sharing Windows/Surface RT | Rashed Talukder's Blog
Hello chev65.

I've enabled the Server service, but the problem persists.

Regards.
The anti virus software could also be preventing you from making a connection with the other machines, or there is a system file problem with the surface RT.
Hello chev65.

As I said a few posts ago, I'm able to access the desktop shared folders if I set the permissions of those folders to "Everyone", but I don't want to do that for obvious reasons. so a firewall blocking my surface is out of the question.

I'm a bit confused on how you added users in order to get sharing to work. This shouldn't be required if the files from the main Users account are shared out correctly via the C:\Users folder sharing permissions.
I added users on my main machine, and used those credentials to authenticate the other hosts.

Regards.
 

My Computer

System One

  • OS
    Windows 8 x64
#15
Ok sounds good, so adding the user account from the Surface RT doesn't allow for access to the main PC with the usual username/password, while it seems to work fine for all the other locally networked machines.

Have you tried adding the surface RT's user credentials to the Credential Manager via the Control Panel of the main PC?

There are other ways to prevent certain users from accessing specific folders by using a Homegroup and Workgroup together then designate certain Library's with the Everyone share to allow Workgroup machines to access if required.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
Posts
1
#16
Good morning.

So I've some folders in my Desktop that I want to share with all the hosts in my network, so what i did was to create a new users and set all those folders only to read mode and, everytime I wanted to access the folders on those machines I simply access those folders via that user (in Windows hosts I just enter the network path like \\ip_address\folder , windows then asks for the network password, I authenticate with that user and I have access to those folders.

The thing is that in my Surface RT (Windows RT -ARM), every time I try to access those folders via the method above (\\ip_address\folder), I do see the folders, but when I double click on one of them in order to have access, instead of letting me authenticate, it simply returns the following error: Windows Cannot Access \\ip_address\folder

Why is this so? Why doesn't Windows allow me to authenticate? Is this a limitation of the RT platform?

Regards.
Hi, did you ever get this problem resolved? I have the exact same problem on a Nokia Lumia 2520. I can connect via SMB to my home directory on my Mac, but every other share fails as you describe above. These folders can be reached flawlessly from my main Win8.1 machine. Something about the way RT handles authentication must be different.

Any thoughts?
 

My Computer

System One

  • OS
    Windows RT 8.1
    Computer type
    Tablet
    System Manufacturer/Model Number
    Nokia Lumia 2520

Portugal

Member
Member
Posts
15
#17
Good morning.

So I've some folders in my Desktop that I want to share with all the hosts in my network, so what i did was to create a new users and set all those folders only to read mode and, everytime I wanted to access the folders on those machines I simply access those folders via that user (in Windows hosts I just enter the network path like \\ip_address\folder , windows then asks for the network password, I authenticate with that user and I have access to those folders.

The thing is that in my Surface RT (Windows RT -ARM), every time I try to access those folders via the method above (\\ip_address\folder), I do see the folders, but when I double click on one of them in order to have access, instead of letting me authenticate, it simply returns the following error: Windows Cannot Access \\ip_address\folder

Why is this so? Why doesn't Windows allow me to authenticate? Is this a limitation of the RT platform?

Regards.
Hi, did you ever get this problem resolved? I have the exact same problem on a Nokia Lumia 2520. I can connect via SMB to my home directory on my Mac, but every other share fails as you describe above. These folders can be reached flawlessly from my main Win8.1 machine. Something about the way RT handles authentication must be different.

Any thoughts?
Hello.

The only workaround with some form of authentication is to enable Windows HomeGroup.
With HomeGroup, you do have access, the thing is I don't really like not to be able to fully control permissions and such.

If you want to have access regardless, you can set the permissions of said folders to everyone, and that way you'll have access.

Regards.
 

My Computer

System One

  • OS
    Windows 8 x64