• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Stuck on BIOS setup utility loop


noelian13

Member
Member
Posts
55
#1
System Specs
Brand: Asus
Model G1S-1A
OS: Win 8 64bit
Processor: intel core 2 duo @2.3 ghz
RAM: 2 GB
Video Card: Geforce 8600M GT 256 mb

Problem:
it was all okay back then i was working with my document on ms office then i had it on sleep the next day when i opened it it was still okay then i decided to shut down my system then run off to work when i got back and turned on this laptop it just won't get passed the bios setup its like this

Open system->asus rog plays with the logo-> then it will enter the bios set up ->when i exit it it will reboot and the process repeats .

What I tried so far
-Made a bootable USB installer of windows 8 and tried to configure the bios to boot from there, nothing it just wont get past that setup utility so its a no go
-tried the bios recovery by pressing CTRL+Home button then powered it up and it restored the bios successfully - nothing happened to the issue
-tried flashing bios to latest version of bios via usb and ez flash nothing happened
-Tried resetting to manufacture defaults of bios nothing
-Tried pressing ctrl while its booting up windows error recovery pops up got two options
start windows normally or startup recovery
when i press start windows... logo appears then it will restart and go get stuck at the bios utility again
if i press recover still the same


* yes hard drive is still detected and no problems so far

any suggestions?
 

My Computer

System One

  • OS
    Windows 8.1 Build 9600
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Toshiba,Acer(2 notebooks)Asus G1S
    CPU
    Intel i5 2400 @3.1 ghz/i3 4th gen
    Motherboard
    GA-Z77M-D3H
    Memory
    8GB
    Graphics Card(s)
    Sapphire, AMD Radeon HD 6570
    Screen Resolution
    1360x760
    Internet Speed
    40mbps