• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Startup programs won't start


liakou

New Member
Posts
5
#1
Hello, as the title reads, I have this problem and it's really bothering me. Even though the programs(eset ss, ups control program, realtek audio config, idm) are set to start, are not starting up whenever I log into windows. The only program that is starting and it's being shown on the system tray is "ASUS GPU tweak". ESET Smart Security is running as well but won't appear on the tray. Plus if I want to bring it's GUI up by clicking on the program from the start menu, nothing will come up but just a second "eset gui" running as it looks from the task manager.
The rest of the mentioned programs just won't start at all. It appears to be somehow related to the UAC, although im not 100% sure about it. For example, I completely turned notifications of UAC off, I restarted my PC and on startup all of the programs supposed to start, started normally and appeared on the tray. But to rule out this as being the problem, I restarted again and upon startup the programs did not start. It's like whenever I make a change on the UAC, the problem goes away upon next boot, but on further startups the problem is there again....:confused:
I've also tried setting UAC on just the first level but with suppressed elevation prompts for admins and didn't work for long.
Is anyone experiencing the same problem?
Any ideas?!

Thanks in advance.
 

My Computer

System One

liakou

New Member
Posts
5
#2
UPDATE: I did a windows refresh. It's like a rollback to all default settings which keeps your documents/personal files intact. Downside, all the programs are being deleted.
So, I re-installed all programs and drivers one-by-one and restarted the PC after each program installation. All worked normal. Startup programs starting properly and all.....
Until I turned off the PC. When I turned it off and on again, all the startup programs didn't start again like before. They start only after I restart Windows. So for the programs to start I have to power on the PC and after I log into Windows, I must restart it.
After the restart everything's starting as normal..
But of course I don't want to turn on my PC "twice" to be normal..

Any ideas what it could be??
 

My Computer

System One

liakou

New Member
Posts
5
#3
UPDATE 2: So I discovered the source of this problem.
The problem is caused by the windows 8 feature "Hybrid Shutdown".
Once you turn it off every startup program starts normally, whether you shut down the PC, or restart it.
So to anyone experiencing the same problem, do this:

Go to Control panel->Power options and on the left side choices, click "Change what the power buttons do".
On the new window, scroll down to "Shutdown settings" and you'll see an option "Turn on fast startup (recommended)".
Uncheck this option and save changes. Now you can rest assured the problem is gone from the next time you start windows,
everything starts as it should.
 

My Computer

System One

gbs

New Member
Posts
6
#4
UPDATE 2: So I discovered the source of this problem.
The problem is caused by the windows 8 feature "Hybrid Shutdown".
Once you turn it off every startup program starts normally, whether you shut down the PC, or restart it.
So to anyone experiencing the same problem, do this:

Go to Control panel->Power options and on the left side choices, click "Change what the power buttons do".
On the new window, scroll down to "Shutdown settings" and you'll see an option "Turn on fast startup (recommended)".
Uncheck this option and save changes. Now you can rest assured the problem is gone from the next time you start windows,
everything starts as it should.
In my case, it was that I discovered that windows 8 does not run startup shortcuts that have runasadmin flags, either in the shortcut itself or as a compatibility flag.

Am I missing something? The account is an admin account, but for some reason, it keeps asking for admin rights, like for example, when I try to move something to the program files folder. I already turned off UAC. For applications, I have to strictly tell them to run as admin, otherwise they don't elevate themselves. Is this normal windows 8 behavior? Or is there a setting I have to change in order to make an already administrator, an actual administrator?

edit:

Nevermind, fixed it through the local security policy > local policies > security options and disabling
"User Account Control: run all administrators in admin approval mode"

Now, I am an administrator again, can run anything at startup, even elevated applications with any flags, can do anything I like. Windows is mine again.

Nice hideout for the setting though, I'm wondering exactly which way microsoft is going with windows, if you dont want to concede users admin rights, thats what the standard account is for, any action that requires elevation goes through credential verification. Thats the normal behavior, windows 8, even as admin with uac disabled, you have to approve system changes. Not cool bro, I bought windows because its not mac os...

Thus, for anybody having problems running stuff at startup, try disabling approval mode and tweaking the user account settings in the local security policy screen. These are my settings:



Fineprint: metro apps do not work with UAC disabled. Mother of god... this operating system...
 
Last edited:

My Computer

System One

  • OS
    Win8x64
Posts
6
#5
Not really smart to disable UAC because most new applications expect UAC to be there, especially any apps that you installed before turning off UAC. This causes tons of problems later on down the line, seen it hundreds of times with people who turned off UAC in Windows 7 after installing programs with it on, led to corruption in programs and would often lead to a complete reinstall of Windows eventually. The best advice here would be to disable the secure desktop only and enable Admin approval mode which will not disable UAC, but will just pop up an approval screen without dimming the desktop. It really is not smart for anyone to always run as an admin, especially since all applications since Windows XP are built with UAC exceptions in them already. I don't think you realize what you are saying...
 

My Computer

System One

  • OS
    Windows 7 , 8 , OpenSuse12.1, Ubuntu 12.04, Fedora
    System Manufacturer/Model Number
    HP
    CPU
    AMD Turion
    Motherboard
    HP
    Memory
    8gb
    Graphics Card(s)
    ATI, AMD

gbs

New Member
Posts
6
#6
Not really smart to disable UAC because most new applications expect UAC to be there, especially any apps that you installed before turning off UAC. This causes tons of problems later on down the line, seen it hundreds of times with people who turned off UAC in Windows 7 after installing programs with it on, led to corruption in programs and would often lead to a complete reinstall of Windows eventually. The best advice here would be to disable the secure desktop only and enable Admin approval mode which will not disable UAC, but will just pop up an approval screen without dimming the desktop. It really is not smart for anyone to always run as an admin, especially since all applications since Windows XP are built with UAC exceptions in them already. I don't think you realize what you are saying...
I know perfectly well what I'm saying... I've been running like that since vista, that means since 6 years ago, even using the built in admin account in the last two iterations of windows. You see, not all applications have exceptions for UAC already, nor are they granted admin rights automatically and having to close and reopen them as admin is a nice waste of time. Not to mention, them not even running at startup due to that is a greater joke. And no, i have never had an operating system corruption with a need for reinstall due to UAC, I dont even see how that is possible. I'm fairly aware of the "dangers" of running as admin, but I have never had a problem with application corruption, viruses or malware, since I have the good old common sense.

It really is not smart for anyone to discredit someone without any information whatsoever :think:. You don't recommend it? fine, i dont recommend it either, but it may solve people's problems with applications in windows 8 since UAC works differently than it did in 7, or at least is more persistent, and if x86 applications are a priority over the toy metro ones, then disabling them wont hurt. The "windows e-parent" behavior is getting a bit old already.
 

My Computer

System One

  • OS
    Win8x64

stealth2920

Member
Member
Posts
19
#7
Not really smart to disable UAC because most new applications expect UAC to be there, especially any apps that you installed before turning off UAC. This causes tons of problems later on down the line, seen it hundreds of times with people who turned off UAC in Windows 7 after installing programs with it on, led to corruption in programs and would often lead to a complete reinstall of Windows eventually. The best advice here would be to disable the secure desktop only and enable Admin approval mode which will not disable UAC, but will just pop up an approval screen without dimming the desktop. It really is not smart for anyone to always run as an admin, especially since all applications since Windows XP are built with UAC exceptions in them already. I don't think you realize what you are saying...
I know perfectly well what I'm saying... I've been running like that since vista, that means since 6 years ago, even using the built in admin account in the last two iterations of windows. You see, not all applications have exceptions for UAC already, nor are they granted admin rights automatically and having to close and reopen them as admin is a nice waste of time. Not to mention, them not even running at startup due to that is a greater joke. And no, i have never had an operating system corruption with a need for reinstall due to UAC, I dont even see how that is possible. I'm fairly aware of the "dangers" of running as admin, but I have never had a problem with application corruption, viruses or malware, since I have the good old common sense.

It really is not smart for anyone to discredit someone without any information whatsoever :think:. You don't recommend it? fine, i dont recommend it either, but it may solve people's problems with applications in windows 8 since UAC works differently than it did in 7, or at least is more persistent, and if x86 applications are a priority over the toy metro ones, then disabling them wont hurt. The "windows e-parent" behavior is getting a bit old already.
I have never run the UAC since the first time I saw it however many operating systems ago. Never had a corrupt file due to that. The very first thing I do when installing an operating system is turn off the pain in the A-- UAC.
 

My Computer

System One

  • OS
    Win 8 Pro
    CPU
    i7
    Motherboard
    Asrock Pro
    Memory
    32 G
    Graphics Card(s)
    Gigabyte Radeon HD 7870 2GB
    Hard Drives
    2 Raptor 1000 G
    PSU
    Corsair 1000

Toenail

New Member
Posts
2
#8
Thank you GBS, once i changed that policy - EVERYTHING is working as normal.
Startup items, everything - even Skyrim runs better now :)

I suspected MS would do this, mundane but logical way to combat future malicious apps etc
use a decent anti-virus (in my experience, don't use Mcafee!! :p)

cheers
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Self Assembled
    CPU
    Phenom ll 975 BE
    Motherboard
    ASUS M4A77TD PRO
    Memory
    8GB DDR3
    Graphics Card(s)
    HD6950 2G
    Browser
    Chrome
    Antivirus
    Avast
Posts
1
#9
UPDATE 2: So I discovered the source of this problem.
The problem is caused by the windows 8 feature "Hybrid Shutdown".
Once you turn it off every startup program starts normally, whether you shut down the PC, or restart it.
So to anyone experiencing the same problem, do this:

Go to Control panel->Power options and on the left side choices, click "Change what the power buttons do".
On the new window, scroll down to "Shutdown settings" and you'll see an option "Turn on fast startup (recommended)".
Uncheck this option and save changes. Now you can rest assured the problem is gone from the next time you start windows,
everything starts as it should.
In my case, it was that I discovered that windows 8 does not run startup shortcuts that have runasadmin flags, either in the shortcut itself or as a compatibility flag.

Am I missing something? The account is an admin account, but for some reason, it keeps asking for admin rights, like for example, when I try to move something to the program files folder. I already turned off UAC. For applications, I have to strictly tell them to run as admin, otherwise they don't elevate themselves. Is this normal windows 8 behavior? Or is there a setting I have to change in order to make an already administrator, an actual administrator?

edit:

Nevermind, fixed it through the local security policy > local policies > security options and disabling
"User Account Control: run all administrators in admin approval mode"

Now, I am an administrator again, can run anything at startup, even elevated applications with any flags, can do anything I like. Windows is mine again.

Nice hideout for the setting though, I'm wondering exactly which way microsoft is going with windows, if you dont want to concede users admin rights, thats what the standard account is for, any action that requires elevation goes through credential verification. Thats the normal behavior, windows 8, even as admin with uac disabled, you have to approve system changes. Not cool bro, I bought windows because its not mac os...

Thus, for anybody having problems running stuff at startup, try disabling approval mode and tweaking the user account settings in the local security policy screen. These are my settings:



Fineprint: metro apps do not work with UAC disabled. Mother of god... this operating system...
I cannot for the life of me find the local security policy screen.
 

My Computer

System One

  • OS
    Windows 8.1

4wd

New Member
Power User
Posts
375
#10
In my case, it was that I discovered that windows 8 does not run startup shortcuts that have runasadmin flags, either in the shortcut itself or as a compatibility flag.
:) Good tip, learned something new today. Had a battle with some programs refusing to load at startup.
 

My Computer

System One

  • OS
    W8.1, W7
    Computer type
    Laptop
    System Manufacturer/Model Number
    HP \ Toshiba \ Lenovo \ Dell E7440
    Browser
    FF

gbs

New Member
Posts
6
#11
In my case, it was that I discovered that windows 8 does not run startup shortcuts that have runasadmin flags, either in the shortcut itself or as a compatibility flag.
:) Good tip, learned something new today. Had a battle with some programs refusing to load at startup.
Totally forgot i wrote in this thread.
Late tip: If anyone uses metro/modern apps and wants to run admin apps at startup, use the task scheduler to launch them at logon with high privileges.
 

My Computer

System One

  • OS
    Win8x64

laplagam

New Member
Posts
1
#12
UPDATE 2: So I discovered the source of this problem.
The problem is caused by the windows 8 feature "Hybrid Shutdown".
Once you turn it off every startup program starts normally, whether you shut down the PC, or restart it.
So to anyone experiencing the same problem, do this:

Go to Control panel->Power options and on the left side choices, click "Change what the power buttons do".
On the new window, scroll down to "Shutdown settings" and you'll see an option "Turn on fast startup (recommended)".
Uncheck this option and save changes. Now you can rest assured the problem is gone from the next time you start windows,
everything starts as it should.
In my case, it was that I discovered that windows 8 does not run startup shortcuts that have runasadmin flags, either in the shortcut itself or as a compatibility flag.

Am I missing something? The account is an admin account, but for some reason, it keeps asking for admin rights, like for example, when I try to move something to the program files folder. I already turned off UAC. For applications, I have to strictly tell them to run as admin, otherwise they don't elevate themselves. Is this normal windows 8 behavior? Or is there a setting I have to change in order to make an already administrator, an actual administrator?

edit:

Nevermind, fixed it through the local security policy > local policies > security options and disabling
"User Account Control: run all administrators in admin approval mode"

Now, I am an administrator again, can run anything at startup, even elevated applications with any flags, can do anything I like. Windows is mine again.

Nice hideout for the setting though, I'm wondering exactly which way microsoft is going with windows, if you dont want to concede users admin rights, thats what the standard account is for, any action that requires elevation goes through credential verification. Thats the normal behavior, windows 8, even as admin with uac disabled, you have to approve system changes. Not cool bro, I bought windows because its not mac os...

Thus, for anybody having problems running stuff at startup, try disabling approval mode and tweaking the user account settings in the local security policy screen. These are my settings:



Fineprint: metro apps do not work with UAC disabled. Mother of god... this operating system...
I cannot for the life of me find the local security policy screen.
Hi, I had problems with the same thing. What you can do is hit the windows key+r and type secpol.msc and click enter. That should do the trick.
 

My Computer

System One

  • OS
    Windows 8.1.
    Computer type
    PC/Desktop
#13
In my Win 8.1 Basic I found a similar solution

In my Win 8.1 Basic I don't have this options.
I made this change in this way:

  1. Control Panel > User Accounts > Change User Account Control Settings > Never Notify
  2. Run > RegEdit:
    Set the key: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Policies \ System \ EnableLUA to 0.
    About this option read about it here: windows 8 - How do I make every program run as an admin? - Super User
Thanks,
 

My Computer

System One

  • OS
    Windows 8.1

Portugal

Member
Member
Posts
15
#14
UPDATE 2: So I discovered the source of this problem.
The problem is caused by the windows 8 feature "Hybrid Shutdown".
Once you turn it off every startup program starts normally, whether you shut down the PC, or restart it.
So to anyone experiencing the same problem, do this:

Go to Control panel->Power options and on the left side choices, click "Change what the power buttons do".
On the new window, scroll down to "Shutdown settings" and you'll see an option "Turn on fast startup (recommended)".
Uncheck this option and save changes. Now you can rest assured the problem is gone from the next time you start windows,
everything starts as it should.
Thanks, I had the exact same problem in Windows 8.1 and your suggestion solved it :)
 

My Computer

System One

  • OS
    Windows 8 x64

tombar

New Member
Posts
5
#15
In my Win 8.1 Basic I don't have this options.
I made this change in this way:

  1. Control Panel > User Accounts > Change User Account Control Settings > Never Notify
  2. Run > RegEdit:
    Set the key: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Policies \ System \ EnableLUA to 0.
    About this option read about it here: windows 8 - How do I make every program run as an admin? - Super User
Thanks,
Thanks, Sorted this for me as well - I don't know why two programs suddenly stopped loading, but it's sorted.

Regarding the Local Policy approach, I seem to remember reading that the option to change these settings isn't available in basic Win 8.1 (need Pro)


Edit: Mmmh! Every time I have this set, I get a volsnap on system reboot and lose my System Restore point!
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1