• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Slow Slow internet speed with Windows 8


slantpro

New Member
Posts
1
#1
Purchased Windows 8 Pro with a new computer system, an HP Envy, last week for work.

Have a dedicated 20 down and 20 up connection that is functioning at speed.

Loading internet pages with Windows 8 is incredibly slow. Had the very same connection with a 7 year old HP using Windows XP and the speed blew this away.

Help?
 

My Computer

System One

  • OS
    windows 8

Mystere

Power User
VIP Member
Power User
Posts
1,925
#2
Slow pages are usually a sign of a dns problem. How do you have DNS configured? Are you using a gateway or router of some kind? Is that configured properly?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    CPU
    Intel i7 3770K
    Motherboard
    Gigabyte Z77X-UD4 TH
    Memory
    16GB DDR3 1600
    Graphics Card(s)
    nVidia GTX 650
    Sound Card
    Onboard Audio
    Monitor(s) Displays
    Auria 27" IPS + 2x Samsung 23"
    Screen Resolution
    2560x1440 + 2x 2048x1152
    Hard Drives
    Corsair m4 256GB, 2 WD 2TB drives
    Case
    Antec SOLO II
    Keyboard
    Microsoft Natural Ergonomic Keyboard 4000
    Mouse
    Logitech MX
#3
Purchased Windows 8 Pro with a new computer system, an HP Envy, last week for work.

Have a dedicated 20 down and 20 up connection that is functioning at speed.

Loading internet pages with Windows 8 is incredibly slow. Had the very same connection with a 7 year old HP using Windows XP and the speed blew this away.

Help?
First thing you should do when ever you purchase a new OEM machine is to remove all the useless preinstalled non windows software that came on your laptop "otherwise known as bloatware", especially any third party A/V software. This stuff is famous for causing connection slowdown problems not to mention a million other problems.

After that visit Windows update and see if there are any updates for your system.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
Posts
1
#4
Hi.
I think i found the solution.


1. Open Network Sharing Center
2. Click Change Adapter Settings
3 Right click on WiFi and choose properties
4 Click Configure
5 Choose Advanced
6 From the list below choose minimum power consumption and change value to disable
7 Click Ok.


Hope it helps.
 

My Computer

System One

  • OS
    win 8 64

Users Who Are Viewing This Thread (Users: 0, Guests: 1)