• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Sleep mode turns off keyboard and mouse


eldiener

New Member
Posts
16
#1
I have a wired USB keyboard and a wireless USB mouse on my computer. I have set the Power Options for sleep mode under Windows 8.1 to occur after a certain amount of time. When I have returned to my computer when it is in Sleep mode after a particularly long period of time both the keyboard and the mouse USB ports are turned off and there is then no way I can resume from sleep mode. What do I have to do to have sleep mode work on my computer under Windows ?
 

My Computer

System One

  • OS
    Windows 7

MilesAhead

Eclectician
VIP Member
Pro User
Posts
2,130
#2
Open Device Manager by pressing Winkey x, then m. Open the properties for each USB hub, click the Power Management Tab. Make sure the box to allow the system to turn off power is unchecked.

usb.png
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad

eldiener

New Member
Posts
16
#3
Open Device Manager by pressing Winkey x, then m. Open the properties for each USB hub, click the Power Management Tab. Make sure the box to allow the system to turn off power is unchecked.

View attachment 67588
I see a number of devices for my computer under the Universal Serial Bus Controllers, including Generic USB Hub, Standard Enhanced PCI to USB Enhanced Controller, Standard OpenHCD USB Host Controller, USB Composite Device, and USB Root Hub. Should I make sure the box to allow the system to turn off power is unchecked for all of them ?

I tried to follow the particular keyboard and mouse connection when viewing Devices by Connection but the connections which Device Manager is showing me do not appear to be the actual connections on my computer for some reason.
 

My Computer

System One

  • OS
    Windows 7

MilesAhead

Eclectician
VIP Member
Pro User
Posts
2,130
#4
Of the ones I looked at, only USB port hub had the setting. So I would just try unchecking them all.

Here's the tutorial link where I got the suggestion. I should have posted it with the screen shot.

Prevent Windows from Turning Off USB Devices
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad

eldiener

New Member
Posts
16
#7
Of the ones I looked at, only USB port hub had the setting. So I would just try unchecking them all.

Here's the tutorial link where I got the suggestion. I should have posted it with the screen shot.

Prevent Windows from Turning Off USB Devices
Thanks ! Unchecking all of them did work properly and I am able to resume from sleep mode with either my USB keyboard or USB mouse.

What is strange is that if I just unchecked the USB hubs connected to my keyboard and mouse this was not enough to allow my keyboard or mouse to work to resume from sleep. Perhaps Windows 8.1 is showing the connections for my keyboard and mouse incorrectly.
 

My Computer

System One

  • OS
    Windows 7

MilesAhead

Eclectician
VIP Member
Pro User
Posts
2,130
#8
Of the ones I looked at, only USB port hub had the setting. So I would just try unchecking them all.

Here's the tutorial link where I got the suggestion. I should have posted it with the screen shot.

Prevent Windows from Turning Off USB Devices
Thanks ! Unchecking all of them did work properly and I am able to resume from sleep mode with either my USB keyboard or USB mouse.

What is strange is that if I just unchecked the USB hubs connected to my keyboard and mouse this was not enough to allow my keyboard or mouse to work to resume from sleep. Perhaps Windows 8.1 is showing the connections for my keyboard and mouse incorrectly.
Power management, like wireless networking, I avoided for some time. When I was doing support I saw a lot of problems with hibernation, sleep etc. when it was a new thing. So I just ran everything in performance mode and did my networks wired. For this reason I do not know as much about it as many others on the forum. But I do seem to notice that doing stuff like setting your network card not to wake on Lan does not seem to stop it from waking the machine unless you do it at the device manager level.

At least that is my impression. Windows keeps a list,at least for USB drives, in the registry. Often I notice if I plug in a USB stick the same size as another stick, both having a different drive letter on last use, it will assign it the last drive letter used even if it is for the other stick.

Maybe something similar goes on with other USB stuff. I am not sure. But I am glad the work-around does the trick for you. :)
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad

eldiener

New Member
Posts
16
#9
Hibernate not working but Sleep is working

I realized just recently that Sleep is working on my computer, even if I change nothing in the default Power Management Balanced settings which I use and also accept the defaults in the Device Manager for my USB devices and USB hubs. It was my error to think that Sleep was not working for my computer on Windows 8.1.

What is hanging up on my computer is Hibernate, which the default Power Management Balanced settings | Advanced Settings has occurring after 180 minutes, or 3 hours, of inactivity ( Sleep triggers off after 30 minutes of inactivity ). When Hibernate occurs my keyboard and mouse shut down and the only thing which seems on is the computer itself, so pressing a key on the keyboard or clicking my mouse does nothing and I can't seem to get out of Hibernate.

What is the usual way of waking up from Hibernate in Windows ?

Even briefly pressing the Power Button, when in Hibernate, does nothing which I can see.

OTOH my computer, which is fairly old, does not support the ACPI S4 state, but only the S1 and S3 states. Could this be the reason why I cannot wake up from Hibernate ?
 

My Computer

System One

  • OS
    Windows 7

MilesAhead

Eclectician
VIP Member
Pro User
Posts
2,130
#10
OTOH my computer, which is fairly old, does not support the ACPI S4 state, but only the S1 and S3 states. Could this be the reason why I cannot wake up from Hibernate ?
Speaking of which you give no info about the PC make,model, processor etc..
There must be a Windows 8.1 hardware compatibility grid around somewhere. The trouble is MS pages like this one got overwritten with the W10 stuff:
https://www.microsoft.com/en-us/windows

Perhaps this site will give a lead:
Is Your Software & Hardware Compatible With Windows 8.1?

If anyone is adept at hibernate problems on older PCs fell free to chip in. I avoided hibernate and deleted the .sys file whenever possible.
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad

eldiener

New Member
Posts
16
#11
OTOH my computer, which is fairly old, does not support the ACPI S4 state, but only the S1 and S3 states. Could this be the reason why I cannot wake up from Hibernate ?
Speaking of which you give no info about the PC make,model, processor etc..
There must be a Windows 8.1 hardware compatibility grid around somewhere. The trouble is MS pages like this one got overwritten with the W10 stuff:
https://www.microsoft.com/en-us/windows

Perhaps this site will give a lead:
Is Your Software & Hardware Compatible With Windows 8.1?

If anyone is adept at hibernate problems on older PCs fell free to chip in. I avoided hibernate and deleted the .sys file whenever possible.
As it turns out I do have to make sure in Device Manager that all my USB hubs are set so that they cannot be powered off in order to get Sleep to work. But in Hibernate mode it seems that all my USB hubs are powered off and the Power button no longer does anything.

My computer is an MSI K9A2 mobo. The BIOS supports S1 and S3 but there is no mention of S4. I think the lack of S4 is why there is no way to return from Hibernate for me. At least Sleep does work consistently.
 

My Computer

System One

  • OS
    Windows 7

TechnoMage

Active Member
Power User
Central Florida

Posts
394
#12
Just a little trip down Memory Lane.....memories to share with the newcomers.

Going all the way back to when MS first introduced the Sleep mode, people have been posting that their PC went to sleep and never woke up again. :mad:

So, I've just made it a standard part of every Windows install to totally disable Sleep and Hibernate and to only allow two modes on those PC's, that being ON and OFF. Everything is much safer that way. And you avoid having that humongous 'Hiberfil.sys' file residing in your Root Directory.
Actually, I don't even like screen savers, on home computers, because I've found programs that will stop working while a screen saver is ON. Modern day computer screens really don't need saving anyway, because they don't 'Burn', like the old CRT's did.

I thoroughly subscribe to the K.I.S.S. method of running a computer (Keep It Simple, Stupid)
The more complicated you make it, the greater the chance of something going just terribly wrong, because Windows is far from being Bullet Proof. :rolleyes:

Good Luck,
TechnoMage :cool:
 

My Computer

System One

  • OS
    Win-8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gigabyte
    CPU
    AMD 8 Core
    Motherboard
    Gigabyte
    Memory
    PNY, 4GB
    Graphics Card(s)
    NVIDIA, GForce 210
    Monitor(s) Displays
    21" HP
    Hard Drives
    Seagate SATA III, 500GB
    PSU
    Antec Earthwatts, 650
    Case
    Pac-Man Case
    Keyboard
    HP Professional
    Mouse
    GearHead Wireless
    Internet Speed
    5 Meg
    Browser
    Firefox
    Antivirus
    AVG Free
    Other Info
    Using Classic Shell on Win-8.1 pro

MilesAhead

Eclectician
VIP Member
Pro User
Posts
2,130
#13
I agree with all your points TM.

Modern day computer screens really don't need saving anyway, because they don't 'Burn', like the old CRT's did.
Even in the case of CRT monitors the only time I ever saw images "burned in" to one of them was when a company would have the monitor sitting on a table in Reception with the company logo displayed for months on end. When I first got my Laptop fast booting seemed cool until I realized it also caused headaches. Better just to boot normally. If something does go wrong it is much easier to figure out what. :)
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad

Users Who Are Viewing This Thread (Users: 0, Guests: 1)