• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Self-extracting executable results in file error.


mwo100

New Member
Posts
3
#1
Hi, any help would be appreciated,

Trying to install ENVI 5.0 which in the case of this installation uses a self extracting executable.

When attempting to install the extraction scrolls to 100% then pops up a "7 Zip" error stating that, "The specified file cannot be found."

Running as administrator results in the error.
Running in compatibility mode results in the error.
Uninstalling 7-zip and restarting computer results in error. Looking at the .exe properties reveals that the .exe was likely made with 7-ZIP SFX Maker so the zip application on my computer likely wasn't the issue. Installing WINRAR instead didn't solve the problem.
Restoring default file extension type association for .exe results in error.

Any help would be greatly appreciated as I need this program for a college course.

Thanks,

mwo100
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Dell
    CPU
    Intel Core i7-4510
    Memory
    8 Gb
    Graphics Card(s)
    Nvidia GeForce 840M
    Browser
    Firefox
    Antivirus
    Avast

KYHI

Well-Known Member
Pro User
Posts
2,753
#2
redownload the file
 

My Computer

System One

  • OS
    Windows 3.1 > Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dell XPS 8700
    CPU
    I7
    Memory
    24 GB

mwo100

New Member
Posts
3
#3
Thank you for the suggestion. Re-downloading didn't work. Acquiring the file from another student didn't work.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Dell
    CPU
    Intel Core i7-4510
    Memory
    8 Gb
    Graphics Card(s)
    Nvidia GeForce 840M
    Browser
    Firefox
    Antivirus
    Avast

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#4
A self extracting executable does not need any third party archiver, it should do it all by itself. You can try opening it with any archiver directly. Open archiver and find that file thru it, if it still can't open, than file is no good.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

KYHI

Well-Known Member
Pro User
Posts
2,753
#5
A self extracting executable does not need any third party archiver, it should do it all by itself.
Good Catch...

Or Right Click Open With - archiver
 

My Computer

System One

  • OS
    Windows 3.1 > Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dell XPS 8700
    CPU
    I7
    Memory
    24 GB

mwo100

New Member
Posts
3
#6
Hey guys,

Thanks for the tips. Working with ENVI support I've found out that having anti-virus active while downloading the executable leads to it malfunctioning. Turning off Avast while downloading and installing causes it to work.

Thanks.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Dell
    CPU
    Intel Core i7-4510
    Memory
    8 Gb
    Graphics Card(s)
    Nvidia GeForce 840M
    Browser
    Firefox
    Antivirus
    Avast

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#7
Hey guys,

Thanks for the tips. Working with ENVI support I've found out that having anti-virus active while downloading the executable leads to it malfunctioning. Turning off Avast while downloading and installing causes it to work.

Thanks.
That was my next guess.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

Users Who Are Viewing This Thread (Users: 0, Guests: 1)