• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

"Secure Connection Failed" when trying to connect to this one website on my desktop


#1
I've been trying to resolve this before and did not succeed. So I have to start again.

Let me explain the issue:

When I'm trying to connect to the website of this small local bank from my desktop using both Chrome and Firefox browsers, both hang for about half a minute and then display these messages:

Firefox: "Secure Connection Failed"

Capture3.PNG

Chrome: "This site can’t be reached"

Capture2.PNG

Also note, that while waiting, Firefox displays this message at the bottom, "Performing a TLS handshake to ...":

Capture1.PNG

So I tried asking on another forum before and got a flurry of replies, basically all saying to flush my DNS, reset my WiFi router, etc. All generic do-it-noob responses. Note that I've done all that before I asked that question. Namely, I ran:

ipconfig /flushdns

and then:

net stop dnscache
net start dnscache

I also rebooted the desktop and the router, etc. It still didn't help.


Additional observations:

1. If I go to that same site from my laptop that is on the same WiFi network, it connects just fine. This is some configuration on this Windows desktop that makes this site not work.

2. I don't have any issues (that I know of) connecting to any other websites from this desktop.

3. Both Chrome and Firefox are auto-updating to the latest versions.

4. When I just tried connecting to that site again and then tried "ipconfig /displaydns" on that desktop, I got this response from the DNS in the cache:

Capture4.PNG

5. I don't use any third party anti-virus. I'm using whatever Windows 8.1 has built-in (Windows Defender, I think.)


So what could be causing this?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Dell XPS 8700 (customized)
    CPU
    Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
    Motherboard
    Intel Z87
    Memory
    32 GB
    Graphics Card(s)
    Haswell on-board, 2 GB VDRAM
    Sound Card
    Haswell on-board
    Monitor(s) Displays
    Acer / DVI
    Screen Resolution
    1680x1050
    Hard Drives
    C: Mushkin Scorpion PCle SSD, 222 GB
    D: Samsung SSD 840-series, 238 GB
    E: Samsung SSD 840 eVo, 500 GB
    F: WD (Red) HDD, 2 TB
    PSU
    Dell standard
    Case
    Dell standard
    Cooling
    Dell standard
    Keyboard
    Logitech K120
    Mouse
    Infrared wired mouse from Microsoft
    Internet Speed
    Comcast DSL
    Browser
    Google Chrome, Mozilla Firefox, IE
    Antivirus
    Windows 8 built-in