• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Scheduled Task wakes computer up, BUT does NOT run?


firepuppy

New Member
Posts
2
#1
I found LOTS of Windows 8 waking & sleeping issues in this forum, but not this particular one:

This is a backup task I've been using for several years with Windows 7 machines, but only recently started adding to Windows 8.1 boxes. The strange behavior is as follows:

If the computer is on, the task will start at the scheduled time and do it's thing.
If the computer is asleep (S3), it will wake up at the scheduled time, but the task never runs??!!

I have attached the XML export of the task in case anyone's interested.

Any ideas?
 

Attachments

My Computer

System One

  • OS
    Windows 8.1

MilesAhead

Eclectician
VIP Member
Pro User
Posts
2,130
#2
I don't know the cause of the error. But I wonder if a quickie work-around might be to launch an Autohotkey program to move the mouse and click it a couple of times, wait a few seconds, then launch the task? Kludge but it might be easier than fixing Windows. :)

That is, assuming it works. :)
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad

firepuppy

New Member
Posts
2
#3
Solved (I think!!)

I may have an answer to my own problem: I initially thought this was an intermittent issue because during testing it did work once in a while. The backup job ran successfully last night at 10:00pm. On reviewing the event logs, I noticed the machine actually woke up about 30 seconds before the job was scheduled to run (9:59:30). It's possible that some of the tests I did yesterday before reporting the problem were not giving the system enough time to schedule the wakeup 30 seconds in advance of running the job (i.e. setting the job to run in 2 minutes, then saving everything, then putting the machine to sleep manually and not getting all that done soon enough to allow the system to schedule the wakeup 30 seconds before it needed to run the job). That may be why the problem appeared to be intermittent: sometimes I gave it just enough time to schedule the wakeup & sometimes I didn't !!

I just did another test where I set everything up to run 5 minutes AFTER putting the system to sleep and everything worked fine, so I'm going to mark this problem as solved for now.

Thanx for the reply...
 

My Computer

System One

  • OS
    Windows 8.1

MilesAhead

Eclectician
VIP Member
Pro User
Posts
2,130
#4
Often things are timing issues. I hope it stays fixed for you. Thanks for posting the details. :)
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad