• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Remote desktop to active session no longer works in 8.1?


kimjansen

New Member
Posts
1
#1
I've been using the following changes to be able to logon to the 'active' session of a Windows 8 machine:

Run ‘gpedit.msc’, change:

  • Local Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Connections, set “Allow users to connect remotely by using Remote Desktop Services” to ‘Enabled
  • Local Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Connections, set “Restrict Remote Desktop users to a single Remote Desktop Services session” to ‘Enabled
  • Local Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Session Time Limits, set “Set time limit for disconnected sessions” to ‘Enabled’ and ‘Never
  • Local Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Remote Session Environment, set “Remove “Disconnect” option from Shut Down dialog” to ‘Enabled
  • Local Computer Policy->Computer Configuration->Windows Settings->Security Settings->Local Policies->Security Options, set “Accounts: Limit local account use of blank passwords to console logon only” to ‘Disabled

This would allow me to connect using "mstsc /v:IPADDRESS /admin" and to quit the connection and restore the session I'd click a shortcut that called 'tscon' with the following parameters:

“%windir%\System32\tscon.exe RDP-Tcp#0 /dest:console”

This was working fine in Windows 8, but I've discovered that in Windows 8.1 even with the above mentioned changes in the computer policy every session (cmd: "query session") the rdp-tcp ID is no longer rdp-tcp#0 but the number increases after every session.

Am I doing something wrong or has Microsoft made changes to this in 8.1 ?
 

My Computer

System One

  • OS
    Windows 8.1