• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Realtek HD Audio only shows one audio output at a time


Posts
1
#1
Hi guys,


I'm having a little problem with my onboard audio, having just installed Windows 8.1 (clean install). I have an Asus P8Z77-V LE PLUS motherboard, which includes a "Realtek® ALC889 8-Channel High Definition Audio CODEC" onboard.
I have installed the latest realtek drivers; R2.73 from the official website.


Now, here's my problem: when I was using Windows 7 on this same machine, I could plug headphones in the front panel connector, as well as speakers in the green back panel connector. This would give me two audio outputs in the device manager/sound list, which was pretty practical and enabled me to output different applications through the speakers or the headphones.


Now, however, there's only one output, irrelevant of whether or not I have two outputs plugged in at the same time. They appear in the device manager as a single device called "speakers" (see picture). Instead of both having separate outputs, they both output exactly the same audio.

Capture.PNG


Any solution to this?
 

My Computer

System One

  • OS
    Windows 8.1

QWERTYFREAK

Member
Member
Posts
15
#2
Hello audiobreak,

Try going into the Realtek HD Audio Manager (Control Panel > Hardware and Sound > Realtek HD Audio Manager), then look for a setting called 'Make front and rear output devices playback two different audio streams simultaneously'. I cannot remember where this is located (The Realtek HD Audio Manager has different skins depending on the motherboard vendor), but for an ASUS Motherboard, I believe you click the Cog Icon in the top left and the option should be in there. I don't know if this will create a separate Playback Device for the Front Panel in Window's Playback Devices, but it will at least allow you to hear audio from both your speakers and headphones at the same time.

Hope this helps.
 

My Computer

System One

  • OS
    N/A

fireberd

Beach Observer
VIP Member
Pro User
Inverness, FL

Posts
1,811
#3
I have that motherboard and yesterday updated the RealTek drivers from the ASUS site to the latest which includes Windows 8.1 support.
The Driver version is 6.0.1.7040. It changes the look of the RealTek HD Audio Panel. It no longer has that option, that I can see.

New Version.

Win 8.1 RealTek HD Manager.JPG
 

My Computer

System One

  • OS
    Win 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Built
    CPU
    i7 6700K
    Motherboard
    ASUS ROG Maximus VIII Hero
    Memory
    16 Gb G Skill TridentZ DDR4 3400
    Graphics Card(s)
    Intel (i7 CPU)
    Sound Card
    RealTek Integrated
    Monitor(s) Displays
    27" Dell SE2717HR
    Screen Resolution
    1920X1080
    Hard Drives
    500GB Samsung 850 SSD, 3TB for backups
    PSU
    EVGA Supernova 750 G2
    Case
    BeQuiet Silent Base 600
    Cooling
    Deepcool Captain 120EX
    Keyboard
    Microsoft Wireless
    Mouse
    Logitech wireless
    Internet Speed
    Cable - 100MB Downlink
    Browser
    Edge/Firefox
    Antivirus
    Microsoft
    Other Info
    Sonar Platinum 64 bit recording studio software with MOTU 896Mk3 Hybrid recording interface unit.

QWERTYFREAK

Member
Member
Posts
15
#4
I have that motherboard and yesterday updated the RealTek drivers from the ASUS site to the latest which includes Windows 8.1 support.
The Driver version is 6.0.1.7040. It changes the look of the RealTek HD Audio Panel. It no longer has that option, that I can see.

New Version.

View attachment 34162
Ah, I cannot help out then as I've never ever seen or used that Realtek HD Audio Manager. The option is either hidden somewhere in there or maybe even removed for whatever reason.

I see a Cog in the top right of the window though. Try clicking that and see if the option is in there.
 

My Computer

System One

  • OS
    N/A

fireberd

Beach Observer
VIP Member
Pro User
Inverness, FL

Posts
1,811
#5
That's it. The "gear" in the top right of the panel has the options for speakers.

Realtek Options Panel.JPG
 

My Computer

System One

  • OS
    Win 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Built
    CPU
    i7 6700K
    Motherboard
    ASUS ROG Maximus VIII Hero
    Memory
    16 Gb G Skill TridentZ DDR4 3400
    Graphics Card(s)
    Intel (i7 CPU)
    Sound Card
    RealTek Integrated
    Monitor(s) Displays
    27" Dell SE2717HR
    Screen Resolution
    1920X1080
    Hard Drives
    500GB Samsung 850 SSD, 3TB for backups
    PSU
    EVGA Supernova 750 G2
    Case
    BeQuiet Silent Base 600
    Cooling
    Deepcool Captain 120EX
    Keyboard
    Microsoft Wireless
    Mouse
    Logitech wireless
    Internet Speed
    Cable - 100MB Downlink
    Browser
    Edge/Firefox
    Antivirus
    Microsoft
    Other Info
    Sonar Platinum 64 bit recording studio software with MOTU 896Mk3 Hybrid recording interface unit.

fireberd

Beach Observer
VIP Member
Pro User
Inverness, FL

Posts
1,811
#7
No way that I've ever found. You can have "Analog" (Speakers) or "Digital" but not both. Internal routing of the audio is different depending on which is selected.
 

My Computer

System One

  • OS
    Win 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Built
    CPU
    i7 6700K
    Motherboard
    ASUS ROG Maximus VIII Hero
    Memory
    16 Gb G Skill TridentZ DDR4 3400
    Graphics Card(s)
    Intel (i7 CPU)
    Sound Card
    RealTek Integrated
    Monitor(s) Displays
    27" Dell SE2717HR
    Screen Resolution
    1920X1080
    Hard Drives
    500GB Samsung 850 SSD, 3TB for backups
    PSU
    EVGA Supernova 750 G2
    Case
    BeQuiet Silent Base 600
    Cooling
    Deepcool Captain 120EX
    Keyboard
    Microsoft Wireless
    Mouse
    Logitech wireless
    Internet Speed
    Cable - 100MB Downlink
    Browser
    Edge/Firefox
    Antivirus
    Microsoft
    Other Info
    Sonar Platinum 64 bit recording studio software with MOTU 896Mk3 Hybrid recording interface unit.

Conco

New Member
Posts
1
#8
Hi guys,


I'm having a little problem with my onboard audio, having just installed Windows 8.1 (clean install). I have an Asus P8Z77-V LE PLUS motherboard, which includes a "Realtek® ALC889 8-Channel High Definition Audio CODEC" onboard.
I have installed the latest realtek drivers; R2.73 from the official website.


Now, here's my problem: when I was using Windows 7 on this same machine, I could plug headphones in the front panel connector, as well as speakers in the green back panel connector. This would give me two audio outputs in the device manager/sound list, which was pretty practical and enabled me to output different applications through the speakers or the headphones.


Now, however, there's only one output, irrelevant of whether or not I have two outputs plugged in at the same time. They appear in the device manager as a single device called "speakers" (see picture). Instead of both having separate outputs, they both output exactly the same audio.

View attachment 34160


Any solution to this?
Just out of curiosity was this ever solved? I had a similar situation today with the same setup and it was driving me mad to fix. I have connected headphones and computer speakers and was able to finally get them to play at the same time. Although I am not sure if it will help you since I had several 'playback' devices to play around with. My solution to get them both playing on headset and computer speakers was to click on the 'recording' tab and click on 'stereo mix' device and click properties and under the 'listen' tab you should see see a bunch of options. Just look at my screenshot on the far right and see if you can duplicate what I did. Hope this helps! Where it says 'playback through this device' select your headphones.
 

Attachments

My Computer

System One

  • OS
    8.1
    Motherboard
    P5W DH Deluxe
    Memory
    8GB
    Graphics Card(s)
    GeForce 8800 GT

lewisww

New Member
Posts
1
#9
No way that I've ever found. You can have "Analog" (Speakers) or "Digital" but not both. Internal routing of the audio is different depending on which is selected.
I had the same problem, just made an account to tell you guys how I fixed it. Clicked on the COGS similar to your screenshot and then went to 'Connector Settings' and selected "AC97 front panel". Now its playing from both headphones and speakers.
 

My Computer

System One

  • OS
    Windows 8

jasonperns

New Member
Posts
1
#10
I messed around with this for a couple of minutes and found out how to fix it. See Below.

1) go to device advanced settings, then click option


2) Under Playback Devise click "make frond and rear output devices playback two different audio streams simultaneously.
Under Recording device click: Seperate all input jacks as independent input devices



After you've done this, the headphones and speakers will show up as independent devices.
Jason
 

Attachments

My Computer

System One

  • OS
    Windows 8.1

Quilua

New Member
Posts
2
#11
I know this is an old topic but... There's a way to change my Manager to that version in black? Mine has none of this options, would could be useful on my problem (Windows 10)
This is my manager and I'm having no sound at all in my speakers

(Also, sorry for my english, I'm brazilian)
 

Attachments

My Computer

System One

  • OS
    Windows 10
    Computer type
    PC/Desktop
    Browser
    Chrome

erpster4

Member
Member
Posts
145
#12
I know this is an old topic but... There's a way to change my Manager to that version in black? Mine has none of this options, would could be useful on my problem (Windows 10)
This is my manager and I'm having no sound at all in my speakers

(Also, sorry for my english, I'm brazilian)
what computer do you have, Quilua? use either HWInfo or Speccy to gather more specs of your computer and fill in the specs here in this forum.
jasonperns computer is an ASUS computer which uses a different interface for Realtek HD Audio Manager - I get something like that only when using an ASUS motherboard or laptop.

it does not matter what "interface" you have as long as you have the "Device Advanced Settings" option in the top right hand corner of the Realtek HD Audio Manager

here's what I have on my old HP pavilion m8417c computer with Realtek HD Audio Manager using Realtek ALC888S:

realtek-audio-manager-classic-advancedsettings.png
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satellite C55Dt-A5306
    CPU
    AMD Quad-Core A6-5200M Accelerated Processor
    Memory
    4 GB

Quilua

New Member
Posts
2
#13
what computer do you have, Quilua? use either HWInfo or Speccy to gather more specs of your computer and fill in the specs here in this forum.
jasonperns computer is an ASUS computer which uses a different interface for Realtek HD Audio Manager - I get something like that only when using an ASUS motherboard or laptop.

it does not matter what "interface" you have as long as you have the "Device Advanced Settings" option in the top right hand corner of the Realtek HD Audio Manager

here's what I have on my old HP pavilion m8417c computer with Realtek HD Audio Manager using Realtek ALC888S:

View attachment 71541
I downloaded Speccy and here is what it shows. My version didn't have the Device Advanced Settings at first, but after a feel thing I made, it did appear, although it solved nothing
 

Attachments

My Computer

System One

  • OS
    Windows 10
    Computer type
    PC/Desktop
    Browser
    Chrome
Posts
1
#14
I know this is an old topic but... There's a way to change my Manager to that version in black? Mine has none of this options, would could be useful on my problem (Windows 10)
This is my manager and I'm having no sound at all in my speakers

(Also, sorry for my english, I'm brazilian)
You have to select the option "Configurações avançadas do dispositivo" and then select the multi-stream mode. It's probably the second option.
 

My Computer

System One

  • OS
    Windows 10
    Computer type
    PC/Desktop

Users Who Are Viewing This Thread (Users: 0, Guests: 1)