• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Razer Megalodon - (Device Descriptor Request Failed)


Posts
2
#1
Hello Ladies & Gents.

I would like to ask for your assistance on this slightly annoying problem.

I have 1 pair of Razer Megalodon USB headphones, on the start up of Windows 8.1 these headphones are not detected correctly. The only proof I have of this is in the device manager displays:

Universal Serial Bus Controllers -
Unknown USB Device (Device Descriptor Request Failed).

(Please see attached screenshots)

Once the device is disconnected and reconnected device manager then displays:

Universal Serial Bus Controllers -
USB Composite Device

The device then shows in "Audio inputs and outputs"

Cheers,

Mr Collective

View attachment 38815
 

Attachments

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel(R) Core(TM) i5-3570k CPU @ 4.4GHz
    Motherboard
    Asus P8Z77
    Memory
    Partriot Intel Extreme Masters 8GB
    Graphics Card(s)
    2 x Nvidia GeForce 650 TI Boost SLI
    Browser
    FireFox
    Antivirus
    AVG
Posts
1,883
#2
Razer is well known for BSOD drivers and problems, otherwise. (And taking very old drivers, changing nothing at all, giving it a new date and then claiming "Compatible!" with new OS.)

Perhaps give a shot with uninstalling their software, rebooting, the re-installing.

Make sure using the latest.

When all is said and done, you might just have to live with it.

Can't hurt to make sure chipset drivers are up to date. If Intel chipset, search their driver site for "Inf"
 

My Computer

System One

  • OS
    7601.18247.x86fre.win7sp1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Self-built Intel based
    CPU
    Pentium D 925 3.0 GHz socket 775, Presler @ ~ 3.2 GHz
    Motherboard
    Intel DQ965MT
    Memory
    Hyundai 2 GB DDR2 @ 333 MHz
    Graphics Card(s)
    ASUS DirectCU II HD7790-DC2OC-2GD5 Radeon HD 7790 2GB 128-Bit GDDR5
    Sound Card
    MOTU Traveler firewire interface
    Hard Drives
    1 Seagate Barracuda SATA II system/boot drive 80 GB, 2 Western Digital hdds - 1 is SATA II Caviar Black 1 TB attached to card (assorted media, page, temp), other is SATA I 420 GB (games, media, downloads)
    PSU
    Thermaltake 450W
    Cooling
    stock Gateway cooling, extra large fan in rear of case
    Keyboard
    Alienware/Microsoft Internet kb
    Mouse
    Logitech M510
    Internet Speed
    Optimum Online, fast for US
    Browser
    Pale Moon
    Antivirus
    Kaspersky integrated into ZoneAlarm+Antivirus
Posts
2
#3
--------------------------------
:warn: I will update this post with any specific answer I get relating to this issue for others.
--------------------------------

Unfortunately they don't have an updated Firmware driver above 2012 for the Razer Megalodons.

I'm currently in a very slow responsive email conversation with Razer relating to this issue.

I have attempted all of the above numerous time.

Doesn't work on any 8 or 8.1 OS
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel(R) Core(TM) i5-3570k CPU @ 4.4GHz
    Motherboard
    Asus P8Z77
    Memory
    Partriot Intel Extreme Masters 8GB
    Graphics Card(s)
    2 x Nvidia GeForce 650 TI Boost SLI
    Browser
    FireFox
    Antivirus
    AVG