• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Question about IE 11 in Windows 8.1


LittleJay

New Member
Power User
Posts
1,338
#1
Since running the update for Windows 8.1 there have been certain websites, like the various search engines, Google, Bing, etc. that cause IE 11 to lock up every time I try to use them with Protected Mode running. When I turn off Protected Mode they work just fine. I don't recall having this problem with IE 10 and I was just wondering if that is normal for IE 11, or if it is a glitch with the web browser itself.
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    CyberPower
    CPU
    i5 2500K
    Motherboard
    Asus P8P67 Deluxe
    Memory
    8 gigabytes Corsair PC3-12800 DDR3
    Graphics Card(s)
    EVGA GeForce GTX 460 superclocked
    Sound Card
    Integrated
    Monitor(s) Displays
    Viewsonic 23" LCD
    Screen Resolution
    1920 x 1080
    Hard Drives
    128 Gb Samsung 840 Pro SSD
    128 Gb Kingston Hyper X SSD
    1 Tb Western Digital Caviar Black HDD
    PSU
    1000 watt Coolermaster modular
    Case
    Coolermaster Haf X full tower
    Cooling
    Coolermaster Hyper 212 plus
    Keyboard
    Logitech
    Mouse
    Logitec M310 USB cordless
    Internet Speed
    1.5 mb/s download 300 kb/s upload

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#2

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

LittleJay

New Member
Power User
Posts
1,338
#3
Thank you for your quick reply my2cents! Unfortunately unchecking "use Microsoft compatabilty lists" didn't seem to help, but I appreciate the help.
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    CyberPower
    CPU
    i5 2500K
    Motherboard
    Asus P8P67 Deluxe
    Memory
    8 gigabytes Corsair PC3-12800 DDR3
    Graphics Card(s)
    EVGA GeForce GTX 460 superclocked
    Sound Card
    Integrated
    Monitor(s) Displays
    Viewsonic 23" LCD
    Screen Resolution
    1920 x 1080
    Hard Drives
    128 Gb Samsung 840 Pro SSD
    128 Gb Kingston Hyper X SSD
    1 Tb Western Digital Caviar Black HDD
    PSU
    1000 watt Coolermaster modular
    Case
    Coolermaster Haf X full tower
    Cooling
    Coolermaster Hyper 212 plus
    Keyboard
    Logitech
    Mouse
    Logitec M310 USB cordless
    Internet Speed
    1.5 mb/s download 300 kb/s upload

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#4

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

Dutto11

New Member
Posts
7
#5
Hi All,
This is my first post so please bear with me.
I'm having issues with IE11 that I keep getting a message that says "Cannot Display this Page".
I have read a lot of things about how to fix this but it just keeps reappearing. It is very annoying to say the least as
I do all the refreshing and resetting as per all the things I have read and it still happens.
Can anyone tell a more permanent fix (if there is one that is).
Cheers
Gary

 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    Tablet
    System Manufacturer/Model Number
    Acer

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#6
Hi All,
This is my first post so please bear with me.
I'm having issues with IE11 that I keep getting a message that says "Cannot Display this Page".
I have read a lot of things about how to fix this but it just keeps reappearing. It is very annoying to say the least as
I do all the refreshing and resetting as per all the things I have read and it still happens.
Can anyone tell a more permanent fix (if there is one that is).
Cheers
Gary

You would be better off starting a new thread for your own issue so all responses can target your specific issue.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11