• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Professional and Core editions of Windows 8 both on the RP setup iso


fafhrd

Active Member
Pro User
Portsmouth Hants

Posts
772
#1
I just ran the imagex /info command on the install.wim image in the RP iso, and there are two images - one for the Professional edition and one for the Core edition:

Code:
Microsoft Windows [Version 6.2.8400](c) 2012 Microsoft Corporation. All rights reserved.


C:\windows\system32>imagex /info h:\install.wim


ImageX Tool for Windows
Copyright (C) Microsoft Corp. All rights reserved.
Version: 6.1.7600.16385


WIM Information:
----------------
Path:        h:\install.wim
GUID:        {fcb0f643-393c-49be-9ec4-73b366c9d278}
Image Count: 2
Compression: LZX
Part Number: 1/1
Attributes:  0xc
             Integrity info
             Relative path junction




Available Image Choices:
------------------------
<WIM>
  <TOTALBYTES>2180842704</TOTALBYTES>
[COLOR=#008000]  <IMAGE INDEX="1">[/COLOR]
[COLOR=#008000]    <DIRCOUNT>28840</DIRCOUNT>[/COLOR]
[COLOR=#008000]    <FILECOUNT>89990</FILECOUNT>[/COLOR]
[COLOR=#008000]    <TOTALBYTES>8500198783</TOTALBYTES>[/COLOR]
[COLOR=#008000]    <HARDLINKBYTES>3292079743</HARDLINKBYTES>[/COLOR]
[COLOR=#008000]    <CREATIONTIME>[/COLOR]
[COLOR=#008000]      <HIGHPART>0x01CD3599</HIGHPART>[/COLOR]
[COLOR=#008000]      <LOWPART>0xAB80C848</LOWPART>[/COLOR]
[COLOR=#008000]    </CREATIONTIME>[/COLOR]
[COLOR=#008000]    <LASTMODIFICATIONTIME>[/COLOR]
[COLOR=#008000]      <HIGHPART>0x01CD3599</HIGHPART>[/COLOR]
[COLOR=#008000]      <LOWPART>0xC512D846</LOWPART>[/COLOR]
[COLOR=#008000]    </LASTMODIFICATIONTIME>[/COLOR]
[COLOR=#008000]    <WINDOWS>[/COLOR]
[COLOR=#008000]      <ARCH>0</ARCH>[/COLOR]
[COLOR=#008000]      <PRODUCTNAME>Microsoft® Windows® Operating System</PRODUCTNAME>[/COLOR]
[COLOR=#ff0000]      <EDITIONID>Professional</EDITIONID>[/COLOR]
[COLOR=#008000]      <INSTALLATIONTYPE>Client</INSTALLATIONTYPE>[/COLOR]
[COLOR=#008000]      <SERVICINGDATA>[/COLOR]
[COLOR=#008000]        <PKEYCONFIGVERSION>6.2.8400.0;2012-05-18T22:00:52Z</PKEYCONFIGVERSION>[/COLOR]
[COLOR=#008000]      </SERVICINGDATA>[/COLOR]
[COLOR=#008000]      <HAL>acpiapic</HAL>[/COLOR]
[COLOR=#008000]      <PRODUCTTYPE>WinNT</PRODUCTTYPE>[/COLOR]
[COLOR=#008000]      <PRODUCTSUITE>Terminal Server</PRODUCTSUITE>[/COLOR]
[COLOR=#008000]      <LANGUAGES>[/COLOR]
[COLOR=#008000]        <LANGUAGE>en-US</LANGUAGE>[/COLOR]
[COLOR=#008000]        <DEFAULT>en-US</DEFAULT>[/COLOR]
[COLOR=#008000]      </LANGUAGES>[/COLOR]
[COLOR=#008000]      <VERSION>[/COLOR]
[COLOR=#008000]        <MAJOR>6</MAJOR>[/COLOR]
[COLOR=#008000]        <MINOR>2</MINOR>[/COLOR]
[COLOR=#008000]        <BUILD>8400</BUILD>[/COLOR]
[COLOR=#008000]        <SPBUILD>0</SPBUILD>[/COLOR]
[COLOR=#008000]        <SPLEVEL>0</SPLEVEL>[/COLOR]
[COLOR=#008000]      </VERSION>[/COLOR]
[COLOR=#008000]      <SYSTEMROOT>WINDOWS</SYSTEMROOT>[/COLOR]
[COLOR=#008000]    </WINDOWS>[/COLOR]
[COLOR=#008000]    <NAME>Windows 8 Release Preview</NAME>[/COLOR]
[COLOR=#008000]    <DESCRIPTION>Windows 8 Release Preview</DESCRIPTION>[/COLOR]
[COLOR=#008000]    <FLAGS>Professional</FLAGS>[/COLOR]
[COLOR=#008000]    <DISPLAYNAME>Windows 8 Release Preview</DISPLAYNAME>[/COLOR]
[COLOR=#008000]    <DISPLAYDESCRIPTION>Windows 8 Release Preview</DISPLAYDESCRIPTION>[/COLOR]
[COLOR=#008000]  </IMAGE>[/COLOR]
[COLOR=#0000ff]  <IMAGE INDEX="2">[/COLOR]
[COLOR=#0000ff]    <DIRCOUNT>28762</DIRCOUNT>[/COLOR]
[COLOR=#0000ff]    <FILECOUNT>89429</FILECOUNT>[/COLOR]
[COLOR=#0000ff]    <TOTALBYTES>8451956574</TOTALBYTES>[/COLOR]
[COLOR=#0000ff]    <HARDLINKBYTES>3261422192</HARDLINKBYTES>[/COLOR]
[COLOR=#0000ff]    <CREATIONTIME>[/COLOR]
[COLOR=#0000ff]      <HIGHPART>0x01CD359A</HIGHPART>[/COLOR]
[COLOR=#0000ff]      <LOWPART>0x723CC7A5</LOWPART>[/COLOR]
[COLOR=#0000ff]    </CREATIONTIME>[/COLOR]
[COLOR=#0000ff]    <LASTMODIFICATIONTIME>[/COLOR]
[COLOR=#0000ff]      <HIGHPART>0x01CD359A</HIGHPART>[/COLOR]
[COLOR=#0000ff]      <LOWPART>0x8334FC26</LOWPART>[/COLOR]
[COLOR=#0000ff]    </LASTMODIFICATIONTIME>[/COLOR]
[COLOR=#0000ff]    <WINDOWS>[/COLOR]
[COLOR=#0000ff]      <ARCH>0</ARCH>[/COLOR]
[COLOR=#0000ff]      <PRODUCTNAME>Microsoft® Windows® Operating System</PRODUCTNAME>[/COLOR]
[COLOR=#ff0000]      <EDITIONID>Core</EDITIONID>[/COLOR]
[COLOR=#0000ff]      <INSTALLATIONTYPE>Client</INSTALLATIONTYPE>[/COLOR]
[COLOR=#0000ff]      <SERVICINGDATA>[/COLOR]
[COLOR=#0000ff]        <PKEYCONFIGVERSION>6.2.8400.0;2012-05-18T22:01:35Z</PKEYCONFIGVERSION>[/COLOR]
[COLOR=#0000ff]      </SERVICINGDATA>[/COLOR]
[COLOR=#0000ff]      <HAL>acpiapic</HAL>[/COLOR]
[COLOR=#0000ff]      <PRODUCTTYPE>WinNT</PRODUCTTYPE>[/COLOR]
[COLOR=#0000ff]      <PRODUCTSUITE>Terminal Server</PRODUCTSUITE>[/COLOR]
[COLOR=#0000ff]      <LANGUAGES>[/COLOR]
[COLOR=#0000ff]        <LANGUAGE>en-US</LANGUAGE>[/COLOR]
[COLOR=#0000ff]        <DEFAULT>en-US</DEFAULT>[/COLOR]
[COLOR=#0000ff]      </LANGUAGES>[/COLOR]
[COLOR=#0000ff]      <VERSION>[/COLOR]
[COLOR=#0000ff]        <MAJOR>6</MAJOR>[/COLOR]
[COLOR=#0000ff]        <MINOR>2</MINOR>[/COLOR]
[COLOR=#0000ff]        <BUILD>8400</BUILD>[/COLOR]
[COLOR=#0000ff]        <SPBUILD>0</SPBUILD>[/COLOR]
[COLOR=#0000ff]        <SPLEVEL>0</SPLEVEL>[/COLOR]
[COLOR=#0000ff]      </VERSION>[/COLOR]
[COLOR=#0000ff]      <SYSTEMROOT>WINDOWS</SYSTEMROOT>[/COLOR]
[COLOR=#0000ff]    </WINDOWS>[/COLOR]
[COLOR=#0000ff]    <NAME>Windows 8</NAME>[/COLOR]
[COLOR=#0000ff]    <DESCRIPTION>Windows 8</DESCRIPTION>[/COLOR]
[COLOR=#0000ff]    <FLAGS>Core</FLAGS>[/COLOR]
[COLOR=#0000ff]    <DISPLAYNAME>Windows 8</DISPLAYNAME>[/COLOR]
[COLOR=#0000ff]    <DISPLAYDESCRIPTION>Windows 8</DISPLAYDESCRIPTION>[/COLOR]
[COLOR=#0000ff]  </IMAGE>[/COLOR]
</WIM>
Core edition is the likely version that will appear on OEM machines, equivalent to "Starter" or "Home Basic" in earlier Windows releases.

There are no .clg files to enable the setup or install executables to allow a choice of edition to install

However, if anyone wants to install it, the imagex command would be:

imagex /apply D:\sources\install.wim 2 T:

where D: is the drive where the setup disk Windows8-ReleasePreview-32bit-English.iso is mounted, and T: is the target drive where you want to install the Core edition to.

Who'll be first to test-drive it?
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1

SIW2

Well-Known Member
Team Member
Posts
5,360
#2
Yes, I know, I installed image 2 first of all.

I don't know if there is a product key to activate it tho.

You can just use it as a trial.

It looks pretty much the same - it wouldn't let me install media centre - not because it was the wrong edition - but because it wasn't activated.

I installed it by applying the wim - like I always install.

However, you don't need to do it that way.

If you just boot the dvd - then enter the default core edition product key - it will install

2H7NK-3VJJY-HHY3Y-WM3T8-JFCRY

Or you can put an ei.cfg file in - but it's hardly worth the bother.
 

My Computer

System One

  • OS
    7/8/ubuntu/Linux Deepin
    Computer type
    PC/Desktop

fafhrd

Active Member
Pro User
Portsmouth Hants

Posts
772
#3
Since I have not used the DVD setup, only imagex, I did not realise there was an option to install the Core edition in setup. Thanks for that information.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1

jeffrys

Power User
Power User
BELGIUM

Posts
503
#4
well I tried just now, but sill Imagex is not recognized , although WAIK is installed

sorry

Jeff
 

My Computer

System One

  • OS
    WINDOWS 8.1 x64
    Computer type
    PC/Desktop
    CPU
    INTEL CORE I--3770K LGA1155
    Motherboard
    ASUS P8Z77-V
    Memory
    KINGSTON 2400 MHZ KHX24C11K4 16GB
    Graphics Card(s)
    INTEL HD GRAFICS 4000
    Monitor(s) Displays
    Philip BDL3245€ 32 inch
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SAMSUNG 840 PRO RAID 0 ON BOARD 2 x 128 GB
    Keyboard
    LOGITEC MX™ 5500
    Mouse
    LOGITEC MX 5500
    Internet Speed
    120 Mbps

fafhrd

Active Member
Pro User
Portsmouth Hants

Posts
772
#5
well I tried just now, but sill Imagex is not recognized , although WAIK is installed

sorry

Jeff
I think this was a crossposting, so I have answered it where it should have been - in your thread - no probs

Best of luck.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1

fafhrd

Active Member
Pro User
Portsmouth Hants

Posts
772
#6
Well I've now set up Core and Professional :

Screenshot (1).png Screenshot (13).png one difference so far - Professional never even asked to be activated, but Core has difficulties:

Screenshot (2).png the product id I gave (2H7NK-3VJJY-HHY3Y-WM3T8-JFCRY) in the install seems to have been blocked by the activation server.

I used slmgr /ipk -successful then slmgr /ato gave the error 0xC004C003

Screenshot (3).png

Any ideas anyone? - or am I going to start using some of those 1000 rearms I have left?
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1

SIW2

Well-Known Member
Team Member
Posts
5,360
#7
Yes, that is just the default key which gives the 30 day trial.

I haven't found a key to activete the core edition - I don't know if MS are giving them out for the core edition - except perhaps to oem's.

Perhaps they aren't even doing that - could be why there are so many rearms.
 

My Computer

System One

  • OS
    7/8/ubuntu/Linux Deepin
    Computer type
    PC/Desktop

SIW2

Well-Known Member
Team Member
Posts
5,360
#8
Have you started mucking with pe yet?

Can't get sound to work - bit annoying
 

My Computer

System One

  • OS
    7/8/ubuntu/Linux Deepin
    Computer type
    PC/Desktop

fafhrd

Active Member
Pro User
Portsmouth Hants

Posts
772
#10
Well I am intrigued, Fercian - It worked fine - thanks - should I ask the origin of the PK?

Screenshot (8).png
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1

fafhrd

Active Member
Pro User
Portsmouth Hants

Posts
772
#13
Now here's a question - now that I have the Core Edition running, can I use the setup .iso to upgrade to Professional? Presumably users with OEM installations of Core Ed. could purchase a Professional license and upgrade.

I know it's an odd question since I could have used Professional in the first place - it's just a chance to recreate the user experience.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1

NiFu

New Member
Power User
Posts
160
#14
now that I have the Core Edition running, can I use the setup .iso to upgrade to Professional?
  • No need for an iso
  • No need for an internet connection
Enter professional key by "add features" and professional features will be installed. All components of all versions are always available in "C:\Windows\winsxs" - they only need to unlock by the right key.
 

My Computer

System One

  • OS
    Windows 8

fafhrd

Active Member
Pro User
Portsmouth Hants

Posts
772
#15
Yep, did it weeks ago, after confirming that you could not upgrade Core to MCE directly, but first have to use "add features" to U/G to Professional, and only then will the MCE product key work.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1