• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

"Pressing the Power button" defaulting to sleep


Posts
1
#1
Hey guys.
I'm new, So i'm not sure if this would go under general, or if it's even a windows 8 problem in the first place.
But anyway, here's what's been happening.
I currently have a Windows 8 64-bit Dell Inspiron 15, 3000 Series.
Every time I press the power button when the computer is on, It goes to sleep instead of turning off.
So, I hit (windows key)+x and I click control panel.
I search up "power" and click "Change what the Power buttons do.
I change "sleep" to "shut down" for "pressing the power button".
I then click Save changes.
And it works. At least, for a few days.
I just changed it to shut down yesterday, and today it's already been reset to sleep.
This in't anything really something so big that I can't use the computer anymore, but it's pretty annoying having to reset the settings every few days.

Any help on what is causing this or how to fix this would be much appreciated.
Thanks!
 

My Computer

System One

  • OS
    Windows 8

TechnoMage

Active Member
Power User
Central Florida

Posts
389
#2
Hmmmm!
If you're using the power button to shut down your computer, that's a HUGE Operational ERROR.
Don't do that!

Use the correct "Shutdown" procedure or you can really screw things up in the PC's registry.
The registry resided in RAM when you're running your PC and is only saved back to the hard drive when the PC does a proper shutdown.
If the PC is crashed after you make setting changes, all those settings will be lost. That may even be the cause of your problem.

I understand, that if you're NOT using the Classic Shell, doing a correct Shutdown can be a
real pain in the *ss! Regardless of the OS I'm using (and right now I AM using Windows 8.1 Pro)
I always use a desktop or Taskbar shortcut to the Windows Shutdown.exe program.

Just create a desktop Shortcut with the following syntax.
%windir%\System32\shutdown.exe /s /t 1

You might want to just copy and paste the blue line into a desktop shortcut, because
every space is important.
I use that same shortcut on Windows 7, 8.1 and 10. My current desktop PC, (homebrew with an SSD)
will shut down in just five seconds when I use my Quick Shutdown shortcut, as shown above.

As to why your settings keep changing, I have only one CLUE, and I mentioned that above.
I have five laptops and none of them ever do that.
So if it can't be fixed, at least now you have a way around it. Eh?

Good Luck, and Happy Holidays!
TechnoMage :cool:
 

My Computer

System One

  • OS
    Win-8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Gigabyte
    CPU
    AMD 8 Core
    Motherboard
    Gigabyte
    Memory
    PNY, 4GB
    Graphics Card(s)
    NVIDIA, GForce 210
    Monitor(s) Displays
    21" HP
    Hard Drives
    Seagate SATA III, 500GB
    PSU
    Antec Earthwatts, 650
    Case
    Pac-Man Case
    Keyboard
    HP Professional
    Mouse
    GearHead Wireless
    Internet Speed
    5 Meg
    Browser
    Firefox
    Antivirus
    AVG Free
    Other Info
    Using Classic Shell on Win-8.1 pro

Users Who Are Viewing This Thread (Users: 0, Guests: 1)