• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Ports closed; router forwarded ports, firewalls disabled?


Flower

New Member
Posts
9
#1
Hey all so I have forwarded some ports on my router with Airport Utility (NAT port forwarding), but using cmd netstat -n the ports I forwarded aren't listed and using online port checkers confirms they are closed. I added exceptions to my firewall (even though it is off), and windows defender is off, and Avast's shields are all off. I honestly have no idea how to open the ports up and haven't found a way to do this using Windows 8 (not pro).

Anybody have any ideas? It seems like Windows 8 is blocking these ports from opening for some reason. There doesn't seem to be an override function in cmd to open them, either.

In case you're wondering why I need the ports open, I'm trying to resolve a "request timeout" error when pinging somebody on Hamachi - so I'm trying to open the main ports Hamachi uses (I just want to play Terraria, man).

Any help would be greatly appreciated.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Wullail

Active Member
Pro User
Posts
467
#2
Temporarily add your PC IP into the DMZ and try again , see if the internal/external tests then notice the ports open , this will test if it's a router or PC issue....

Don't forget to take it out of the DMZ after testing...
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

Shadowjk

Network Enthusiast
VIP Member
Power User
#3
In addition, make sure that the relevant ports are open on the other side. It's a two way thing

Josh :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Built
    CPU
    Intel Core i5 2400 @ 3.10GHz
    Motherboard
    Foxconn H67MP-S/-V/H67MP (CPU 1)
    Memory
    8.0GB DDR3 @ 665MHz (2GBx4)
    Graphics Card(s)
    AMD Radeon HD 6800 Series (Sapphire/PCPartner)
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    SMB1930NW + AOC 2243W
    Screen Resolution
    1440x900 + 1920x1080
    Hard Drives
    977GB Seagate ST31000524AS ATA Device (SATA)
    250GB WD iSCSI attached drive
    PSU
    750W PSU
    Case
    Novatech Night
    Keyboard
    Dell Standard PS/2 Keyboard
    Mouse
    R.A.T 7 Gaming Mouse
    Browser
    Google Chrome
    Other Info
    Optiarc DVD RW AD-5260S ATA Device

Flower

New Member
Posts
9
#4
Hey guys thanks for the response.

The funny thing is that Hamachi was working before, but then suddenly stopped working for no apparent reason (weird). Wullail, I don't understand what you mean by putting my IP in the DMZ. From looking online it seems to be a firewall thing, if so, is it a type of inbound/outbound rule? Sorry for the trouble, I'm just not very familiar with this.

Shadowjk, good point, will check.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Wullail

Active Member
Pro User
Posts
467
#5
DMZ stands for 'demilitarized zone' , it basically removes that IP address from any form of firewalling , meaning anything can connect to it externally.

You should have an option in the router settings somewhere to add a single IP address into the DMZ , it's basically a way to make sure it's the firewall/port forwarding thats causing the issue.

If you add that IP address into the DMZ and it still doesn't work...the problem is elsewhere...
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

Flower

New Member
Posts
9
#6
Okay I managed to figure out how to set my laptop to DMZ mode on the router. And surprisingly this fix worked. So somehow forwarding ports doesn't work but enabling DMZ does? Isn't that counter intuitive?
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Wullail

Active Member
Pro User
Posts
467
#7
OK , that points to the fact that either the firewall settings on the router are blocking the incoming/outgoing connection or not all the needed ports to run the game are being forwarded.

Does your router firewall settings include 'flood protection' as an option? , I found that some games sent a lot of small packets very quickly when trying to connect and this caused the router to block them.

I turned off flood protection here and it fixed the games I was having problems with.
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

Shadowjk

Network Enthusiast
VIP Member
Power User
#9
Wullail is correct in that it points to ports on your side. Just a question, are you using a static IP address on your machine for the port forwarding? Most port forwarding requires it to be forward to a static IP address because of how NAT works.

If you don't know please upload your ipconfig/all and we will be able to see if you have or not and if not possibly suggest a static address stack to use

Josh :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Built
    CPU
    Intel Core i5 2400 @ 3.10GHz
    Motherboard
    Foxconn H67MP-S/-V/H67MP (CPU 1)
    Memory
    8.0GB DDR3 @ 665MHz (2GBx4)
    Graphics Card(s)
    AMD Radeon HD 6800 Series (Sapphire/PCPartner)
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    SMB1930NW + AOC 2243W
    Screen Resolution
    1440x900 + 1920x1080
    Hard Drives
    977GB Seagate ST31000524AS ATA Device (SATA)
    250GB WD iSCSI attached drive
    PSU
    750W PSU
    Case
    Novatech Night
    Keyboard
    Dell Standard PS/2 Keyboard
    Mouse
    R.A.T 7 Gaming Mouse
    Browser
    Google Chrome
    Other Info
    Optiarc DVD RW AD-5260S ATA Device

XweAponX

New Member
VIP Member
Pro User
#10
I have the same issue with Port 8080 on my machine which I was forwarding for Open Hardware Monitor Web Server. I installed it on my 2nd machine with a different port, and it fouled up port 8080. My Web server is running, but port 8080 is blocked solid.

I'll try some of the things mentioned in here, but my Router is whack, it's a Linksys WRT110. I tried re-creating all of the forwarding, but that didn't help.
[FONT=Arial, Helvetica, sans-serif]
WRT
[/FONT]
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.

Flower

New Member
Posts
9
#11
boo router boo

Actually... Something really annoying happened. I had disabled the DMZ yesterday and then re-enabled it today but it didn't work today. I think the trouble is that my NAT must have reset my IP address, so I did ipconfig /all, and got my iPv4 address (Preferred- that word appeared for some reason) and put that in, but it still doesn't work. WTF. This is so despair-inducing. Why can't this stupid router open the ports I want?

To set up DMZ my router (I hate it so much, it's an Apple Airport my mother bought years ago) you basically have to put the local NAT address in to allow DMZ at that address. Yesterday I just had 10.0.1.25 and it worked fine, but it didn't work today so I tried the number (1) on the ipconfig image I have attached. The number (2) marks an address I tried to put in but came back as an invalid address for some reason. And neither of those options work even though I'm technically putting the right IP in... At least, I thought I was. But there is no other address with the 10.0.1.xx configuration to try!

/commits suicide

Actually I should answer some of the other questions. Sorry for the delay. There isn't a firewall option on my router to disable flood filtering. As per the non static IP, the DHCP IPs are set to reset every 24 hours so it doesn't look like a statis IP is set up. If I'm looking at the right thing. Derrp feel like such a noob. Several people connect to this wireless network, btw.

It might also be worth mentioning that I can connect to several games online with no problem (e.g. Dark Souls, League of Legends, other MMOs) but it's just Terraria that doesn't work and requires Hamachi to work so that's why I'm trying to get Hamachi to work...

EDIT: Attached another ipconfig screenshot because on the first I accidentally merged the Ethernet Adapter and Hamachi Adapter sections so parts from both are missing.
 

Attachments

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Shadowjk

Network Enthusiast
VIP Member
Power User
#12
Is there a specific reason to using hamachi? It can cause a host of problems...

Are you hosting the server or running it as a peer to peer style system that is restricted to the LAN? If you are hosting a public server then all you need is to forward the ports as needed. Does the hamachi connection succeed?

The hamachi adapter uses both an IPv6 and IPv4 address. What was the address that you entered before that allowed it to work?

My apologies for the questions, I am trying to determine if there issue is with hamachi or if there is an issue with the addressing used in the DMZ section.

Many Thanks,
Josh
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Built
    CPU
    Intel Core i5 2400 @ 3.10GHz
    Motherboard
    Foxconn H67MP-S/-V/H67MP (CPU 1)
    Memory
    8.0GB DDR3 @ 665MHz (2GBx4)
    Graphics Card(s)
    AMD Radeon HD 6800 Series (Sapphire/PCPartner)
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    SMB1930NW + AOC 2243W
    Screen Resolution
    1440x900 + 1920x1080
    Hard Drives
    977GB Seagate ST31000524AS ATA Device (SATA)
    250GB WD iSCSI attached drive
    PSU
    750W PSU
    Case
    Novatech Night
    Keyboard
    Dell Standard PS/2 Keyboard
    Mouse
    R.A.T 7 Gaming Mouse
    Browser
    Google Chrome
    Other Info
    Optiarc DVD RW AD-5260S ATA Device

Flower

New Member
Posts
9
#13
Hamachi works well (or better than anything else). I tried Tunngle but had issues getting that to work as well. Hamachi seems to have the higher success. I am joining the server on Hamachi and Terraria. My partner (who I am trying to connect to) hosted a server on Terraria but I had trouble connecting to that as wel, even without Hamachi installedl. We have managed to play together in the past and each time it's been an issue on my end preventing us from connecting with Hamachi.

We use iPv4 addresses for connecting, so I assume putting my iPv4 address into the NAT default host (DMZ) is correct. I did on online test awhile ago and the result was iPv4 was used for visiting websites most frequently and was the preferred protocol to use.

I suspect a static IP issue so I might have a look at that later. Still, other suggestions are welcome - particularly why putting my iPv4 address into the router didn't work... because that was strange.

Thank you everyone for your help thus far. Much appreciated.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Shadowjk

Network Enthusiast
VIP Member
Power User
#14
What IP address did you put in the DMZ that worked? You have multiple addresses

Josh
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Built
    CPU
    Intel Core i5 2400 @ 3.10GHz
    Motherboard
    Foxconn H67MP-S/-V/H67MP (CPU 1)
    Memory
    8.0GB DDR3 @ 665MHz (2GBx4)
    Graphics Card(s)
    AMD Radeon HD 6800 Series (Sapphire/PCPartner)
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    SMB1930NW + AOC 2243W
    Screen Resolution
    1440x900 + 1920x1080
    Hard Drives
    977GB Seagate ST31000524AS ATA Device (SATA)
    250GB WD iSCSI attached drive
    PSU
    750W PSU
    Case
    Novatech Night
    Keyboard
    Dell Standard PS/2 Keyboard
    Mouse
    R.A.T 7 Gaming Mouse
    Browser
    Google Chrome
    Other Info
    Optiarc DVD RW AD-5260S ATA Device

Flower

New Member
Posts
9
#15
I put in the one ending in 11 in. The DMZ set up for my router only accepts IP addresses starting with 10.0.1.xx so I used 10.0.1.11
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Shadowjk

Network Enthusiast
VIP Member
Power User
#16
I put in the one ending in 11 in. The DMZ set up for my router only accepts IP addresses starting with 10.0.1.xx so I used 10.0.1.11
I have a feeling that this may be the issue, Hamachi is reporting to be using the public IP address of 25.24.233.184. This might be blocked by the firewall unless granted access.

Follow this tutorial on STEPs 1-3 ONLY - http://www.eightforums.com/tutorials/29241-ip-address-enable-alternate-configuration.html

When you get to the IPv4 properties box for your wireless NIC (If you wish to connect using wireless), enter the following address:

IP address: 10.0.1.11

Subnet Mask: 255.255.255.0

Default Gateway: 10.0.1.1

DNS server: 10.0.1.1

In the DMZ box enter the IP address '10.0.1.11'. Apply and then reboot the router and computer. Try connection to the server without using hamachi. What are the results?

Josh :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Built
    CPU
    Intel Core i5 2400 @ 3.10GHz
    Motherboard
    Foxconn H67MP-S/-V/H67MP (CPU 1)
    Memory
    8.0GB DDR3 @ 665MHz (2GBx4)
    Graphics Card(s)
    AMD Radeon HD 6800 Series (Sapphire/PCPartner)
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    SMB1930NW + AOC 2243W
    Screen Resolution
    1440x900 + 1920x1080
    Hard Drives
    977GB Seagate ST31000524AS ATA Device (SATA)
    250GB WD iSCSI attached drive
    PSU
    750W PSU
    Case
    Novatech Night
    Keyboard
    Dell Standard PS/2 Keyboard
    Mouse
    R.A.T 7 Gaming Mouse
    Browser
    Google Chrome
    Other Info
    Optiarc DVD RW AD-5260S ATA Device

Flower

New Member
Posts
9
#17
Hey guys sorry for the delay, I got pretty busy but only tried fixing this yesterday. I discovered that reinstalling Hamachi helped fix the problem with DMZ set up under the same address. Not sure why Hamachi keeps pooping itself but whatever.

Shadowjk, thanks for the info. I didn't try that since reinstalling Hamachi seemed to work but if it decides to poop itself again I will give that method a try.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

Shadowjk

Network Enthusiast
VIP Member
Power User
#18
Hamachi was the most likely cause because of the IP address differences. I am glad you found a suitable solution however please do not hesitate to post back should the issue reoccur!

Josh :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit ; Windows Server 2012 R2 Standard
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Built
    CPU
    Intel Core i5 2400 @ 3.10GHz
    Motherboard
    Foxconn H67MP-S/-V/H67MP (CPU 1)
    Memory
    8.0GB DDR3 @ 665MHz (2GBx4)
    Graphics Card(s)
    AMD Radeon HD 6800 Series (Sapphire/PCPartner)
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    SMB1930NW + AOC 2243W
    Screen Resolution
    1440x900 + 1920x1080
    Hard Drives
    977GB Seagate ST31000524AS ATA Device (SATA)
    250GB WD iSCSI attached drive
    PSU
    750W PSU
    Case
    Novatech Night
    Keyboard
    Dell Standard PS/2 Keyboard
    Mouse
    R.A.T 7 Gaming Mouse
    Browser
    Google Chrome
    Other Info
    Optiarc DVD RW AD-5260S ATA Device